Bug 192770 - tar produces verbose output, even when verbose is not specified
tar produces verbose output, even when verbose is not specified
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tar (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
: 205877 (view as bug list)
Depends On:
Blocks: FAST4.5APPROVED
  Show dependency treegraph
 
Reported: 2006-05-22 16:34 EDT by Jim Perrin
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0662
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 00:31:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (544 bytes, patch)
2006-05-23 05:02 EDT, Peter Vrabec
no flags Details | Diff
patch of the previous patch (510 bytes, patch)
2006-05-23 20:15 EDT, Jim Perrin
no flags Details | Diff

  None (edit)
Description Jim Perrin 2006-05-22 16:34:01 EDT
Description of problem:
tar produces verbose output, even when -v is not specified.

Version-Release number of selected component (if applicable):
RHEL 4 fastrack channel tar, version tar-1.14-10.RHEL4

How reproducible:
Always

Steps to Reproduce:
1. install tar
2. Run a tar backup command like -> tar --newer=./backup.timestamp  -czf
./foo.tar.gz . 
3. Note that unchanged files are also listed in the output, with "file is
unchanged; not dumped"
4. This extra output was not in previous versions of tar before this one.


  
Actual results:
All files are listed in tar output, even unchanged files. 

Expected results:
Only changed files should produce output unless -v is specified.

Additional info:

Email communication with Sergey Poznyakoff (tar developer) confirms that this 
'feature' of tar was added, then reverted because of its annoyance. It should
now only be available with -v or --verbose.
 
Email communication with sergey copied below  
 
> A while back, someone posted a bug / feature request for version 1.15.1 to
> disable the "file is unchanged; not dumped" messages that occur when doing a
> backup with --newer, or a switch to revert to the old behavior.
 
Recent versions print this message only if given the  -v (--verbose)
option.
 
Regards,
Sergey 


This added output was not in previous versions of tar released in RHEL, nor is
it produced by current vanilla tar source (version 1.15.90). This addded output
is far from desirable and increases the size of backup logs from 3-4K daily to
375K daily.
Comment 1 Peter Vrabec 2006-05-23 05:02:55 EDT
Created attachment 129846 [details]
proposed patch
Comment 2 Jim Perrin 2006-05-23 20:15:38 EDT
Created attachment 129894 [details]
patch of the previous patch

the previous patch seemed to be made from an attempted patch, and not the tar
source. This one should apply cleanly.
Comment 13 Peter Vrabec 2006-09-10 05:26:37 EDT
*** Bug 205877 has been marked as a duplicate of this bug. ***
Comment 14 Red Hat Bugzilla 2006-09-14 00:31:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0662.html

Note You need to log in before you can comment on or make changes to this bug.