Bug 205877 - tar switches to verbose output when used with --newer option
tar switches to verbose output when used with --newer option
Status: CLOSED DUPLICATE of bug 192770
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: tar (Show other bugs)
4.4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-09 07:02 EDT by Ingimar Robertsson
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 05:26:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar 1.14-9 to 1.14-10 diff (4.76 KB, text/plain)
2006-09-09 07:02 EDT, Ingimar Robertsson
no flags Details

  None (edit)
Description Ingimar Robertsson 2006-09-09 07:02:29 EDT
Description of problem:

After upgrade from RHEL4u3 to RHEL4u4 tar started to spew out verbose messages
about unchanged files when used with the --newer option even though the -v
verbose option is not used.  This seems to be caused by the upgrade from
tar-1.14-9 to tar-1.14-10 since the older tar did not behave like this.

Version-Release number of selected component (if applicable):

tar-1.14-10


How reproducible:

[root@srvr ]# mkdir demo
[root@srvr ]# cd demo/
[root@srvr demo]# touch file1
[root@srvr demo]# touch file2
[root@srvr demo]# touch file4
[root@srvr demo]# touch timemarker
[root@srvr demo]# touch file5 
[root@srvr demo]# tar cf allfiles.tar file*
[root@srvr demo]# tar tvf allfiles.tar 
-rw-r--r-- root/root         0 2006-09-09 10:38:05 file1
-rw-r--r-- root/root         0 2006-09-09 10:38:07 file2
-rw-r--r-- root/root         0 2006-09-09 10:38:11 file4
-rw-r--r-- root/root         0 2006-09-09 10:38:27 file5
[root@srvr demo]# tar cf newerthantimemarker.tar --newer="`date -r timemarker`"
file*
tar: file1: file is unchanged; not dumped
tar: file2: file is unchanged; not dumped
tar: file4: file is unchanged; not dumped
[root@srvr demo]# tar tvf newerthantimemarker.tar 
-rw-r--r-- root/root         0 2006-09-09 10:38:27 file5
[root@srvr demo]# 

Steps to Reproduce:

See above
  
Actual results / Expected results:

The "tar: file1: file is unchanged; not dumped" messages should only be
displayed when the -v (verbose) option is used with tar.

Additional info:

According to the following web pages this seems to be an old bug that resurfaced
in the tar-1.14-9 to tar-1.14-10 upgrade.
http://lists.gnu.org/archive/html/bug-tar/2005-03/msg00001.html
http://groups.google.is/group/linux.debian.bugs.dist/browse_thread/thread/ee0595e2a5f4631a/56a7419b18f9b6a2%2356a7419b18f9b6a2

Attached is a diff of tar-1.14-9 and tar-1.14.10.  (src packages patched with
rpmbuild -bp).  The diff seems to point to that the bug is similar to the one
mentioned in the above urls.
Comment 1 Ingimar Robertsson 2006-09-09 07:02:29 EDT
Created attachment 135901 [details]
tar 1.14-9 to 1.14-10 diff
Comment 2 Peter Vrabec 2006-09-10 05:26:25 EDT

*** This bug has been marked as a duplicate of 192770 ***

Note You need to log in before you can comment on or make changes to this bug.