Bug 1928050 - python-pytest-cases: FTBFS in Fedora rawhide
Summary: python-pytest-cases: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pytest-cases
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zbigniew Jędrzejewski-Szmek
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1969109 (view as bug list)
Depends On:
Blocks: PYTHON3.10 F35FTBFS F35FailsToInstall 1968911 1969109
TreeView+ depends on / blocked
 
Reported: 2021-02-12 09:29 UTC by Tomáš Hrnčiar
Modified: 2021-06-08 21:58 UTC (History)
3 users (show)

Fixed In Version: python-pytest-cases-3.6.1-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-08 21:58:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-02-12 09:29:10 UTC
Description of problem:
Package python-pytest-cases fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
1.11.1-5.fc34

Steps to Reproduce:
koji build --scratch f34 python-pytest-cases-1.11.1-5.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-pytest-cases

_________ ERROR collecting pytest_cases/tests/advanced/test_memoize.py _________
/usr/lib/python3.9/site-packages/pluggy/hooks.py:286: in __call__
    return self._hookexec(self, self.get_hookimpls(), kwargs)
/usr/lib/python3.9/site-packages/pluggy/manager.py:93: in _hookexec
    return self._inner_hookexec(hook, methods, kwargs)
/usr/lib/python3.9/site-packages/pluggy/manager.py:84: in <lambda>
    self._inner_hookexec = lambda hook, methods, kwargs: hook.multicall(
/usr/lib/python3.9/site-packages/_pytest/python.py:249: in pytest_pycollect_makeitem
    res = list(collector._genfunctions(name, obj))
/usr/lib/python3.9/site-packages/_pytest/python.py:458: in _genfunctions
    definition = FunctionDefinition.from_parent(self, name=name, callobj=funcobj)
/usr/lib/python3.9/site-packages/_pytest/python.py:1619: in from_parent
    return super().from_parent(parent=parent, **kw)
/usr/lib/python3.9/site-packages/_pytest/nodes.py:190: in from_parent
    return cls._create(parent=parent, **kw)
/usr/lib/python3.9/site-packages/_pytest/nodes.py:94: in _create
    return super().__call__(*k, **kw)
/usr/lib/python3.9/site-packages/_pytest/python.py:1609: in __init__
    fixtureinfo = self.session._fixturemanager.getfixtureinfo(
/usr/lib/python3.9/site-packages/_pytest/fixtures.py:1464: in getfixtureinfo
    initialnames, names_closure, arg2fixturedefs = fm.getfixtureclosure(
pytest_cases/plugin.py:499: in getfixtureclosure
    merge(sorted_fixturenames, _init_fixnames)
pytest_cases/plugin.py:461: in merge
    into_list.append(l)
E   AttributeError: 'generator' object has no attribute 'append'

Comment 2 Miro Hrončok 2021-06-04 20:13:09 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 3 Miro Hrončok 2021-06-07 22:58:01 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 4 Miro Hrončok 2021-06-08 11:31:30 UTC
*** Bug 1969109 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.