Bug 193037 - New 1.4.0-4 release doesn't play .flac files any more
Summary: New 1.4.0-4 release doesn't play .flac files any more
Status: CLOSED DUPLICATE of bug 192802
Alias: None
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Aurelien Bompard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-24 19:17 UTC by Quentin Spencer
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-24 22:32:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Quentin Spencer 2006-05-24 19:17:03 UTC
Description of problem:
After updating to the new 1.4.0 release, it won't play flac files.

Version-Release number of selected component (if applicable):
1.4.0-4.fc5

How reproducible:
Always

Steps to Reproduce:
1.Start Amarok
2.Try to load a .flac file
  
Actual results:
"These media could not be loaded into the playlist:"

Expected results:
Load and play the file

Additional info:
When amarok started, there was a message about the player switching to a new
streaming engine or something. This probably has something to do with that.
However, it needs to support all the file formats that were previously
supported. If there's a different plugin available that will loaded to load
.flac files, it should be a dependency so it is installed automatically when
amarok is upgraded.

Comment 1 Aurelien Bompard 2006-05-24 22:32:04 UTC
The flac format was supported by the gstreamer engine, which is not included in
amarok 1.4 final (developer's decision). The Helix engine is still available,
unfortunately it does not support flac yet.

One of the solutions would be to install the xine engine, which can not be
distributed by Fedora for software patents reasons. But you can find it in
another repository if you don't live in a country which recognizes software patents.

*** This bug has been marked as a duplicate of 192802 ***


Note You need to log in before you can comment on or make changes to this bug.