Bug 193076 - FC5 creates garbage DVDs
FC5 creates garbage DVDs
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On: 193095
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-24 19:22 EDT by Dimitris
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 08:49:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2006-05-24 19:22:35 EDT
Description of problem:

I'm using FC5 with all the latest updates. Unfortunately when i burn a DVD all i
end up with is a disk that contains garbage.


Version-Release number of selected component (if applicable):

mkisofs-2.01.01.0.a03-3
cdrecord-2.01.01.0.a03-3


How reproducible:

always


Steps to Reproduce:
1) load Places->CD/DVD Creator
2) drag&drop some files (total 4gigs)
3) click on Write to Disc
4) select File Image, to create just the image first
5) click on Write to create the image


Actual results:

now, lets test the image...

#mount /tmp/image.iso /mnt/image -t iso9660 -o loop

as a result, we'll be able to browse the image we created under /mnt/image/.

so it worked under the loop device in linux... so now lets burn it...

#cdrecord -v -dao -eject driveropts=burnfree speed=48 dev=2,0,0 "image.iso"

the above command burns the image at my Plextor PX-716 (external USB2 dvd
writer), once that is done, we take the ejected DVD and insert it again on the
same drive or into another drive.

guess what... the DVD is unreadable, it contains garbage...

so what is this about? FC5 generates an image thats usable under the mount loop
device but it burns garbage?


Expected results:

the dvd should be readable.


Additional info:

Here is the cdrecord output.

# cdrecord -v -dao -eject driveropts=burnfree speed=48 dev=2,0,0 "image.iso"
Cdrecord-Clone 2.01.01a03-dvd (x86_64-unknown-linux-gnu) Copyright (C) 1995-2005
Jörg Schilling
NOTE: This version contains the OSS DVD extensions for cdrtools and thus may
      have bugs related to DVD issues that are not present in the original
      cdrtools. Please send bug reports or support requests to
      http://bugzilla.redhat.com/bugzilla The original cdrtools author should
      not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
scsidev: '2,0,0'
scsibus: 2 target: 0 lun: 0
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.85-RH '@ (#)scsi-linux-sg.c      1.85 05/05/16 Copyright
1997 J. Schilling').
Driveropts: 'burnfree'
SCSI buffer size: 64512
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 1
Vendor_info    : 'PLEXTOR '
Identifikation : 'DVDR   PX-716A  '
Revision       : '1.09'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Current: 0x001B
Profile: 0x002B
Profile: 0x001B (current)
Profile: 0x001A
Profile: 0x0015
Profile: 0x0014
Profile: 0x0013
Profile: 0x0011
Profile: 0x0010
Profile: 0x000A
Profile: 0x0009
Profile: 0x0008
cdrecord: Found DVD media: using cdr_mdvd.
Using Session At Once (SAO) for DVD mode.
Using Session At Once (SAO) for DVD mode.
Using Session At Once (SAO) for DVD mode.
Using generic SCSI-3/mmc DVD-R(W) driver (mmc_mdvd).
Driver flags   : SWABAUDIO BURNFREE
Supported modes: PACKET SAO
Drive buf size : 6291456 = 6144 KB
Drive DMA Speed: 12035 kB/s 68x CD 8x DVD
FIFO size      : 4194304 = 4096 KB
Track 01: data  4482 MB
Total size:     5147 MB (509:59.53) = 2294965 sectors
Lout start:     5148 MB (510:01/40) = 2294965 sectors
Current Secsize: 2048
  ATIP start of lead in:  -150 (00:00/00)
  ATIP start of lead out: 157789 (35:05/64)
Disk type:    unknown dye (reserved id code)
Manuf. index: -1
Manufacturer: unknown (not in table)
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 139
scsi_set_streaming
Speed set to 5540 KB/s
Starting to write CD/DVD at speed   4.0 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
BURN-Free is OFF.
cdrecord: Turning BURN-Free on
Performing OPC...
Sending CUE sheet...
cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Starting new track at sector: 0
Track 01: 4482 of 4482 MB written (fifo 100%) [buf  98%]  36.7x.
Track 01: Total bytes read/written: 4700088320/4700088320 (2294965 sectors).
Writing  time:  869.507s
Average write speed  36.1x.
Min drive buffer fill was 97%
Fixating...
Fixating time:    3.853s
Last selected write speed: 31x
Max media write speed:     62x
Last actual write speed:   31x
cdrecord: fifo had 74032 puts and 74032 gets.
cdrecord: fifo was 0 times empty and 33352 times full, min fill was 65%.
#
Comment 1 Dimitris 2006-05-25 07:44:26 EDT
I believe i found what the problem/bug is.

Apparently, cdrecord shouldn't allow me to use -dao to burn DVDs.

Instead it should force me to use SAO only, since DAO burns garbage.

Since you are using 1 year old version of cdrecord, i downloaded the unmodified
cdrecord which was released 15 May 2006. I tested with the same commandline and
this newer version didn't allow me to burn with DAO, instead it complained that
i should use PACKET or SAO when burning DVDs.
Comment 2 Dimitris 2006-05-25 09:23:25 EDT
Well, apparently the cdrecord that comes with FC5 is broken.

It ALWAYS burns garbage.

I can't understand why people haven't reported this before, maybe its related to
Plextor dvd recorders.

The same commandline for FC5's cdrecord burns fine when used with the original
cdrecord. Any try to burn a DVD with the FC5 cdrecord results in a bad disk with
garbage on it (DVD is just unreadable).

Comment 3 Harald Hoyer 2006-05-29 08:28:43 EDT
It is related to Plextor drives... use growisofs...
Comment 4 Dimitris 2006-05-29 08:55:52 EDT
Well, apparently the cdrecord version included in FC5 is 1 year old!

I've opened a separate bug and requested the latest version of cdrecord to be
included, which also fixes all the Plextor related garbage that i've reported in
this bug, this growisofs isn't needed.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.