Bug 193095 - cdrecord version too old (1 year old!)
cdrecord version too old (1 year old!)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
http://debburn.alioth.debian.org/
:
Depends On:
Blocks: 193076
  Show dependency treegraph
 
Reported: 2006-05-25 04:48 EDT by Dimitris
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-09 14:28:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris 2006-05-25 04:48:47 EDT
Description of problem:

The FC5 cdrecord version is 2.01.01a03-dvd, which is about a year old. Currently
the latest cdrecord version is a09, released on the 15th of May 2006.

I also believe that the latest cdrecord version also contains Open Source
released DVD code which wasn't previously available.


Version-Release number of selected component (if applicable):

cdrecord-2.01.01.0.a03-3


How reproducible:

always


Steps to Reproduce:
N/A

  
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2006-05-29 08:27:34 EDT
The new versions have a new license, which has to be checked yet by legal.
Comment 2 Harald Hoyer 2006-05-29 08:47:11 EDT
ok... nothing really important changed anyway...
Comment 3 Harald Hoyer 2006-05-29 08:48:30 EDT
regarding the license, I mean. The DVD source is well... not enough. We had
patched previous versions with: http://crashrecovery.org/oss-dvd.html
Comment 4 Dimitris 2006-05-29 08:58:27 EDT
Why isn't it enough? I've had success with the new cdrecord burning various DVDs
(DVD+R and DVD-R).
Comment 6 Harald Hoyer 2006-06-14 08:16:58 EDT
------- Additional Comments From sehh@altered.com  2006-06-09 05:41 EST -------
Downloaded and installed the test RPM. Here is the difference:


# cdrecord --scanbus
Cdrecord-ProDVD-Clone 2.01.01a10 (cpu-pc-linux-gnu) Copyright (C) 1995-2006 J�rg
Schilling
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red
Hat-scsi-linux-sg.c-1.86-RH '@(#)scsi-linux-sg.c  1.86 05/11/22 Copyright 1997
J. Schilling').
scsibus3:
        3,0,0   300) 'PLEXTOR ' 'DVDR   PX-716A  ' '1.09' Removable CD-ROM
        3,1,0   301) *
        3,2,0   302) *
        3,3,0   303) *
        3,4,0   304) *
        3,5,0   305) *
        3,6,0   306) *
        3,7,0   307) *



# ./cdrecord-alpha --scanbus
Cdrecord-ProDVD-Clone 2.01.01a09 (x86_64-unknown-linux-gnu) Copyright (C)
1995-2006 J�rg Schilling
./cdrecord-alpha: Warning: Running on Linux-2.6.16-1.2111_FC5
./cdrecord-alpha: There are unsettled issues with Linux-2.5 and newer.
./cdrecord-alpha: If you have unexpected problems, please try Linux-2.4 or Solaris.
Linux sg driver version: 3.5.33
Using libscg version 'schily-0.8'.
scsibus0:
        0,0,0     0) 'ATA     ' 'ST380817AS      ' '3.42' Disk
        0,1,0     1) *
        0,2,0     2) *
        0,3,0     3) *
        0,4,0     4) *
        0,5,0     5) *
        0,6,0     6) *
        0,7,0     7) *
scsibus1:
        1,0,0   100) 'ATA     ' 'Maxtor 6Y080M0  ' 'YAR5' Disk
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
scsibus3:
        3,0,0   300) 'PLEXTOR ' 'DVDR   PX-716A  ' '1.09' Removable CD-ROM
        3,1,0   301) *
        3,2,0   302) *
        3,3,0   303) *
        3,4,0   304) *
        3,5,0   305) *
        3,6,0   306) *
        3,7,0   307) *

I'll create a few DVDs and report my results.

Comment 7 Dimitris 2006-06-14 08:21:05 EDT
I burned a few DVDs without problem. Its definetly working... unlike the
original version that came with FC5.
Comment 8 Marcin Garski 2006-09-04 06:48:25 EDT
There is a fork of cdrtools (named cdrkit):
http://lxer.com/module/newswire/view/68828/index.html
Project has been forked because of a new license, cdrkit is fully on GPL.
Time to switch?
Comment 9 Rahul Sundaram 2006-09-09 14:28:34 EDT
We will evaluate switching to a fork after FC6 release. The current cdrecord in
the development release is the latest one without the CDDL/GPL incompatibilies.
Closing this. 

Note You need to log in before you can comment on or make changes to this bug.