Bug 193175 - prelink changes symlinks of binaries
prelink changes symlinks of binaries
Status: CLOSED DUPLICATE of bug 188062
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-25 17:05 EDT by Christian Krause
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 06:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2006-05-25 17:05:37 EDT
Description of problem:
After running of /etc/cron.daily/prelink at least one symlink in /usr/bin (in my
case pnmdepth) is changed to to content of the file to which it pointed to.

Version-Release number of selected component (if applicable):
prelink-0.3.6-3

How reproducible:
- running /etc/cron.daily/prelink or just prelink
- please note, that this problem does not occur on all machines, but if it
occurs on one, it will happen every time
  
Actual results:
symlink pnmdepth is removed, instead there is a new file with the content of
pamdepth (target of the previous symlink)

Expected results:
prelink should not alter any symlinks 

Additional info:

root@:~# ls -l /usr/bin/*depth*
-rwxr-xr-x 1 root root 5768 Apr 14 13:51 /usr/bin/pamdepth
lrwxrwxrwx 1 root root    8 May 25 17:03 /usr/bin/pnmdepth -> pamdepth
root@:~# /etc/cron.daily/prelink 
root@:~# ls -l /usr/bin/*depth*
-rwxr-xr-x 2 root root 7696 Apr 14 13:51 /usr/bin/pamdepth
-rwxr-xr-x 2 root root 7696 Apr 14 13:51 /usr/bin/pnmdepth
root@:~# 

/var/log/prelink.log:
...
Prelinking /usr/bin/pnmdepth
Linking /usr/bin/pamdepth to /usr/bin/pnmdepth
/usr/sbin/prelink: /usr/bin/pamdepth is no longer hardlink to /usr/bin/pnmdepth
...

Some days ago I've filed a bug on this issue for netpbm-progs:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=192623

I'm not sure whether this is a problem of prelink, netpbm-progs, both or a
packaging problem. Nevertheless I was surprised that a program just alters some
files in /usr/bin ...
Comment 1 Jakub Jelinek 2006-05-26 06:17:16 EDT

*** This bug has been marked as a duplicate of 188062 ***

Note You need to log in before you can comment on or make changes to this bug.