Bug 193243 - Install Everything gone, devel packages missing
Install Everything gone, devel packages missing
Status: CLOSED DUPLICATE of bug 186007
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-26 11:11 EDT by Andreas M. Kirchwitz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 12:20:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas M. Kirchwitz 2006-05-26 11:11:51 EDT
Description of problem:

There's already been a lot of discussion about the missing
choices for "Minimum Package Selection" and "Install Everything"
during the installation process of Fedora Core 5.

Personally, I liked the "Install Everything" because it saved me
a lot of time. Well, I really miss some packages which could
have been installed without known conflicts (like iptables-ipv6,
ncompress, perl-suidperl, procinfo, sharutils, tcl/tk, usbutils,
xscreensaver-*).

I never expected "Everything" to actually install every single
package but the maximum of packages of the Core distribution that
can be installed without conflicts.

However, that's not the reason for this ticket.

During installation of Fedora Core 5, now I go through the
"dumb" (sorry), time-consuming and error-prone process of selecting
all packages of every sub-category and then all sub-packages of that
sub-category (right mouse button helps, but a "Select All" checkbox
whould be handy).

Although some packages cannot be selected here (like the ones stated
above), this process is somewhat misleading because it doesn't include
the *-devel packages for quite some of packages. For example,
"glib" is installed, but not "glib-devel", "gtk+" is included but
not "gtk+-devel". Similar for "gnome-libs-devel", "imlib-devel",
"ImageMagick-devel" and others).

I'm sure that most people won't notice the missing *-devel packages
because they don't compile any software themselves. But I do, and then
it's often confusing to analyze software why it fails to compile.
For example, the software finds the library of a package, but not the
header files (includes) or the usual *-config tools.

Even if I select everything that can be selecting during the installation
of Fedora Core 5, the system ends up with a number of incomplete packages
where only one "half" of them is installed. What's "wrong" with installing
the devel package along with every selected main package?

Isn't the current practice one step too far? I would have expected this
from a typical end-user distribution like "Ubuntu", but Fedora has always
been a distribution for end-users *and* programmers/developers.

Usually, the *-devel packages don't consume much space and don't
do any harm to the system. My suggestion is that all packages
should be installed with their according *-devel packages, if
it's obvious that the user might need them (for example, if the
user has selected most/all of the development packages like
compilers and stuff).

Version-Release number of selected component (if applicable):


How reproducible:

Always.

Steps to Reproduce:
1. Install FC5 from CD/DVD or over network.
2. Enable everything possible in the package selection.
3. After installation, check what actually gets installed.
  
Actual results:

Although if everything that can be selected is selected
during the installation process, packages are missing
that could/should be included.

Besides that, the package selection process is a little bit
annoying if you want to install the maximum number of packages
that can be selected.

Expected results:

If it's obvious that the devel packages might be needed,
all selected packages should have their devel package included
(and everything else that is required to compile/develop).

A global "Select All" checkbox would be nice as a shortcut to
select all packages that can be selected. (To save time and to
avoid errors.)

Additional info:

This topic came up recently on the fedora mailing list again.
And people from RedHat/Fedora project said it's important to
not just complain on the list but also open a bug report or
a feature request. Something that can be counted. Even if this
ticket goes to CLOSED/NOTABUG immediately, hopefully someone
keeps in mind that not all Fedora users are completely happy
with the current package selection process. There might be good
reasons that it changed with FC5. I don't vote for the "Everything"
button here (I respect that you don't want it). I just want to say,
that the current package selection process could be improved.
Comment 1 Paul Nasrat 2006-05-26 12:20:46 EDT

*** This bug has been marked as a duplicate of 186007 ***

Note You need to log in before you can comment on or make changes to this bug.