Bug 19325 - rmt does not work with solarus ufsdump as client
Summary: rmt does not work with solarus ufsdump as client
Status: CLOSED DUPLICATE of bug 20926
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-18 17:28 UTC by ivan
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-01 15:02:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ivan 2000-10-18 17:28:56 UTC
When trying to backup to a DLT drive on a RedHat Linux 6.2 machine (x86),
from a Solaris (7) 
machine using ufsdump, I get the following error:

$ ufsdump -0uf admin2:/dev/nst0 /
  DUMP: Writing 32 Kilobyte records
  DUMP: Date of this level 0 dump: Wed Oct 18 17:43:38 2000
  DUMP: Date of last level 0 dump: the epoch
  DUMP: Dumping /dev/rdsk/c0t0d0s0 (web-1:/) to admin2:/dev/nst0.
  DUMP: Mapping (Pass I) [regular files]
  DUMP: Mapping (Pass II) [directories]
  DUMP: Estimated 3934176 blocks (1920.98MB).
  DUMP: rmtstatus: expected response size 24, got 28
  DUMP: This means the remote rmt daemon is not compatible.
  DUMP: Lost connection to remote host.
  DUMP: Bad return code from dump: 1

To me, this points to a compatability problem between Solaris and Linux
(for rmt). FWIW, there 
was a bug logged in FreeBSD, with the same problem. See:
http://www.FreeBSD.org/cgi/getmsg.cgi?fetch=108594+116864+/usr/local/www/db/text+/2000/freebsd-hackers/20000220.freebsd-hackers

(Solaris is obviously a pretty major player, and not being able to backup
from Solaris to Linux 
is a bit of a downer).

P.S. There doesn't seem to be an "rmt" package mentioned in this bugzilla,
so I had to specify it as the "dump" component :(

Comment 1 Jeff Johnson 2000-11-26 15:43:12 UTC

*** This bug has been marked as a duplicate of 20926 ***


Note You need to log in before you can comment on or make changes to this bug.