Bug 1932754 - X.org Utility Deaggregation - xorg-x11-server-utils
Summary: X.org Utility Deaggregation - xorg-x11-server-utils
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server-utils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1932760 1933574 1934358 1934365 1934382 1934383 1934384 1934385 1934386 1934387 1934389 1934390 1934391 1934392 1934393 1934394 1934395 1934396 1936697 1947238
Blocks: 1867220
TreeView+ depends on / blocked
 
Reported: 2021-02-25 07:07 UTC by Peter Hutterer
Modified: 2021-04-23 02:02 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1932731
: 1933574 (view as bug list)
Environment:
Last Closed: 2021-04-23 02:02:40 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Peter Hutterer 2021-02-25 07:07:58 UTC
This is a tracking bug for Change: X.org Utility Deaggregation
For more details, see: https://fedoraproject.org/wiki/Changes/XorgUtilityDeaggregation

This is the tracker bug for the xorg-x11-server-utils subpackages.

Comment 1 Zbigniew Jędrzejewski-Szmek 2021-03-05 17:43:59 UTC
Installing dependencies:
 iceauth                  x86_64 1.0.8-1.fc34                      updates-testing        26 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 sessreg                  x86_64 1.1.2-1.fc34                      updates-testing        17 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xgamma                   x86_64 1.0.6-1.fc34                      updates-testing        16 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xhost                    x86_64 1.0.7-1.fc34                      updates-testing        19 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xinput                   x86_64 1.6.3-1.fc34                      updates-testing        36 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xkill                    x86_64 1.0.5-1.fc34                      updates-testing        17 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xmodmap                  x86_64 1.0.9-1.fc34                      updates-testing        30 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xrandr                   x86_64 1.5.1-1.fc34                      updates-testing        45 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xrdb                     x86_64 1.1.1-1.fc34                      updates-testing        28 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xrefresh                 x86_64 1.0.6-1.fc34                      updates-testing        16 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xset                     x86_64 1.2.4-1.fc34                      updates-testing        27 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xsetroot                 x86_64 1.1.2-1.fc34                      updates-testing        19 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34
 xstdcmap                 x86_64 1.0.4-1.fc34                      updates-testing        17 k
     replacing  xorg-x11-server-utils.x86_64 7.7-38.fc34

Comment 2 Kevin Fenzi 2021-03-05 19:40:05 UTC
Hi there. This has broken rawhide composes. ;) 

lorax tries to install xorg-x11-server-utils and fails. ;( 

DEBUG util.py:446:  template command error in runtime-install.tmpl:
DEBUG util.py:446:  2021-03-05 05:48:39,056:   installpkg xorg-x11-server-utils xorg-x11-xauth
DEBUG util.py:446:    installpkg xorg-x11-server-utils xorg-x11-xauth
DEBUG util.py:446:  2021-03-05 05:48:39,057:   Exception: Required installpkg failed.
DEBUG util.py:446:    Exception: Required installpkg failed.
DEBUG util.py:446:  Traceback (most recent call last):
DEBUG util.py:446:    File "/usr/sbin/lorax", line 223, in <module>
DEBUG util.py:446:      main()
DEBUG util.py:446:    File "/usr/sbin/lorax", line 204, in main
DEBUG util.py:446:      lorax.run(dnfbase, opts.product, opts.version, opts.release,
DEBUG util.py:446:    File "/usr/lib/python3.9/site-packages/pylorax/__init__.py", line 271, in run
DEBUG util.py:446:      rb.install()
DEBUG util.py:446:    File "/usr/lib/python3.9/site-packages/pylorax/treebuilder.py", line 136, in install
DEBUG util.py:446:      self._runner.run("runtime-install.tmpl")
DEBUG util.py:446:    File "/usr/lib/python3.9/site-packages/pylorax/ltmpl.py", line 149, in run
DEBUG util.py:446:      self._run(commands)
DEBUG util.py:446:    File "/usr/lib/python3.9/site-packages/pylorax/ltmpl.py", line 168, in _run
DEBUG util.py:446:      f(*args)
DEBUG util.py:446:    File "/usr/lib/python3.9/site-packages/pylorax/ltmpl.py", line 603, in installpkg
DEBUG util.py:446:      raise Exception("Required installpkg failed.")
DEBUG util.py:446:  Exception: Required installpkg failed.

So, we need a new lorax with this adjusted. It's not clear to me what packages out of there it needs however?

Comment 3 Kevin Fenzi 2021-03-05 19:43:53 UTC
Also filed https://github.com/weldr/lorax/issues/1117 so we can perhaps discuss there.

Comment 4 Peter Hutterer 2021-03-08 07:05:19 UTC
doh, that one escaped my grep through the specfiles, apologies. What do you want to do for F34 here? I'm not 100% if this needs a F34 update but if it does I can add it to the bodhi update to go out as one bunch?

Comment 5 Kevin Fenzi 2021-03-08 18:13:55 UTC
Yes, lorax in f34 will also need a change for this. :) 
If you want to do the downstream lorax change for now and add it to your update that would be great. 

Then we can make the upstream one and the next lorax release should be happy...

Comment 6 Peter Hutterer 2021-03-08 23:25:13 UTC
Done and tracked in Bug 1936697 now to make things easier to follow (or less so, whichever applies ;)

Comment 7 Carlos 2021-04-01 19:50:34 UTC
I can´t upgrade to f34 due to conflicting files between packages. xorg-x11-server-utils seems to still provide the binaries for each utility. So as a result there is a conflict between the new packages and the old one.

Error: Error de prueba de transacción:
  conflicto del archivo /usr/bin/iceauth entre instalaciones intentadas de xorg-x11-server-utils-7.7-39.fc34.x86_64 y iceauth-1.0.8-1.fc34.x86_64
  conflicto del archivo /usr/bin/xhost entre instalaciones intentadas de xorg-x11-server-utils-7.7-39.fc34.x86_64 y xhost-1.0.7-1.fc34.x86_64
  conflicto del archivo /usr/bin/xmodmap entre instalaciones intentadas de xorg-x11-server-utils-7.7-39.fc34.x86_64 y xmodmap-1.0.9-1.fc34.x86_64
  conflicto del archivo /usr/bin/xrandr entre instalaciones intentadas de xorg-x11-server-utils-7.7-39.fc34.x86_64 y xrandr-1.5.1-1.fc34.x86_64
  conflicto del archivo /usr/bin/xrdb entre instalaciones intentadas de xorg-x11-server-utils-7.7-39.fc34.x86_64 y xrdb-1.1.1-1.fc34.x86_64
  conflicto del archivo /usr/share/man/man1/xrandr.1.gz entre instalaciones intentadas de xorg-x11-server-utils-7.7-39.fc34.x86_64 y xrandr-1.5.1-1.fc34.x86_64
  conflicto del archivo /usr/bin/sessreg entre instalaciones intentadas de sessreg-1.1.2-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/share/man/man1/sessreg.1.gz entre instalaciones intentadas de sessreg-1.1.2-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xgamma entre instalaciones intentadas de xgamma-1.0.6-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xinput entre instalaciones intentadas de xinput-1.6.3-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xkill entre instalaciones intentadas de xkill-1.0.5-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xrefresh entre instalaciones intentadas de xrefresh-1.0.6-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xset entre instalaciones intentadas de xset-1.2.4-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xsetroot entre instalaciones intentadas de xsetroot-1.1.2-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/bin/xstdcmap entre instalaciones intentadas de xstdcmap-1.0.4-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64
  conflicto del archivo /usr/share/man/man1/xstdcmap.1.gz entre instalaciones intentadas de xstdcmap-1.0.4-1.fc34.x86_64 y xorg-x11-server-utils-7.7-39.fc34.x86_64


I tested with updates-testing enabled

Comment 8 Serge Matveenko 2021-04-07 14:12:47 UTC
Attempting to install groups "Xfce Desktop" or "Xfce" after "Fedora Workstation " results in the conflict as well. 

```
Error: Transaction test error:
  file /usr/bin/sessreg from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package sessreg-1.1.2-1.fc34.x86_64
  file /usr/share/man/man1/sessreg.1.gz from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package sessreg-1.1.2-1.fc34.x86_64
  file /usr/bin/xgamma from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xgamma-1.0.6-1.fc34.x86_64
  file /usr/bin/xhost from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xhost-1.0.7-1.fc34.x86_64
  file /usr/bin/xinput from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xinput-1.6.3-1.fc34.x86_64
  file /usr/bin/xkill from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xkill-1.0.5-1.fc34.x86_64
  file /usr/bin/xmodmap from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xmodmap-1.0.9-1.fc34.x86_64
  file /usr/bin/xrdb from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xrdb-1.1.1-1.fc34.x86_64
  file /usr/bin/xrefresh from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xrefresh-1.0.6-1.fc34.x86_64
  file /usr/bin/xsetroot from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xsetroot-1.1.2-1.fc34.x86_64
  file /usr/bin/xstdcmap from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xstdcmap-1.0.4-1.fc34.x86_64
  file /usr/share/man/man1/xstdcmap.1.gz from install of xorg-x11-server-utils-7.7-39.fc34.x86_64 conflicts with file from package xstdcmap-1.0.4-1.fc34.x86_64
```

Comment 9 Peter Hutterer 2021-04-08 00:39:18 UTC
Can I have a full dnf history log for this transaction please? I'm aware of these issues but I'm unable to reproduce them - all of the new packages have the required Obsoletes and any combination I've tried so far properly removed xorg-x11-server-utils. The issue here is that (apparently) the utils package is installed together with the new packages but again, I've been unable to reproduce this.

Comment 10 Peter Hutterer 2021-04-08 03:24:28 UTC
Ok, I found it after reproducing the opposite issue (xhost cannot be installed if xorg-x11-server-utils is installed) in a podman F34 container (after installing xorg-x11-xinit  which drags in xorg-x11-server-utils). The problem is in the Obsoletes: line of xhost (and other packages, need to go through all of them now).

xhost.spec:
  Obsoletes:  xorg-x11-server-utils <= 7.7-39

This is wrong, it only matches up to -38 because it's missing %{?dist}, so the existing 7.7-39.fc34 is not <= 7.7-39. It doesn't get obsoleted, xorg-x11-server-utils doesn't get replaced by any of the subpackages and we end up with this mess. At least one package (xisxwayland) has the correct < 7.7-40 line which obsoletes correctly.

Expect a bunch of package updates to hit the repos soon, Bug #1947238 is the one to track this issue for the server-utils package.

Comment 11 Peter Hutterer 2021-04-23 02:02:40 UTC
These are all in the F34 stable repos and in rawhide, closing.


Note You need to log in before you can comment on or make changes to this bug.