Bug 1933229 - No sound on broadwell-rt286 in kernel 5.10
Summary: No sound on broadwell-rt286 in kernel 5.10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 33
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-02-26 06:25 UTC by David Ward
Modified: 2021-03-10 00:42 UTC (History)
20 users (show)

Fixed In Version: kernel-5.10.21-100.fc32 kernel-5.10.21-200.fc33
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-10 00:25:51 UTC
Type: Bug


Attachments (Terms of Use)
alsa-info.txt with kernel 5.10.17-200.fc33.x86_64 (36.06 KB, text/plain)
2021-02-26 11:24 UTC, David Ward
no flags Details
alsa-info.txt with kernel 5.12.0-0.rc0.20210225gitc03c21ba6f4e.160.fc35.x86_64 (36.06 KB, text/plain)
2021-02-26 12:53 UTC, David Ward
no flags Details

Description David Ward 2021-02-26 06:25:36 UTC
This seems to be a repeat of bug 1750194, and likely an upstream issue again.

Fedora kernels 5.10.x are compiling with CONFIG_SND_SOC_SOF_BROADWELL=m. Looking at the package history, I'm not sure this change was intentional.

Because of this, both the modules snd_soc_sst_broadwell and snd_sof_intel_bdw are being loaded at the same on Broadwell platforms. As before, the result is no working sound. (This is happening to me on a Dell Latitude 7350 2-in-1 laptop.)


Fedora kernels 5.9.x are not affected: CONFIG_SND_SOC_SOF_BROADWELL was not set during the builds, even with CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT=y as it is now.

Comment 1 David Ward 2021-02-26 11:24:30 UTC
Created attachment 1759478 [details]
alsa-info.txt with kernel 5.10.17-200.fc33.x86_64

Comment 2 David Ward 2021-02-26 11:55:16 UTC
Apparently since kernel 5.10, snd_soc_sst_broadwell is no longer an SST driver.

In any case, there is still no sound. speaker-test is not producing anything, even when trying different devices.

This also affects Rawhide nightly builds.

Comment 4 David Ward 2021-02-26 12:53:07 UTC
Created attachment 1759483 [details]
alsa-info.txt with kernel 5.12.0-0.rc0.20210225gitc03c21ba6f4e.160.fc35.x86_64

Comment 5 David Ward 2021-02-26 13:11:32 UTC
Actually, Rawhide has a different issue, because this works on it:

speaker-test -D sysdefault:CARD=broadwellrt286


However, in Rawhide, PipeWire has replaced PulseAudio. Applications are not producing any sound; the speaker test in gnome-control-center is not producing sound either. This appears in alsa-info.txt (attachment 1759483 [details]):

> !!Sound Servers on this system
> !!----------------------------
>
> No sound servers found.
>

Comment 6 David Ward 2021-02-27 17:52:35 UTC
I examined alsa-info.sh and it isn't written to check for PipeWire (yet), which explains the message in Rawhide.


I tested issue this under Arch Linux, first when running the stock kernel 5.10.16 (with CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT=n), and then when running a rebuilt kernel (with CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT=y, but otherwise identical).  I believe I've identified the cause of the issue.  Please see this upstream bug I opened:

https://bugzilla.kernel.org/show_bug.cgi?id=211985

Comment 7 David Ward 2021-03-02 23:54:55 UTC
Upstream responded that kernel 5.10 is missing a Kconfig mutual exclusion, which should cause CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT to be unset when CONFIG_SND_SOC_INTEL_CATPT=y/m. In kernels 5.9 and earlier this happened automatically, but the introduction of the catpt sound driver led to this oversight. Fedora 33 is affected by this since both options are set in its kernel config.

A one-line code change would fix the Kconfig mutual exclusion in kernel 5.10. However this is superseded in kernel 5.11, which supports the co-existence of these two drivers and does not have this issue.


Are additional kernel 5.10.x packages for Fedora 33 expected?  If so, can CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT be temporarily unset in order to restore sound on Broadwell, and restored later for kernel 5.11?

Thanks!

Comment 8 Hans de Goede 2021-03-04 16:39:29 UTC
I'm not sure if there is going to be another 5.10.y build, but I think so.

So I've just pushed a change to unset the CONFIG_SND_SOC_SOF_BROADWELL_SUPPORT option for the 5.10.y kernels. Unfortunately I just missed the 5.10.20 kernel build which was done today. But this should be picked up by the next build.

Unless the next build is a 5.11.y build, in which case this will be resolved too :)

Comment 9 Fedora Update System 2021-03-08 14:18:51 UTC
FEDORA-2021-de87c13b55 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-de87c13b55

Comment 10 Fedora Update System 2021-03-08 21:15:42 UTC
FEDORA-2021-de87c13b55 has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-de87c13b55`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-de87c13b55

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2021-03-08 21:27:34 UTC
FEDORA-2021-a8b059afa1 has been pushed to the Fedora 32 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a8b059afa1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a8b059afa1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2021-03-10 00:25:51 UTC
FEDORA-2021-a8b059afa1 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Fedora Update System 2021-03-10 00:42:24 UTC
FEDORA-2021-de87c13b55 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.