Bug 19337 - Problem with Auto Partitioning
Problem with Auto Partitioning
Status: CLOSED DUPLICATE of bug 17085
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-10-18 16:54 EDT by Jarin Satterlee
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-10-27 17:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jarin Satterlee 2000-10-18 16:54:42 EDT
*NOTE* I didn't write this as a bug report, but it may be a bug.  I have
included a lot of information here that may seem extraneous.

I would like to share with you my recent experience installing RedHat 7.0
Deluxe.  I hope that you will take this seriously and that you will

I should first start off by saying that I have been using un*x systems for
6 years now and much of that time has been as a system administrator.  I
have installed pretty much every linux distribution there is (mainly to see
how the installation process works in the different distros) over the past
several years.  I started my journey into linux with a 68K mac running a
beta version if mklinux.  I do not consider myself in anyway to be a newbie
to linux.  I would love to get rid of my windows machine altogether (though
I would like that to be my choice, a little forshadowing...) and use only
unix based systems. I am a professional programmer and unix system
administrator, but this system I was installed was for personal use.

Now that we have that out of the way, I will get into the problems I had
with RedHat 7.0.  Aside from the obvious problems like backwards binary
compatibility, the problems I had were with the installation.  I also have
had some problems running kde programs (like kpackage) that gave me library
function mismatches and suggested relinking the libraries....

My system is a Pentium III 600mhz emachine with 128megs of ram a riva tnt2
AGP video card with 8 megs of ram and pci, isa and usb ports.  I have two
15gig maxtor drives set up in a master/slave config.  There is also a
CD-RW, DVD and floppy drives.  The master drive (hda) has 1 dos partition
and has windows on it.  The other drive has linux on it with currently 2
partitions, / and swap.

Install try #1...  The install was a custom where I chose all packages.
It installed just fine.  I used lilo on the mbr and on reboot got an L.
I tried using a boot floppy, but that resulted in a kernel panic.  I don't
really know why this would happen.  It is the same configuration that the
6.2 was using, but I wanted to do a clean install, so I did not choose the
upgrade path.  It did format the drive and required both binary cds to
install. It appeared that everything had installed, so I am not sure why
the kernel wouldn't boot under lilo or the boot diskette.

Install try #2... This was not the first time an install didn't work on
reboot on a machine I had... so I decided to just try again.  This time I
decided that I wanted to see how RedHat would partition things, so I choose
the Server install (I think) and choose to autopartition.  I started the
install and went to do something else (like I had with all other installs).
 I don't recall if I was asked for the second cd, but when the install was
done, I rebooted the machine.  It booted just fine (thought the graphical
lilo chooser thing is annoying).  When the machine came up I did a df -k
and was absolutely HORRIFIED to see that the linux partitions where on both
disks. I got a very sick feeling and knew that I was screwed.  I have two
computers; one laptop running windows and one desktop running both windows
and linux. I had a couple weeks earlier reinstalled windows on the laptop
(it was crashing a lot) and had moved all my backup files onto the desktop.
 I had not yet synced the two computers.  I also had no external media
backups of my windows machines.  So... everything was lost.  I am very
angry that I was stupid enough let your program auto partition.  I am very
angry that I was stupid enough to not have backups, I should know better
and would never let a commercial system go without backups.  I am just very
angry.  I cannot believe that the dos partition would be deleted and
formatted over.  Your documentation says nothing about that.  Your
documentation (the install booklet that came in the box) says that linux
partitions will be overwritten and that empty disk space will be
partitioned.  WHY would my dos partition be removed???

Now, I have also installed commercial unix systems like Solaris and they
have auto partitioning features, but all it does is set up suggested
partitions in the gui disk editor and the live person must then agree to
the proposed partitioning.  Why doesn't your install program do that?

I feel very foolish for trusting your installation product!!!  And for
paying $75 bucks to erase my data.

How do you respond?
Comment 1 Michael Fulbright 2000-10-19 17:30:04 EDT
Install Try #1: 

 It isn't clear to me what you are saying, so let me see if I understand. You
did a custom install,
specified that LILO should be written to the MBR and also you created a new boot
floppy when

Install Try #2:

 There is already a request for enhancement for the issue you have brought up,
bug number 17085.
Comment 2 Jarin Satterlee 2000-10-19 20:54:44 EDT
Install try #1:  Yes, I did lilo to mbr and made boot disk at the end of the
graphical installation.  On reboot I got (without the boot floppy) just an L out
of lilo.  When I tried the boot floppy it started to boot up and then got a 
kernel panic.  I didn't save the information and frankly I don't really care
about try #1. 

It is what happened in install #2 that pissed me off.  I only included the info
on the first try to illustrate what I was doing. RH7 is running just fine on the
machine now (though taking up both disks) as was RH6.2.  It was the partitioning
over and formating my primary drive that is the problem.  Thanks being such a
drone in your response to the real issue.
Comment 3 Jarin Satterlee 2000-10-19 20:56:33 EDT
BTW: I get the following results when I try to view bug 17085 that you referred

Permission denied.
Sorry; you do not have the permissions necessary to see bug 17085.
Comment 4 Michael Fulbright 2000-10-27 17:50:38 EDT
Sorry my fault the bug should be viewable now.
Comment 5 Michael Fulbright 2000-10-27 17:51:44 EDT
Ok based on your feedback I am going to mark this as a dupe of bug 17085.

Thank you for giving us your comments.

*** This bug has been marked as a duplicate of 17085 ***

Note You need to log in before you can comment on or make changes to this bug.