Bug 193460 - arts-devel should own /usr/include/kde
arts-devel should own /usr/include/kde
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: arts (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-29 03:07 EDT by Mamoru TASAKA
Modified: 2014-01-21 18:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 10:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Failure build log of xmms (63.68 KB, text/plain)
2006-05-29 03:07 EDT, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2006-05-29 03:07:43 EDT
Description of problem:
When I was glancing at buildsys.fedoraproject.org, I saw that Ville Skytta was
repeating to trying to rebuild xmms many times on i386.
So I downloaded xmms from FE-fc5 and tried to rebuild, but it failed because:

main.c:305:29: error: /usr/include/kde/artsc/artsc.h: Permission denied

This is because /usr/include/kde is not owned by any packages. 

Version-Release number of selected component (if applicable):
arts-devel-1.5.2-0.1.fc5

How reproducible:
100%

Steps to Reproduce:
1. rpmbuild --rebuild xmms-1.2.10-23.fc5.src.rpm
2.
3.
  
Actual results:
Rebuilding xmms rpms fails

Expected results:
Should succeed.

Additional info:
Comment 1 Mamoru TASAKA 2006-05-29 03:07:43 EDT
Created attachment 130169 [details]
Failure build log of xmms
Comment 2 Ville Skyttä 2006-05-29 11:24:00 EDT
That looks like a bug in arts-devel, right.

But see bug 193482 for more info about the xmms case.  I can't reproduce the
build failure (or the hang) locally, it builds just fine in mock here.  And the
problem with the xmms build is that it hangs in the i386 builder (not x86_64 or
ppc).  So I guess this is not the actual issue that makes the build hang.  Note
that the xmms one in the buildsys is a devel, not FC-5 build.
Comment 3 Ngo Than 2006-06-01 10:17:34 EDT
it's fixed in arts-1.5.3 and will be available in FC5-update soon. Thanks

Note You need to log in before you can comment on or make changes to this bug.