Bug 193473 - system-config-httpd references obsolete module names
system-config-httpd references obsolete module names
Status: CLOSED DUPLICATE of bug 180056
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
Depends On:
  Show dependency treegraph
Reported: 2006-05-29 08:50 EDT by Andrea V.
Modified: 2015-03-04 20:17 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-18 16:40:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Andrea V. 2006-05-29 08:50:46 EDT
+++ This bug was initially created as a clone of Bug #180056 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922
Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
system-config-httpd needs to be updated for compatibility with Apache 2.2 for
FC5 -- many of the LoadModules and includes in the generated httpd.conf file
fail when used with httpd-2.2.0-5.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start httpd-config-httpd on FC5T2 or later Rawhide.
2. Enter a server name and click OK (and OK on subsequent dialogs).
3. Restart Apache.

Actual Results:  Apache does not start due to errors in the configuration file.

Expected Results:  Apache should have started with the specified configuration.

Additional info:

Tested on FC5T2 and Rawhide 2006-02-04 and compared with FC4 and with the
httpd.conf supplied in the httpd- package. Sample error message when
starting Apache with a configuration file generaated by system-config-httpd:

httpd: Syntax error on line 170 of /etc/httpd/conf/httpd.conf: Cannot load
/etc/httpd/modules/mod_access.so into server: /etc/httpd/modules/mod_access.so:
cannot open shared object file: No such file or directory

-- Additional comment from chris@tylers.info on 2006-02-18 22:23 EST --
Created an attachment (id=124857)
Patch for /usr/share/system-config-httpd/httpd.conf.xsl

This patch updates the LoadModule directives in httpd.conf.xsl for
compatability with Apache 2.2 (FC5)

-- Additional comment from pknirsch@redhat.com on 2006-03-06 12:35 EST --
Thanks for the updated module list, i'll include it in the next build of s-c-h.

Read ya, Phil

-- Additional comment from mpaine@htxml.com on 2006-03-31 02:01 EST --
(In reply to comment #2)
> Thanks for the updated module list, i'll include it in the next build of s-c-
> Read ya, Phil

I ran patch /usr/share/system-config-httpd/httpd.conf.xsl attachment.cgi and I 
still receive the same error.

-- Additional comment from mpaine@htxml.com on 2006-03-31 03:51 EST --
I figured out the problem: SELinux.  I had to turn on "Allow HTTPD scripts and 
modules to connect to the network."  Is this a kludge or would this be 

-- Additional comment from pknirsch@redhat.com on 2006-04-03 11:23 EST --
Ah, thats actually expected behaviour. By default with SELinux enabled your
system won't allow CGI scripts to be executed as they might pose a security risk.

So this is the correct way to "fix" this.

Read ya, Phil

-- Additional comment from ivazquez@ivazquez.net on 2006-04-09 07:48 EST --
*** Bug 188416 has been marked as a duplicate of this bug. ***

-- Additional comment from fedora@adslpipe.co.uk on 2006-04-09 08:00 EST --
Ok, I did search for any open bugs on s-c-httpd before adding #188416, but
obviously this one had been closed, why was it closed as NOTABUG though?

-- Additional comment from denny.antonino@dalsemi.com on 2006-04-11 09:11 EST --
How exactly do I run this patch?

-- Additional comment from chris@tylers.info on 2006-04-11 09:24 EST --
Apply it with:

cd /usr/share/system-config-httpd
patch </wherever/system-config-httpd.patch

-- Additional comment from drpepperguy@gmail.com on 2006-04-16 02:53 EST --
I am new to linux and do not know how to apply this patch. I have logged into 
the gui, copied the text from the attachment for the patch and saved it as 
system-config-httpd.patch in the directory /usr/share/system-config-httpd. 

Then I followed the directions above from a shell...
"cd /usr/share/system-config-httpd
patch /usr/share/system-config-httpd/system-config-httpd.patch"
The prompt just sits there and flashes.

I re-read the instructions and then at the shell I 
typed "patch /usr/share/system-config-httpd system-config-httpd.patch" and 
this time it gave me the message "Patch unexpectedly ended in the middle of 
the patch line: *** Only garbage was found in the patch input."

I am not sure I am saving the patch like I need to. I am just copying it and 
saving it as the filename.patch. Any ideas what I am doing wrong? Any help 
would really be appreciated. Thank you. 

Kind regards, 


-- Additional comment from osvaldoasn@hotmail.com on 2006-04-19 10:44 EST --
This patch or the way to do don't works. How can i run my httpd without problems_

-- Additional comment from carlosalfaro@yahoo.com on 2006-04-25 14:05 EST --
I followed the instructions here and this is the output I get when patching the
patch system-config-httpd system-config-httpd.patch
patching file system-config-httpd
Hunk #1 FAILED at 157.
Hunk #2 FAILED at 208.
2 out of 2 hunks FAILED -- saving rejects to file system-config-httpd.rej
[root@newyork2 system-config-httpd]#

any ideas how to fix this?
Thank in advanced

-- Additional comment from djmcke@yahoo.com on 2006-04-26 07:30 EST --
Could somebody please post the entire
/usr/share/system-config-httpd/httpd.conf.xsl file.

-- Additional comment from vezza@inwind.it on 2006-05-28 14:23 EST --
It appears to me that this bug is still present into the
system-config-httpd.noarch 5:1.3.3-1.1 for distributed from the core repository
of Fedora core 5. I tried the patch and it works but I added this comment in
order to warn developers about that (I don't know if I did the right thing but
hope it is useful to someone).

Thanks... (Sorry if there is something wrong but I'm also new to linux)

Comment 1 Sander Hoentjen 2006-06-18 07:02:28 EDT
Any word on when the update will happen? This is a high severity bug (The
package is just useless the way it is now) with a trivial fix. Surely it doesn't
need to take over 4 months.

Comment 2 Andrea V. 2006-06-18 16:40:43 EDT

*** This bug has been marked as a duplicate of 180056 ***

Note You need to log in before you can comment on or make changes to this bug.