Bug 193548 - Firefox crashes within 24 hours of being launched.
Firefox crashes within 24 hours of being launched.
Status: CLOSED DUPLICATE of bug 193274
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 09:19 EDT by Chris Rankin
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-26 11:16:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rankin 2006-05-30 09:19:13 EDT
Description of problem:
Firefox crashes after less than 24 hours of use.

Version-Release number of selected component (if applicable):
1.5.0.3-1.1.fc5 (and many earlier ones)

How reproducible:
Very, given enough time.

Steps to Reproduce:
1. Launch firefox
2. Use it, with many different tabs open.
3. Eventually, when you either hit the "back" button or launch a new page,
instead of the web-page appearing within the tab it will appear within a
free-floating window. (Possibly several free-floating windows.) Closing these
windows will crash firefox completely.

Actual results:
Bang, no more firefox.

Expected results:
I expect the browser to stay running until I choose to close it.

Additional info:
The free-floating windows are still window-managed.
This problem has existed for a long time, although seems to be worse now than it
used to be.
I am using a dual-P4 machine.
Comment 1 Trevor Cordes 2006-07-10 16:53:38 EDT
I can verify this bug.  It was present in FC3 using FF1 but seemed to get a bit
better as the updates were released.  I recently switched to FC5 (fresh
wipe/install) and firefox-1.5.0.4-1.2.fc5 and the problem is now EXTREMELY BAD.
 With the amount of complicated web pages I frequent (tons of reloads) I'm
seeing this bug 2-4 times a day.  In the past I would only see it once every
couple of days.  The reporter's description is dead on: it's exactly what happens.

Also FF1.5 on FC5 feels at least 30-50% slower than FF1.0 on FC3.  Time to
upgrade my "slow" P4 2.4 w/2GB I guess.
Comment 2 Trevor Cordes 2006-07-10 16:55:13 EDT
Duplicate of bug 193274 ?
Comment 3 Marc Wiriadisastra 2006-09-27 20:31:27 EDT
I've managed to bypass it and yes it does occur in FC5.  Not really a fix but
all you do is reload the page that is supposed to have caused it.

This generally fixes it however you will need to restart firefox cause it will
occur more and more.
Comment 4 Matěj Cepl 2007-05-26 11:16:41 EDT

*** This bug has been marked as a duplicate of 193274 ***

Note You need to log in before you can comment on or make changes to this bug.