Bug 193550 - libgpg-error-devel: +Requires: pkgconfig
libgpg-error-devel: +Requires: pkgconfig
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgpg-error (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Bill Nottingham
: Reopened
: 193409 (view as bug list)
Depends On:
Blocks: BuildReqBlocker FE-BuildReq 194079
  Show dependency treegraph
 
Reported: 2006-05-30 10:11 EDT by Matt Domsch
Modified: 2014-03-16 22:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.3-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-19 16:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-05-30 10:11:25 EDT
This package fails to build in mock if the minimal build group is reduced to
only the packages listed in the Exceptions section of the packaging guidelines.

Configure step fails with:

checking for GPG Error - version >= 1.0... /usr/bin/gpg-error-config: line 64:
/usr/bin/pkg-config: No such file or directoryyes


BuildRequires: pkgconfig

should fix it.
Comment 1 Rex Dieter 2006-05-30 10:31:38 EDT
I don't think gnupg2 was the intended component here... (:

Though, on looking over the report/error, it appears to me that the better fix
would be to add to libgpg-error-devel:
Requires: pkgconfig

instead of the suggestion of adding to yumex:
BuildRequires: pkgconfig 
Comment 2 Rex Dieter 2006-05-30 10:32:58 EDT
FYI, Reassigned Component: gnupg2 -> libgpg-error.
Comment 3 Matt Domsch 2006-06-05 09:28:46 EDT
libgpg-error-1.3-2.src.rpm now builds in mock on i386 and x86_64.
Comment 4 Paul Howarth 2006-06-05 13:06:57 EDT
Why is this bug closed?

libgpg-error-devel 1.3-2 includes /usr/bin/gpg-error-config, which explictly
calls p/usr/bin/pkg-config and yet there is no dependency on pkgconfig.

A dependency of pkgconfig needs to be added to the -devel subpackage.
Comment 5 Rex Dieter 2006-06-05 13:13:14 EDT
Agreed, reopening, and adjusting Summary to match reality (esp since this really
never had anything to do with yumex).
Comment 6 Nalin Dahyabhai 2006-06-07 11:02:57 EDT
*** Bug 193409 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.