Bug 193558 - Gdk-ERROR right after running anaconda during vnc install
Gdk-ERROR right after running anaconda during vnc install
Status: CLOSED DUPLICATE of bug 193555
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 11:19 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 13:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
193555.txt (3.07 KB, text/plain)
2006-06-08 02:17 EDT, IBM Bug Proxy
no flags Details
193555.txt (1.51 KB, text/plain)
2006-06-08 19:56 EDT, IBM Bug Proxy
no flags Details

  None (edit)
Description IBM Bug Proxy 2006-05-30 11:19:00 EDT
LTC Owner is: thinh@us.ibm.com
LTC Originator is: shenlinf@cn.ibm.com

Problem description:
I was testing "fedora-development tree (aka rawhide), snapshot May26" on
discoverylp1. 
During vnc install, anaconda reported Gdk-ERROR. Connecting discoverylp1 by vnc
showed nothing. 
The same problem didn't occur in May1 version, so it seems that it's a regression.

If this is a customer issue, please indicate the impact to the customer:


If this is not an installation problem,
       Describe any custom patches installed.

       Provide output from "uname -a", if possible:


Hardware Environment
    Machine type (p650, x235, SF2, etc.): Squadron SF4+
    Cpu type (Power4, Power5, IA-64, etc.): Power5
    Describe any special hardware you think might be relevant to this problem:


Please provide contact information if the submitter is not the primary contact.
My backups are Shaowu Yang(shaowu@us.ibm.com) in Austin and Changhai
Jiang(jiangchh@cn.ibm.com) in China.


Please provide access information for the machine if it is available.


Is this reproducible?
    If so, how long does it (did it) take to reproduce it?
    Describe the steps:

    If not, describe how the bug was encountered:


Is the system (not just the application) hung?
    If so, describe how you determined this:


Did the system produce an OOPS message on the console?
    If so, copy it here:


Is the system sitting in a debugger right now?
    If so, how long may it stay there?


Additional information:
anaconda output:
--------------------------
Running anaconda, the Fedora Core system installer - please wait...            
Framebuffer ioctl failed. Exiting.
Probing for video card:   Unable to probe
Probing for monitor type:   Unknown monitor
No video hardware found, assuming headless
Starting VNC...


WARNING!!! VNC server running with NO PASSWORD!
You can use the vncpassword=<password> boot option
if you would like to secure the server.


The VNC server is now running.
Please connect to discoverylp1.upt.austin.ibm.com:1 to begin the install...

Gdk-ERROR **: The program 'mini-wm' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest'.
  (Details: serial 72 error_code 1 request_code 146 minor_code 2)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
--------------------------
Comment 1 Chris Lumens 2006-06-02 13:15:36 EDT

*** This bug has been marked as a duplicate of 193555 ***
Comment 2 IBM Bug Proxy 2006-06-06 00:16:59 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Version|Other                       |devel




------- Additional Comments From marksmit@us.ibm.com  2006-06-06 00:20 EDT -------
I am changing the version to 'devel' to properly reflect that this recreates on
rawhide. 
Comment 3 IBM Bug Proxy 2006-06-08 02:17:22 EDT
Created attachment 130724 [details]
193555.txt
Comment 4 IBM Bug Proxy 2006-06-08 02:17:26 EDT
----- Additional Comments From marksmit@us.ibm.com  2006-06-08 02:22 EDT -------
 
error as created on June6 rawhide snapshot

The June7 snapshot of rawhide appears to recreate with a different error.
I hit <enter> to get a shell prompt and the string of 1470 errors occurred.
The VNC did start successfully and gave me the welcome screen.	
When I clicked on 'next', then the serial 886 error occurred.
Fedora/RPMS/anaconda-11.1.0.24-1.ppc.rpm 
Comment 5 IBM Bug Proxy 2006-06-08 02:22:00 EDT
----- Additional Comments From marksmit@us.ibm.com  2006-06-08 02:24 EDT -------
argg. sorry. the text labeling the attachment as a June6 recreate is wrong.
it is a June7 snapshot of rawhide. 
Comment 6 Chris Lumens 2006-06-08 12:02:14 EDT
The assertions you were seeing were being caused by a GTK bug which is fixed in
today's rawhide.
Comment 7 IBM Bug Proxy 2006-06-08 19:56:59 EDT
Created attachment 130793 [details]
193555.txt
Comment 8 IBM Bug Proxy 2006-06-08 19:57:23 EDT
----- Additional Comments From marksmit@us.ibm.com  2006-06-08 20:00 EDT -------
 
June8 rawhide gives 934 error

You are correct.  The old error is gone.  With June8 rawhide I am seeing 
(Details: serial 934 error_code 1 request_code 146 minor_code 23)
Gdk-error when I click on the 'next' of the welcome screen. 

Note You need to log in before you can comment on or make changes to this bug.