Bug 1935612 - FTBFS with PHP 8
Summary: FTBFS with PHP 8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libkolabxml
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Timotheus Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1936325 (view as bug list)
Depends On: 1934995
Blocks: PYTHON3.10 F35FTBFS 1935861
TreeView+ depends on / blocked
 
Reported: 2021-03-05 09:43 UTC by Remi Collet
Modified: 2021-03-22 21:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-22 21:16:52 UTC
Type: Bug


Attachments (Terms of Use)

Description Remi Collet 2021-03-05 09:43:04 UTC
See https://fedoraproject.org/wiki/Changes/php80

Related to swig bug #1934995

Comment 1 Timotheus Pokorra 2021-03-08 11:24:13 UTC
*** Bug 1936325 has been marked as a duplicate of this bug. ***

Comment 2 Timotheus Pokorra 2021-03-14 06:38:11 UTC
I will wait until swig is built for PHP 8, and then rebuild libkolabxml.

Comment 3 Jitka Plesnikova 2021-03-22 14:27:31 UTC
Support for PHP 8 was added in swig-4.0.2-5.fc35.

Comment 4 Timotheus Pokorra 2021-03-22 21:16:52 UTC
Thanks for fixing swig!

The libkolabxml Package has now been built successfully for rawhide: libkolabxml-1.2.0-3.fc35


Note You need to log in before you can comment on or make changes to this bug.