Bug 193566 - DRI permission problem
DRI permission problem
Status: CLOSED DUPLICATE of bug 193567
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 13:24 EDT by Émeric Maschino
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 13:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Émeric Maschino 2006-05-30 13:24:41 EDT
Description of problem:

First, I really don't know whether this bug is reported against the right
component or not. Then, the facts.

Although DRI seems to initialize properly (as reported by Xorg.0.log), it cannot
be used neither by e.g. AIGLX, glxinfo or glxgears. This is on an Itanium
workstation with an ATI FireGL X1 (R300 chipset) graphics adapter. The following
error is displayed:

libGL error: open DRM failed (Operation not permitted)
libGL error: reverting to (slow) indirect rendering

As user emeric, ls -lZ /dev/dri/card0 gives:

crw-------  emeric root system_u:object_r:dri_device_t   /dev/dri/card0

which seems correct to me.

Furthermore, the DRI section in my xorg.conf file is as follows:

Section "DRI"
        Group        0
        Mode         0666
EndSection

I've checked on a x86 Rawhide system: the DRI section is identical.

This issue is present on ia64 since at least January 10th 2006 (the date I
installed Rawhide on my Itanium workstation). Mike Harris suggested this could
be an udev issue. So I filed bug #184045 against udev at that time, but none of
the proposed solutions does the trick. Logging in as root or with SELinux
disabled didn't help.

I recently had the opportunity to put my hands on a Matrox G400 graphics adapter
and put it into my Itanium workstation for testing purposes: same permission
error, so it isn't related to the xorg-x11-drv-ati component.

FYI, I have openSUSE Factory installed on my 2nd HDD from roughly one month now
and DRI works. Well, it's highly unstable (glxgears crashes immediately and
requires a reboot) but glxinfo doesn't report the permission problem and reports
"direct rendering: Yes". A great difference between Fedora Rawhide and openSUSE
Factory is that the latter is shipped with X.org 6.9. IIRC, X.org 6.9/7.0 share
the same source code. So, either something broke DRI during the "modularization"
of the X.org 7.0 code, or (if the X.org 6.9 and 7.0 codes are identical except
for the modularization) this is due to one of the patches applied to the X.org
7.0 code by the Fedora maintainers/developers. Or maybe yet an other thing.

I really don't know how to help further so am open to any suggestion in order to
help finding the root of this problem.

Version-Release number of selected component (if applicable):

From the X.org.log file, X.org 7.1.0

How reproducible:

Always

Steps to Reproduce:
1. Invoke glxinfo or glxgears
2.
3.
  
Actual results:

Permission error

Expected results:

Working DRI :-)

Additional info:
Comment 1 Mike A. Harris 2006-05-30 13:39:20 EDT

*** This bug has been marked as a duplicate of 193567 ***

Note You need to log in before you can comment on or make changes to this bug.