Bug 1936963 - Setup tool of ibus-cangjie aborts with a backtrack
Summary: Setup tool of ibus-cangjie aborts with a backtrack
Keywords:
Status: CLOSED DUPLICATE of bug 1951884
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-cangjie
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mathieu Bridon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-09 14:56 UTC by Mike FABIAN
Modified: 2021-09-13 09:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-13 09:33:01 UTC
Type: Bug


Attachments (Terms of Use)

Description Mike FABIAN 2021-03-09 14:56:14 UTC
I installed Fedora-Workstation-Live-x86_64-34-20210308.n.0.iso in kvm

Install ibus-cangjie and ibus-cangjie-engine-quick:

sudo dnf install ibus-cangjie-engine-quick ibus-cangjie

Try to run the setup tool:

[mfabian@fedora ~]$ rpm -qf /usr/bin/ibus-setup-cangjie 
ibus-cangjie-2.4-22.fc34.noarch
[mfabian@fedora ~]$ /usr/bin/ibus-setup-cangjie -h
usage: ibus-setup-cangjie [-h] {cangjie,quick}

Cangjie input method setup

positional arguments:
  {cangjie,quick}  Input method engine to set up

optional arguments:
  -h, --help       show this help message and exit
[mfabian@fedora ~]$ 
[mfabian@fedora ~]$ /usr/bin/ibus-setup-cangjie cangjie
Traceback (most recent call last):
  File "/usr/bin/ibus-setup-cangjie", line 35, in <module>
    from gi.repository import Gtk
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 627, in _load_backward_compatible
  File "/usr/lib64/python3.9/site-packages/gi/importer.py", line 145, in load_module
    dynamic_module = load_overrides(introspection_module)
  File "/usr/lib/python3.9/site-packages/gi/overrides/__init__.py", line 118, in load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/usr/lib/python3.9/site-packages/gi/overrides/Gtk.py", line 168, in <module>
    class Container(Gtk.Container, Widget):
  File "/usr/lib64/python3.9/site-packages/gi/module.py", line 123, in __getattr__
    raise AttributeError("%r object has no attribute %r" % (
AttributeError: 'gi.repository.Gtk' object has no attribute 'Container'
[mfabian@fedora ~]$ 

Same backtrace for the 'quick' option:

[mfabian@fedora ~]$ /usr/bin/ibus-setup-cangjie quick
Traceback (most recent call last):
  File "/usr/bin/ibus-setup-cangjie", line 35, in <module>
    from gi.repository import Gtk
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 664, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 627, in _load_backward_compatible
  File "/usr/lib64/python3.9/site-packages/gi/importer.py", line 145, in load_module
    dynamic_module = load_overrides(introspection_module)
  File "/usr/lib/python3.9/site-packages/gi/overrides/__init__.py", line 118, in load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "/usr/lib64/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/usr/lib/python3.9/site-packages/gi/overrides/Gtk.py", line 168, in <module>
    class Container(Gtk.Container, Widget):
  File "/usr/lib64/python3.9/site-packages/gi/module.py", line 123, in __getattr__
    raise AttributeError("%r object has no attribute %r" % (
AttributeError: 'gi.repository.Gtk' object has no attribute 'Container'
[mfabian@fedora ~]$ 

The same problem occurs when trying to run the setup tool from the gnome control center.

Comment 1 Mike FABIAN 2021-09-13 09:33:01 UTC

*** This bug has been marked as a duplicate of bug 1951884 ***


Note You need to log in before you can comment on or make changes to this bug.