Bug 1951884 - [abrt] ibus-cangjie: __init__(): setup.py:35:__init__:gi.repository.GLib.GError: gtk-builder-error-quark: /usr/share/ibus-cangjie/setup.ui:43:36 Invalid property: GtkDialog.border_width (11)
Summary: [abrt] ibus-cangjie: __init__(): setup.py:35:__init__:gi.repository.GLib.GErr...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-cangjie
Version: 34
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mathieu Bridon
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:1f6e49bb21aa14065c873c30358...
: 1936963 1958469 1984599 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-21 05:34 UTC by Sampson Fung
Modified: 2021-09-13 09:33 UTC (History)
8 users (show)

Fixed In Version: ibus-cangjie-2.4-25.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-13 09:19:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (797 bytes, text/plain)
2021-04-21 05:34 UTC, Sampson Fung
no flags Details
File: cpuinfo (2.23 KB, text/plain)
2021-04-21 05:34 UTC, Sampson Fung
no flags Details
File: environ (1.33 KB, text/plain)
2021-04-21 05:34 UTC, Sampson Fung
no flags Details
File: mountinfo (2.59 KB, text/plain)
2021-04-21 05:34 UTC, Sampson Fung
no flags Details
File: namespaces (172 bytes, text/plain)
2021-04-21 05:34 UTC, Sampson Fung
no flags Details
File: open_fds (1.25 KB, text/plain)
2021-04-21 05:34 UTC, Sampson Fung
no flags Details

Description Sampson Fung 2021-04-21 05:34:26 UTC
Description of problem:
In Keyboard, added the Cangjie input method.

This error happens when I trying to open the preference of the Cangjie input method.

Version-Release number of selected component:
ibus-cangjie-2.4-22.fc34

Additional info:
reporter:       libreport-2.14.0
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-glib-ibus\x2dsetup\x2dcangjie-2399.scope
cmdline:        /usr/bin/python3 /usr/bin/ibus-setup-cangjie cangjie
crash_function: __init__
exception_type: gi.repository.GLib.GError
executable:     /usr/bin/ibus-setup-cangjie
interpreter:    python3-3.9.4-1.fc34.x86_64
kernel:         5.11.11-300.fc34.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
setup.py:35:__init__:gi.repository.GLib.GError: gtk-builder-error-quark: /usr/share/ibus-cangjie/setup.ui:43:36 Invalid property: GtkDialog.border_width (11)

Traceback (most recent call last):
  File "/usr/bin/ibus-setup-cangjie", line 62, in <module>
    Setup(args.engine, datadir, gettext_package).run()
  File "/usr/lib/python3.9/site-packages/ibus_cangjie/setup.py", line 35, in __init__
    self.__builder.add_from_file(ui_file)
gi.repository.GLib.GError: gtk-builder-error-quark: /usr/share/ibus-cangjie/setup.ui:43:36 Invalid property: GtkDialog.border_width (11)

Local variables in innermost frame:
self: <ibus_cangjie.setup.Setup object at 0x7fe4a358c520>
engine: 'cangjie'
datadir: '/usr/share/ibus-cangjie'
gettext_package: 'ibus-cangjie'
ui_file: '/usr/share/ibus-cangjie/setup.ui'

Comment 1 Sampson Fung 2021-04-21 05:34:28 UTC
Created attachment 1773986 [details]
File: backtrace

Comment 2 Sampson Fung 2021-04-21 05:34:30 UTC
Created attachment 1773987 [details]
File: cpuinfo

Comment 3 Sampson Fung 2021-04-21 05:34:31 UTC
Created attachment 1773988 [details]
File: environ

Comment 4 Sampson Fung 2021-04-21 05:34:32 UTC
Created attachment 1773989 [details]
File: mountinfo

Comment 5 Sampson Fung 2021-04-21 05:34:33 UTC
Created attachment 1773990 [details]
File: namespaces

Comment 6 Sampson Fung 2021-04-21 05:34:34 UTC
Created attachment 1773991 [details]
File: open_fds

Comment 7 Sampson Fung 2021-04-27 03:25:35 UTC
Similar problem has been detected:

Added Cangjie input method.  Log off and Log on again.  Then open the preference of the input method (via Gnome-shell settings)

reporter:       libreport-2.14.0
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-glib-ibus\x2dsetup\x2dcangjie-6189.scope
cmdline:        /usr/bin/python3 /usr/bin/ibus-setup-cangjie cangjie
crash_function: __init__
exception_type: gi.repository.GLib.GError
executable:     /usr/bin/ibus-setup-cangjie
interpreter:    python3-3.9.4-1.fc34.x86_64
kernel:         5.11.15-300.fc34.x86_64
package:        ibus-cangjie-2.4-22.fc34
reason:         setup.py:35:__init__:gi.repository.GLib.GError: gtk-builder-error-quark: /usr/share/ibus-cangjie/setup.ui:43:36 Invalid property: GtkDialog.border_width (11)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 8 Rafal 2021-05-08 06:56:38 UTC
*** Bug 1958469 has been marked as a duplicate of this bug. ***

Comment 9 Giovanni Bravin 2021-07-21 18:06:46 UTC
*** Bug 1984599 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2021-09-13 09:16:50 UTC
FEDORA-2021-73f11511d2 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2021-73f11511d2

Comment 11 Fedora Update System 2021-09-13 09:19:31 UTC
FEDORA-2021-73f11511d2 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Mike FABIAN 2021-09-13 09:33:01 UTC
*** Bug 1936963 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.