Bug 19377 - anaconda crashed at line 438 during upgrade 6.0->7.0
Summary: anaconda crashed at line 438 during upgrade 6.0->7.0
Status: CLOSED DUPLICATE of bug 18019
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i586 Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-19 13:09 UTC by Need Real Name
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 21:54:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-19 13:09:41 UTC
My system reported an error when trying to upgrade RedHat Linux 6.0 
(Hedwig) to 7.0. I downloaded the /RPMS and /base directories to 
my /dev/hda8 (approx. 2gig) partition. I added the /dev/hda8 partition 
later then the original install for storing media files. I ran install and 
after checking installation and checking installed packages it crashed 
with the following error message, asking me to report it. 

I run a Cyrix 6x86 - 300 Mhz, 64 MB ram, onboard video controler, WD 26000 
(+/- 6 gigs.) and two ethernet controllers.

The following error dump was put on a disc: 
Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in 
__call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 941, in 
upgradeFindPackages
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, 
in readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
KeyError: whois

Local variables in innermost frame:
self: <comps.HeaderList instance at 821b8a0>
item: whois

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'ext2'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>

Comment 1 Need Real Name 2000-10-19 13:30:14 UTC
/dev/hda8 is an ext2 partition.

Comment 2 Michael Fulbright 2000-10-19 21:54:02 UTC

*** This bug has been marked as a duplicate of 18019 ***


Note You need to log in before you can comment on or make changes to this bug.