Bug 1938426 - [OSP] Validation should fail when no any IaaS flavor or type related field are given
Summary: [OSP] Validation should fail when no any IaaS flavor or type related field ar...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.7.z
Assignee: Mike Fedosin
QA Contact: Jon Uriarte
URL:
Whiteboard:
: 1942512 (view as bug list)
Depends On: 1903055
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-13 11:51 UTC by OpenShift BugZilla Robot
Modified: 2021-07-06 11:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-06 11:38:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 4750 0 None open [release-4.7] Bug 1938426: Set default values to machine pools before validation 2021-03-26 01:00:25 UTC
Red Hat Product Errata RHBA-2021:2554 0 None None None 2021-07-06 11:39:14 UTC

Comment 1 Emilien Macchi 2021-03-24 16:54:02 UTC
*** Bug 1942512 has been marked as a duplicate of this bug. ***

Comment 9 Jon Uriarte 2021-06-29 11:01:36 UTC
Verified in OCP 4.7.0-0.nightly-2021-06-26-014854 on top of OSP 16.1.6 (RHOS-16.1-RHEL-8-20210506.n.1).

Removed computeFlavor from the install-config:

# install-config.yaml 
...
platform:
  openstack:
    cloud:            "shiftstack"
    externalNetwork:  "nova"
    region:           "regionOne"
    #computeFlavor:    "m4.xlarge"
    lbFloatingIP:     "x.x.x.x"
    ingressFloatingIP:     "y.y.y.y"
    externalDNS:      ["z.z.z.z"]
    
intall-config validation fails as expected:

IPI:
---

$ openshift-install create cluster --log-level=debug --dir=/home/stack/ostest/                                                                                                                                         
DEBUG OpenShift Installer 4.7.0-0.nightly-2021-06-26-014854
DEBUG Built from commit 3948d1fe9f04057823b871133085d602e6575067
DEBUG Fetching Metadata...
DEBUG Loading Metadata...
DEBUG   Loading Cluster ID...
DEBUG     Loading Install Config...
DEBUG       Loading SSH Key...
DEBUG       Loading Base Domain...
DEBUG         Loading Platform...
DEBUG       Loading Cluster Name...
DEBUG         Loading Base Domain...
DEBUG         Loading Platform...
DEBUG       Loading Networking...
DEBUG         Loading Platform...
DEBUG       Loading Pull Secret...
DEBUG       Loading Platform...
FATAL failed to fetch Metadata: failed to load asset "Install Config": [controlPlane.platform.openstack.type: Required value: Flavor name must be provided, compute[0].platform.openstack.type: Required value: Flavor name must be provided]


UPI:
---

$ openshift-install create manifests --log-level=debug --dir=/home/stack/ostest/
DEBUG OpenShift Installer 4.7.0-0.nightly-2021-06-26-014854 
DEBUG Built from commit 3948d1fe9f04057823b871133085d602e6575067 
DEBUG Fetching Master Machines...                  
DEBUG Loading Master Machines...                   
DEBUG   Loading Cluster ID...                      
DEBUG     Loading Install Config...                
DEBUG       Loading SSH Key...                     
DEBUG       Loading Base Domain...                 
DEBUG         Loading Platform...                  
DEBUG       Loading Cluster Name...                
DEBUG         Loading Base Domain...               
DEBUG         Loading Platform...                  
DEBUG       Loading Networking...                  
DEBUG         Loading Platform...                  
DEBUG       Loading Pull Secret...                 
DEBUG       Loading Platform...                    
FATAL failed to fetch Master Machines: failed to load asset "Install Config": [controlPlane.platform.openstack.type: Required value: Flavor name must be provided, compute[0].platform.openstack.type: Required value: Flavor name must be provided]

Comment 11 errata-xmlrpc 2021-07-06 11:38:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.19 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2554


Note You need to log in before you can comment on or make changes to this bug.