Bug 193901 - Error loading files with non-standar ascii characters
Error loading files with non-standar ascii characters
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ddd (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-02 15:45 EDT by Davide Bolcioni
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 05:28:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.tar.gz containing test.pl, the testcase for the report (302 bytes, application/octet-stream)
2006-06-02 15:45 EDT, Davide Bolcioni
no flags Details

  None (edit)
Description Davide Bolcioni 2006-06-02 15:45:38 EDT
+++ This bug was initially created as a clone of Bug #187815 +++

Description of problem:

ddd doesn't show Perl source code properly in case of mismatches between
its encoding and the current locale, even using the iso10646 font suggested
in the original bug

Version-Release number of selected component (if applicable):
ddd 3.3.11

How reproducible:
See attached test case, test.pl

Steps to Reproduce:
1. export LANG=it_IT.utf8
2. ddd test.pl
3. source display is truncated at first accented character
4. export LANG=it_IT.iso88591 (i.e. matching 'use encoding')
5. ddd test.pl
6. ddd test.pl
7. source display is fine

  
Actual results:
ddd stops showing the source file when it finds the first mismatched character

Expected results:
showing the source file properly.

Additional info:
The original reporter suggested that "it's not a bug in ddd because in other
distros it works fine", but I have not been able to try other distros; I think
that ddd might be ignoring the 'use encoding' pragma (it would probably need
help from Perl or the Perl debugger for that, I guess, possibly using iconv).
Comment 1 Davide Bolcioni 2006-06-02 15:45:38 EDT
Created attachment 130420 [details]
.tar.gz containing test.pl, the testcase for the report
Comment 2 Davide Bolcioni 2006-06-02 15:47:26 EDT
Please note that step 6 is a typo, sorry.
Comment 3 Davide Bolcioni 2007-01-24 12:26:33 EST
Just verified this with ddd-3.3.11-14.fc6 and it works OK. I think this bug 
can be closed.

Note You need to log in before you can comment on or make changes to this bug.