Bug 193934 - OpenSceneGraph has broken SONAMES handling
OpenSceneGraph has broken SONAMES handling
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: OpenSceneGraph (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 193982
  Show dependency treegraph
 
Reported: 2006-06-02 21:10 EDT by Christopher Stone
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 02:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Stone 2006-06-02 21:10:22 EDT
Description of problem:
I am trying to build a spec file that uses OpenSceneGraph.  There is a bug in
the OpenSceneGraph spec file which causes OpenSceneGraph-devel to not pick up
OpenSceneGraph:

Requires:	%name = %{version}-%{release}

This should read:

Requires:	%{name} = %{version}-%{release}

Version-Release number of selected component (if applicable):
OpenSceneGraph-1.0-2.fc5
Comment 1 Ralf Corsepius 2006-06-02 22:57:58 EDT
Hmm, I don't understand what you are trying to say.

1. OpenSceneGraph-devel on fc5 does require OpenSceneGraph:

# rpm -q --requires OpenSceneGraph-devel
OpenSceneGraph = 1.0-2.fc5

2. In rpm.spec syntax, "%name" and "%{name}" are supposed to be completely
equivalent: %{name} is the escaped form of %name.

If your proposal above does what you say, your observation would mean you to
have found a bug in rpm.
Comment 2 Christopher Stone 2006-06-02 23:10:55 EDT
I am having problems with this package under mock.  Please see my discussion on
the Fedora-Extras List.  At first I thought it was not picking up the necessary
packages and thought this was the cause.  It turns out there is some other
problem here, possibly a bug in mock.

Please see the discussion on F-E-L:
https://www.redhat.com/archives/fedora-extras-list/2006-June/msg00094.html
Comment 3 Christopher Stone 2006-06-03 17:36:02 EDT
Updating bug summary per your latest comments:

=> Something is broken in this package's libraries' SONAMES handling.

... to be investigated ...
Comment 4 Ralf Corsepius 2006-06-07 02:32:17 EDT
Should now be fixed with 1.0-4. Builds for fc6 and fc5 are currently in the
build-queue.

I am not sure if I am going to fix it for FE3/FE4. Though these suffer from the
same issue, an SONAME change has occured between FE4 (OpenSceneGraph-0.9.x) and
FE5 (OpenSceneGraph-1.0).
Comment 5 Ralf Corsepius 2006-06-07 05:36:24 EDT
I've backported the hacks I've applied to 1.0 for FC5/FC6 to 0.9.9 for FC3/FC4.

So, this issue should also be fixed in 0.9.9-5 for FC3 and FC4, should the
(currently broken) buildsystem once finish building them.

Note You need to log in before you can comment on or make changes to this bug.