Bug 193955 - Current "mkisofs" unable to (non)-bootable disk image
Current "mkisofs" unable to (non)-bootable disk image
Status: CLOSED DUPLICATE of bug 193847
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 05:48 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 02:18:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2006-06-03 05:48:14 EDT
Description of problem:
The creation of a "boot.iso" image from the "isolinux" file for current
"rawhide" fails. The command used herefore was:

  "mkisofs -R -J -T -v -no-emul-boot -boot-load-size 4 -boot-info-table
   -V "FC devel 2006-06-01" -b ./isolinux/isolinux.bin -c
   ./isolinux/boot.cat -o ../boot.iso ."

Version-Release number of selected component (if applicable):
cdrtools-2.01.01.0.a09-1

How reproducible:
Always.

Steps to Reproduce:
1. Download "isolinux" directory.
2. Try to create "ISO" image.
  
Actual results:
Creation fails issuing the following error messages:

INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
mkisofs 2.01.01a05 (i686-pc-linux-gnu)
Scanning .
Scanning ./isolinux
mkisofs: Value too large for defined data type.
  File ./isolinux/boot.msg is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/param.msg is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/splash.lss is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/isolinux.cfg is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/vmlinuz is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/initrd.img is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/rescue.msg is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/memtest is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/isolinux.bin is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/options.msg is too large - ignoring
mkisofs: Value too large for defined data type.
  File ./isolinux/general.msg is too large - ignoring
Writing:   Initial Padblock               Start Block 0
Done with: Initial Padblock               Block(s)    16
Writing:   Primary Volume Descriptor      Start Block 16
Done with: Primary Volume Descriptor      Block(s)    1
Writing:   Eltorito Volume Descriptor     Start Block 17
mkisofs: Uh oh, I cant find the boot image './isolinux/isolinux.bin' !

Expected results:
A bootable "ISO" image file "boot.iso" should have been created.

Additional info:
The boot image was finally successfully created under FC2 with exactly
the same files and usinf the same commands.
Even creating a simple data disk image supposed to contain the files
in "isolinux" fails in the same way.
Comment 1 Harald Hoyer 2006-06-06 02:18:07 EDT

*** This bug has been marked as a duplicate of 193847 ***

Note You need to log in before you can comment on or make changes to this bug.