Bug 193847 - mkisofs 2.01.01.0.a09-0 incorrectly reports "Value too large for defined data type." on small files
mkisofs 2.01.01.0.a09-0 incorrectly reports "Value too large for defined data...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 193796 193955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-02 01:19 EDT by Ellen Shull
Modified: 2013-01-09 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-02 11:34:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ellen Shull 2006-06-02 01:19:12 EDT
Description of problem:
$ ls -l
total 4
-rw-rw-r-- 1 wes wes 0 Jun  1 22:24 foo

$ mkisofs -print-size .
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
Unknown file type (unallocated) ./.. - ignoring and continuing.
mkisofs: Value too large for defined data type. File ./foo is too large - ignoring
Total extents scheduled to be written = 174
174

That was just a simple example, but it flags just about every file with the
"Value too large"

Version-Release number of selected component (if applicable):
mkisofs-2.01.01.0.a09-0.FC5.1.i386.rpm, currently in updates-testing

How reproducible:
always

Steps to Reproduce:
1.  do anything with mkisofs--I can't *not* reproduce it
  
Additional info:
backing off to a03-3 that shipped with FC5 works fine.

Maybe this is related to the somewhat vague bug 191860
Comment 1 Harald Hoyer 2006-06-02 06:30:45 EDT
*** Bug 193796 has been marked as a duplicate of this bug. ***
Comment 2 Harald Hoyer 2006-06-02 06:32:23 EDT
Not related to bug 191860.
Checked in the fix in CVS, waitung for the build system to work again.
Comment 3 Harald Hoyer 2006-06-06 02:18:09 EDT
*** Bug 193955 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2006-06-07 08:01:53 EDT
For FC5, please test
https://www.redhat.com/archives/fedora-test-list/2006-June/msg00051.html

Note You need to log in before you can comment on or make changes to this bug.