Bug 194007 - Yum crashes when temporary filesystem for downloading RPMs is full.
Yum crashes when temporary filesystem for downloading RPMs is full.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
:
: 212975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-04 08:32 EDT by Marc Mendez
Modified: 2014-01-21 17:54 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 15:27:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Mendez 2006-06-04 08:32:17 EDT
Description of problem:
Trying to update my system with the following filesystems:
Filesystem            Size  Used Avail Use% Mounted on
/dev/hda3             3.9G  275M  3.5G   8% /
/dev/hda2             244M  9.4M  222M   5% /boot
tmpfs                 252M     0  252M   0% /dev/shm
/dev/hda6             9.9G  6.3G  3.1G  68% /home
/dev/hda9             487M   28M  434M   7% /tmp
/dev/hda8              12G  3.8G  7.1G  35% /usr
/dev/hda10            532M  131M  375M  26% /var

/var has been filled by package updates causing yum to crash.

Version-Release number of selected component (if applicable):
$ rpm -q yum
yum-2.6.0-1

How reproducible:
Fill the /var filesystem, then try to update.

Additional info:
Should check the space size available and/or be configurable. Error message did
not explicitly precise that the destination FS was full.
Let me know if you need a dump.
Comment 1 Marc Mendez 2006-06-04 08:38:01 EDT
OK, I checked. That's configurable, but should be checked or exception should be
handled.
Comment 2 Seth Vidal 2006-06-04 15:54:56 EDT
actually this one is a problem and the config option doesn't solve that one.

There's a mention of the need to fix the downloading rpm bit in the code and
it'll get fixed up before long.

Thanks
 
Comment 3 Jeremy Katz 2007-04-25 14:41:42 EDT
*** Bug 212975 has been marked as a duplicate of this bug. ***
Comment 4 Seth Vidal 2007-08-03 15:27:56 EDT
Looking at the download code since this time I'm pretty sure this is fixed. All
destinations are checked for available space before downloaded.

Note You need to log in before you can comment on or make changes to this bug.