This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 212975 - yum traceback when /var is 100% full
yum traceback when /var is 100% full
Status: CLOSED DUPLICATE of bug 194007
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 08:29 EST by Steve Grubb
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2006-10-30 08:29:04 EST
Description of problem:
Found my /var partition 100% full and saw 2Gb of cache. So, I did a "yum clean
all" and got a traceback:

[root var]# yum clean all
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 91, in main
    base.doLock(YUM_PID_FILE)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 538, in doLock
    while not self._lock(lockfile, mypid, 0644):
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 583, in _lock
    os.write(fd, contents)
OSError: [Errno 28] No space left on device

Version-Release number of selected component (if applicable):
yum-3.0-6

How reproducible:
everytime
Comment 1 Jeremy Katz 2007-04-25 14:41:39 EDT

*** This bug has been marked as a duplicate of 194007 ***

Note You need to log in before you can comment on or make changes to this bug.