Bug 194016 - prelink triggers assertion failure on /usr/bin/john
prelink triggers assertion failure on /usr/bin/john
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 194588 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-04 18:25 EDT by daw
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.3.8-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-21 07:00:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daw 2006-06-04 18:25:51 EDT
Description of problem:
  /usr/sbin/prelink -v -mR /usr/bin/john
fails with the following error message:
  prelink: dso.c:1465: recompute_nonalloc_offsets: Assertion `dso->shdr[i -
1].sh_offset < dso->ehdr.e_shoff' failed.

Version-Release number of selected component (if applicable):
prelink-0.3.6-3

How reproducible:
prelink -v /usr/bin/john

Steps to Reproduce:
1. Run prelink -v /usr/bin/john as root
  
Actual results:
Assertion failure / seg fault.

Expected results:
Successful execution.

Additional info:
I installed prelink-debuginfo.  Here is a backtrace from gdb:
#0  0x0809442d in abort ()
#1  0x08090392 in __assert_fail ()
#2  0x08068cc9 in recompute_nonalloc_offsets (dso=0x8e60680) at dso.c:1465
#3  0x08052025 in prelink_exec (info=0xbfc11628) at exec.c:1052
#4  0x0805a683 in prelink (dso=0x8e60680, ent=0x8d13da0) at prelink.c:916
#5  0x0804d652 in prelink_ent (ent=0x8d13da0) at doit.c:148
#6  0x0804d8b5 in prelink_all () at doit.c:269
#7  0x08059455 in main (argc=4, argv=0xbfc16a14) at main.c:409
#8  0x0808e2f5 in __libc_start_main ()
#9  0x08048131 in _start ()

I get the same error message, with, e.g., /usr/sbin/prelink -v /usr/bin/john, so
it doesn't seem to be specific to any particular command line argument.  I tried
'yum erase john; yum install john' and got the same error.  This is with the
package john-1.7.0.2-3.fc5.rf from the dries repository; sha1sum /usr/bin/john
yields the digest "297bbc5875ca821bfc5e31c75d7970e13a0d47c8".

(I discovered this when /etc/cron.daily/prelink failed and emailed me with the
error message.)
Comment 1 Jakub Jelinek 2006-06-14 06:08:56 EDT
*** Bug 194588 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2006-06-21 07:00:39 EDT
Should be fixed by prelink-0.3.8-1 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.