Bug 194197 - should check for dep closure before allowing an update to be pushed
should check for dep closure before allowing an update to be pushed
Status: CLOSED CURRENTRELEASE
Product: Fedora Infrastructure
Classification: Retired
Component: update system (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Macken
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-05 21:56 EDT by Jeremy Katz
Modified: 2016-09-19 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-22 12:27:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2006-06-05 21:56:52 EDT
Updates being pushed should at check and at least warn about dep closure
problems before pushing so that we can avoid things like bug 194195
Comment 1 Luke Macken 2006-06-06 12:11:09 EDT
Sounds reasonable.

Before a push, I'll have the update system toss the rpms in a testclosure repo,
run createrepo on it, then run `repoclosure -n -r testclosure -r core -r
{updates,updates-testing}`, correct ?

To make this possible, I would have to modify repoclosure to use return values
to actually know if there are broken deps or not.

Once they are found, what should the update system do, just halt the push ?
Comment 2 Jeremy Katz 2006-06-06 12:30:16 EDT
It should probably at least require an override to know that you're pushing
something that may be broken.  Given that multiple updates could be required for
a set, unless the pushing happens as a batch, an override is going to be needed.

Comment 3 Luke Macken 2006-06-22 12:27:34 EDT
There is now a 'Check Dependecies' button next to the 'Push' button in
fedora-updates/push.py.  It seems to be working OK (although I think a
yum{,-util} upgrade on porkchop might speed things up a bit).  I'll work with
Jesse on polishing this feature up.

Note You need to log in before you can comment on or make changes to this bug.