Bug 194298 - unable to update evolution or evolution-data-server correctly
unable to update evolution or evolution-data-server correctly
Status: CLOSED DUPLICATE of bug 194174
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-06 19:13 EDT by John Mellor
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 20:35:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mellor 2006-06-06 19:13:26 EDT
Description of problem: Unable to update evolution or evolution-data-server due
to incorrect dependency chain in evolution-data-server


Version-Release number of selected component (if applicable): 1.6.2-1.fc5.1


How reproducible: every time


Steps to Reproduce: yum update to latest evolution update version as announced.

  
Actual results:
# yum update evolution-data-server-devel
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna                                                                [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package evolution-data-server-devel.i386 0:1.6.2-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: evolution-data-server = 1.6.2-1.fc5.1 for package:
evolution-data-server-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package evolution-data-server.i386 0:1.6.2-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-sharp
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Processing Dependency: libecal-1.2.so.3 for package: evolution
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-webcal
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package evolution.i386 0:2.6.2-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-sharp
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Processing Dependency: libecal-1.2.so.3 for package: evolution
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-webcal
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package
evolution-sharpError: Missing Dependency: libecal-1.2.so.3 is needed by package
gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-webcal
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution



Expected results: dependency should be correctly resolved.  Packages should be
updated without issues.


Additional info: The supposedly missing library is in fact already installed,
but is not correctly identified.
# locate libecal-1.2.so.3
/usr/lib/libecal-1.2.so.3
/usr/lib/libecal-1.2.so.3.2.8

Basic evolution CAN be updated in spite of this messup by running
yum update --exclude evolution-data-server --exclude evolution-data-server-devel
but this is highly arcane and leaves evolution-data-server in an unknown update
correctness state.  I would expect most admins to get this wrong.
Comment 1 Elijah Newren 2006-06-06 19:28:31 EDT
Looks like a duplicate of bug 194174; I don't have perms to mark it as such.
Comment 2 John Mellor 2006-06-06 20:35:23 EDT

*** This bug has been marked as a duplicate of 194174 ***

Note You need to log in before you can comment on or make changes to this bug.