Bug 194299 - yum update fails due to a missing dependency for libecal-1.2.so.3
yum update fails due to a missing dependency for libecal-1.2.so.3
Status: CLOSED DUPLICATE of bug 194174
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-06 19:42 EDT by Thomas Chung
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 20:38:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Chung 2006-06-06 19:42:08 EDT
Description of problem:
yum update fails due to a missing dependency for libecal-1.2.so.3

Version-Release number of selected component (if applicable):
evolution-data-server-1.6.2 ??

How reproducible:
As of 2006-06-06, always.

Steps to Reproduce:

[tchung@tchung-laptop ~]$ sudo yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/4]
updates                                                              [2/4]
macromedia                                                           [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package evolution-data-server.i386 0:1.6.2-1.fc5.1 set to be updated
---> Package eog.i386 0:2.14.2-1.fc5.1 set to be updated
---> Package glib2.i386 0:2.10.3-1 set to be updated
---> Package gtk2-devel.i386 0:2.8.18-1 set to be updated
---> Package gedit.i386 1:2.14.3-1 set to be updated
---> Package gnome-vfs2-smb.i386 0:2.14.2-1 set to be updated
---> Package control-center.i386 1:2.14.2-1 set to be updated
---> Package pam.i386 0:0.99.4.0-fc5.4 set to be updated
---> Package gnome-utils.i386 1:2.14.0-4.fc5.2 set to be updated
---> Package gnome-themes.noarch 0:2.14.2-1 set to be updated
---> Package hal.i386 0:0.5.7-3.fc5.2 set to be updated
---> Package hal-gnome.i386 0:0.5.7-3.fc5.2 set to be updated
---> Package pango-devel.i386 0:1.12.3-1 set to be updated
---> Package gnome-backgrounds.noarch 0:2.14.2.1-1 set to be updated
---> Package rsync.i386 0:2.6.8-1.FC5 set to be updated
---> Package gthumb.i386 0:2.7.7-1 set to be updated
---> Package gnome-media.i386 0:2.14.2-1 set to be updated
---> Package gnome-screensaver.i386 0:2.14.2-1 set to be updated
---> Package gnome-vfs2.i386 0:2.14.2-1 set to be updated
---> Package evolution-data-server-devel.i386 0:1.6.2-1.fc5.1 set to be updated
---> Package spamassassin.i386 0:3.1.3-1.fc5 set to be updated
---> Package gnome-terminal.i386 0:2.14.2-1 set to be updated
---> Package file-roller.i386 0:2.14.3-1 set to be updated
---> Package gnome-applets.i386 1:2.14.2-1.fc5.1 set to be updated
---> Package hal-devel.i386 0:0.5.7-3.fc5.2 set to be updated
---> Package gnome-vfs2-devel.i386 0:2.14.2-1 set to be updated
---> Package policycoreutils.i386 0:1.30.10-1.fc5 set to be updated
---> Package gnome-desktop-devel.i386 0:2.14.2-1 set to be updated
---> Package gnome-desktop.i386 0:2.14.2-1 set to be updated
---> Package pango.i386 0:1.12.3-1 set to be updated
---> Package pam-devel.i386 0:0.99.4.0-fc5.4 set to be updated
---> Package module-init-tools.i386 0:3.2.2-0.FC5.3 set to be updated
---> Package glib2-devel.i386 0:2.10.3-1 set to be updated
---> Package evolution.i386 0:2.6.2-1.fc5.1 set to be updated
---> Package libsoup.i386 0:2.2.93-1.fc5.1 set to be updated
---> Package vte.i386 0:0.12.2-1.fc5.1 set to be updated
---> Package gnome-session.i386 0:2.14.2-1 set to be updated
---> Package sound-juicer.i386 0:2.14.4-1.fc5.1 set to be updated
---> Package totem.i386 0:1.4.1-1 set to be updated
---> Package nautilus-cd-burner.i386 0:2.14.2-1 set to be updated
---> Package gtk2.i386 0:2.8.18-1 set to be updated
---> Package yelp.i386 0:2.14.2-1 set to be updated
---> Package libwnck.i386 0:2.14.2-1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-sharp
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Processing Dependency: libecal-1.2.so.3 for package: evolution
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-webcal
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-sharp
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-webc
  
Actual results:

Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-sharp
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-webcal

Expected results:
No dependency error

Additional info:

[tchung@tchung-laptop ~]$ rpm -q --whatprovides libecal-1.2.so.3
evolution-data-server-1.6.1-1.fc5.2
Comment 1 Thomas Chung 2006-06-06 20:14:31 EDT
Work around at the moment:

[tchung@tchung-laptop ~]$ sudo yum --exclude=evolution* update
Comment 2 Thomas Chung 2006-06-06 20:29:47 EDT
Here is the result after the work around metion above:

[tchung@tchung-laptop ~]$ sudo yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/4]
updates                                                              [2/4]
macromedia                                                           [3/4]
extras                                                               [4/4]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for evolution to pack into transaction set.
evolution-2.6.2-1.fc5.1.i 100% |=========================| 127 kB    00:00
---> Package evolution.i386 0:2.6.2-1.fc5.1 set to be updated
---> Downloading header for evolution-data-server to pack into transaction set.
evolution-data-server-1.6 100% |=========================|  97 kB    00:00
---> Package evolution-data-server.i386 0:1.6.2-1.fc5.1 set to be updated
---> Downloading header for evolution-data-server-devel to pack into transaction
set.
evolution-data-server-dev 100% |=========================|  71 kB    00:00
---> Package evolution-data-server-devel.i386 0:1.6.2-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-sharp
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Processing Dependency: libecal-1.2.so.3 for package: evolution
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-webcal
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-sharp
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-webcal
[tchung@tchung-laptop ~]$
Comment 3 Matthew Barnes 2006-06-06 20:38:39 EDT

*** This bug has been marked as a duplicate of 194174 ***
Comment 4 James Allerton-Austin 2006-06-07 11:20:21 EDT
I have also experienced this issue but have found that the library
libedata-cal-1.2.so.1 is also missing. This is a dependency for
evolution-connector only.

Thanks

JAA

output from yum:

Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
core                                                                 [1/3]
updates                                                              [2/3]
extras                                                               [3/3]
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for evolution-data-server to pack into transaction set.
evolution-data-server-1.6 100% |=========================|  97 kB    00:01
---> Package evolution-data-server.i386 0:1.6.2-1.fc5.1 set to be updated
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Processing Dependency: libecal-1.2.so.3 for package: evolution
--> Processing Dependency: libedata-cal-1.2.so.1 for package: evolution-connector
--> Processing Dependency: libecal-1.2.so.3 for package: evolution-connector
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution
Error: Missing Dependency: libedata-cal-1.2.so.1 is needed by package
evolution-connector
Error: Missing Dependency: libecal-1.2.so.3 is needed by package evolution-connector

Note You need to log in before you can comment on or make changes to this bug.