Bug 194306 - Kernel panic on boot - unable to mount root filesystem
Kernel panic on boot - unable to mount root filesystem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-07 02:04 EDT by Ingo Schaefer
Modified: 2015-01-04 17:27 EST (History)
2 users (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 18:40:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ingo Schaefer 2006-06-07 02:04:12 EDT
Description of problem:
After doing yum update a time age, I rebooted the machine and found it not
booting. Further investigation showed, that if I use kernel command line with
LABEL=/ as root device, it says: 
"cannot open root device LABEL=/"
If I change the command line to show /dev/hda3 which is in fact my root
filesystem, it shows 
"Warning: unable to open an initial console", after that initializing security
stuff and then doing nothing more.

The newest update (kernel-2.6.16-1.2111_FC4) has the same problem here.
Version 2.6.15_1831 is working without any problems. (but rather old now)

Version-Release number of selected component (if applicable):
2.6.15_1833 and up

How reproducible:
always

Steps to Reproduce:
1. Install FC4, work some time with it *g*
2. Update to newer kernel
3. Reboot
  
Actual results:
Panic and/or hang system

Expected results:
should boot normal

Additional info:
I thought it could be because a second disk in the system has no labels
associated, so I created labels on /dev/hdb1 and /dev/hdb2 (all different from
/, of course), but this did not resolve the issue.
Comment 1 Ingo Schaefer 2006-07-06 14:12:17 EDT
I tried with every kernel package in updates until the newest 2.6.17 - issue is
still the same. 

This spurious "unable to open initial console" and after initializing selinux
the kernel hangs.

Comment 2 Ingo Schaefer 2006-07-14 06:21:07 EDT
I have rebooted the machine another time and found an error, which I have
overlooked.

After loading the jbd.ko and ext3.ko module from initrd kernel prints following
lines:

Creating root device
umount /initrd/dev failed: 2
EXT2-fs warning (device hda3): ext2_fill_super: mounting ext3 filesystem as ext2
VFS: Mounted root (ext2 filesystem) readonly.
Trying to move old root to /initrd ... /initrd does not exist. Ignored.
Unmounting old root
Trying to free ramdisk memory ... failed
Freeing unused kernel memory: 212k freed
Write protecting the kernel read-only data: 924k
Warning: unable to open an initial console.

now 2 lines with security in front and several with SELinux (all looking
normal); after this the machine is not locked up but not booting further

I am really afraid of updating to FC5 or FC6 if these "new" kernels have
problems on this hardware. 

Any ideas?
Comment 3 Dave Jones 2006-07-16 00:07:38 EDT
what does your /etc/modprobe.conf look like ?
Comment 4 Ingo Schaefer 2006-07-16 04:07:20 EDT
Thanks for your reaction, Dave.

I think the file looks fairly normal. No manual action involved there.

If you need more info, let me know.

These two kernel work:
kernel-2.6.11-1.1369_FC4
kernel-2.6.15-1.1831_FC4

These kernel won't:
kernel-2.6.15-1.1833_FC4
kernel-2.6.16-1.2111_FC4
kernel-2.6.17-1.2139_FC4

--- /etc/modprobe.conf
alias eth0 8139too
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-emu10k1
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
# I2C module options
alias char-major-89 i2c-dev
---
Comment 5 Ingo Schaefer 2006-07-24 08:17:21 EDT
Hello there,

I looked into the sources of the two kernel variants of the 2.6.15 from which
one is working and the other one not.

There are just little changed, but one of them must be the important one, which
breaks booting here.

1. In the file /drivers/video/Kconfig the default for FB_GBE_MEM was changed
from 8 MB to 4 MB
2. in file /include/linux/security.h lines 1437 ff. were introduced, which look
like 
if (unlikely (IS_PRIVATE (inode)))
	return 0;
a.s.o.
3. in file types.h one define was added: define BITS_PER_BYTE 8
4. config boot delay was added/introduced - but I don't set this option in my
kernel command line
5. ipw2200 monitor mode was added

Maybe one could tell me which could cause the problem?

My first guess was this security/selinux stuff, so I issued "restorecon -R -F
/"  but this changed nothing.

Regards,
Ingo
Comment 6 Dave Jones 2006-09-16 21:54:50 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 7 Ingo Schaefer 2006-09-18 03:15:28 EDT
I recently updated this particular machine to FC5 (and made sure the working
kernel stays there - just in case)

It is now running 2.6.17-1.2174_FC5 without any problems.
Comment 8 Dave Jones 2006-10-16 16:43:41 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 9 Ingo Schaefer 2006-10-17 02:43:31 EDT
As I wrote the last time: 

The problem was solved by upgrading to FC5.

Regards,
Ingo

Note You need to log in before you can comment on or make changes to this bug.