Bug 194310 - broken dependency while upgrading
broken dependency while upgrading
Status: CLOSED DUPLICATE of bug 194174
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-07 02:48 EDT by Igor Jagec
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 06:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Jagec 2006-06-07 02:48:02 EDT
Description of problem:

# yum update
...
--> Running transaction check
--> Processing Dependency: libecal-1.2.so.3 for package: gnome-panel
--> Finished Dependency Resolution
Error: Missing Dependency: libecal-1.2.so.3 is needed by package gnome-panel

[root@munja dict]# locate libecal-1.2.so.3
/usr/lib/libecal-1.2.so.3
/usr/lib/libecal-1.2.so.3.2.8

# rpm -qf /usr/lib/libecal-1.2.so.3
evolution-data-server-1.6.1-1.fc5.2
Comment 1 Peter Bieringer 2006-06-07 05:32:29 EDT
Prio should be set to high, because yum update is broken now on at least 3
systems here. Looks like a deadlock, can't be solved easily.

# rpm -q evolution-data-server
evolution-data-server-1.6.1-1.fc5.2

# rpm -ql evolution-data-server | grep libecal-
/usr/lib/libecal-1.2.so.3
/usr/lib/libecal-1.2.so.3.2.8

# rpm -q gnome-panel
gnome-panel-2.14.1-1.fc5.1

# wget http://url-to/evolution-data-server-1.6.2-1.fc5.1.i386.rpm

# LANG=C rpm -Fhv evolution-data-server-1.6.2-1.fc5.1.i386.rpm
error: Failed dependencies:
        libecal-1.2.so.3 is needed by (installed) gnome-panel-2.14.1-1.fc5.1.i386

# rpm -qlp evolution-data-server-1.6.2-1.fc5.1.i386.rpm | grep libecal-
/usr/lib/libecal-1.2.so.6
/usr/lib/libecal-1.2.so.6.0.0

Ooops!

Oroblem is caused by evolution-data-server-1.6.2-1.fc5.1 in update repository,
which includes a newer libecal than gnome-panel in update is linked to.

Why hasn't this detected by QA?

Result: automatic yum update of *all* clients is currenty broken, even security
updates!

Please fix this as soon as possible, either by removing
evolution-data-server-1.6.2-1.fc5.1.i386.rpm from update repository or push a
gnome-panel into repository, which is linked against .

*Manual* workaround:
# yum update --exclude evolution-data-server

@gor Jagec: please increase severity/priority
Comment 3 Nigel Metheringham 2006-06-07 05:49:03 EDT
Duplicate of Bug #194174

Will be CLOSED/DUPLICATE as soon as someone with sufficient rights hits it.
Do not add further commentary to this bug report.
Comment 4 Marcin Garski 2006-06-07 06:23:04 EDT

*** This bug has been marked as a duplicate of 194174 ***

Note You need to log in before you can comment on or make changes to this bug.