Bug 19446 - Anaconda crashes using update image
Anaconda crashes using update image
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 20078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-20 01:47 EDT by Patrick Coffey
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-07 10:54:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Core dump file saved by installation program (6.13 KB, text/plain)
2000-10-20 01:49 EDT, Patrick Coffey
no flags Details

  None (edit)
Description Patrick Coffey 2000-10-20 01:47:30 EDT
Here is the dump the installation program asked me to send you:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in 
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 245, in 
__call__
  File "/tmp/updates/todo.py", line 841, in upgradeFindRoot
    mdList = raid.startAllRaid(drives)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/raid.py", line 61, in 
startAllRaid
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/raid.py", line 25, in 
scanForRaid
  File "/usr/lib/anaconda/isys.py", line 37, in raidsb
    rc = _isys.getraidsb(fd)
ValueError: bad md magic on device

Local variables in innermost frame:
mdDevice: hdc1
fd: 15

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://ftp.metalab.unc.edu/pub/linux/distributions/redhat/redhat-
7.0/i386/en'
sbsS'initlevel'
p7
I3
sS'progressWindow'
p8
NsS'expert'
p9
I1
sS'ddruidReadOnly'
p10
I0
sS'bootdisk'
p11
I0
sS'language'
p12
(itodo
Language
(dp13
S'abbrevMap'
p14
(dp15
S'es_ES'
p16
S'Spanish'
p17
sS'tr_TR'
p18
S'Turkish'
p19
sS'sr_YU'
p20
S'Serbian'
p21
sS'de_DE'
p22
S'German'
p23
sS'sk_SK'
p24
S'Slovak'
p25
sS'ru_RU.KOI8-R'
p26
S'Russian'
p27
sS'is_IS'
p28
S'Icelandic'
p29
sS'no_NO'
p30
S'Norwegian'
p31
sS'sv_SE'
p32
S'Swedish'
p33
sS'en_US'
p34
S'English'
p35
sS'it_IT'
p36
S'Italian'
p37
sS'da_DK'
p38
S'Danish'
p39
sS'cs_CZ'
p40
S'Czech'
p41
sS'uk_UA.KOI8-U'
p42
S'Ukrainian'
p43
sS'hu_HU'
p44
S'Hungarian'
p45
sS'fr_FR'
p46
S'French'
p47
sS'sl_SI'
p48
S'Slovenian'
p49
sS'ro_RO'
p50
S'Romanian'
p51
ssS'font'
p52
(dp53
g37
S'lat0-sun16'
sg21
S'cyr-sun16'
sg27
S'cyr-sun16'
sg35
S'None'
sg25
S'lat2-sun16'
sg31
S'lat0-sun16'
sg33
S'lat0-sun16'
sg47
S'None'
sg49
S'lat2-sun16'
sg51
S'lat2-sun16'
sg23
S'None'
sg19
S'lat5-sun16'
sg45
S'lat2-sun16'
sg17
S'None'
sg43
S'cyr-sun16'
sg41
S'lat2-sun16'
sg39
S'lat0-sun16'
sg29
S'lat0-sun16'
ssS'langs'
p54
(dp55
g37
g36
sg21
g20
sg27
g26
sg35
g34
sg25
g24
sg31
g30
sg33
g32
sg47
g46
sg49
g48
sg51
g50
sg23
g22
sg19
g18
sg45
g44
sg17
g16
sg43
g42
sg41
g40
sg39
g38
sg29
g28
ssS'info'
p56
(dp57
S'LANG'
p58
g34
ssS'map'
p59
(dp60
g37
S'iso15'
sg21
S'iso05'
sg27
S'koi8-r'
sg35
S'None'
sg25
S'iso02'
sg31
S'iso15'
sg33
S'iso15'
sg47
S'None'
sg49
S'iso02'
sg51
S'iso02'
sg23
S'None'
sg19
S'iso09'
sg45
S'iso02'
sg17
S'None'
sg43
S'koi8-u'
sg41
S'iso02'
sg39
S'iso15'
sg29
S'iso15'
ssS'lang'
p61
g34
sbsS'fstab'
p62
NsS'lilo'
p63
(ililo
LiloConfiguration
(dp64
S'liloDevice'
p65
S'mbr'
p66
sS'initrdsMade'
p67
(dsS'edd'
p68
I0
sS'default'
p69
NsS'liloImages'
p70
(dsS'liloLinear'
p71
I1
sS'liloAppend'
p72
S''
sbsS'comps'
p73
NsS'network'
p74
(itodo
Network
(dp75
S'netdevices'
p76
(dp77
S'eth0'
p78
(itodo
NetworkDevice
(dp79
g56
(dp80
S'BOOTPROTO'
p81
S'dhcp'
sS'ONBOOT'
p82
S'yes'
sS'DEVICE'
p83
g78
ssbssS'gateway'
p84
S''
sS'secondaryNS'
p85
S'130.207.244.251'
sS'hostname'
p86
S'localhost.localdomain'
p87
sS'primaryNS'
p88
S'192.168.111.1'
sS'domains'
p89
(lp90
S'polter.net'
asS'isConfigured'
p91
I1
sS'readData'
p92
I1
sS'ternaryNS'
p93
S''
sbsS'upgrade'
p94
I1
sS'instClass'
p95
(iinstallclass
DefaultInstall
p96
(dp97
S'rootPasswordCrypted'
p98
I0
sS'nameserver'
p99
S''
sS'x'
NsS'rootPassword'
p100
NsS'makeBootdisk'
p101
I0
sS'installType'
p102
NsS'postScript'
p103
NsS'earlySwapOn'
p104
I0
sS'networkDevice'
p105
NsS'clearText'
p106
Nsg63
(g66
I1
S''
tsg12
S'en_US'
p107
sS'name'
p108
S''
sS'postInChroot'
p109
I0
sS'pixmap'
p110
S''
sS'partitions'
p111
(lsS'clearType'
p112
Nsg84
S''
sS'mouse'
p113
NsS'packages'
p114
NsS'timezone'
p115
NsS'zeroMbr'
p116
I0
sS'keyboard'
p117
S'us'
p118
sS'groups'
p119
NsS'bootProto'
p120
NsS'netmask'
p121
S''
sS'raidList'
p122
(lsS'skipSteps'
p123
(dp124
g117
I1
sg12
I1
ssS'auth'
p125
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsg86
Nsg62
(lsS'showgroups'
p126
NsS'ip'
p127
S''
sS'defaultRunlevel'
p128
NsS'desktop'
p129
S''
sS'clearPartText'
p130
NsS'clearParts'
p131
I0
sbsS'rootpassword'
p132
NsS'extraModules'
p133
(lp134
sg113
(imouse
Mouse
p135
(dp136
S'device'
p137
S'psaux'
p138
sg56
(dp139
S'XMOUSETYPE'
p140
S'none'
p141
sS'FULLNAME'
p142
S'None - None'
p143
sS'MOUSETYPE'
p144
g141
ssS'emu'
p145
I0
sS'wasProbed'
p146
I0
sS'emulate'
p147
I0
sbsS'ddruidAlreadySaved'
p148
I0
sS'serial'
p149
I0
sg115
Nsg116
I0
sg117
(ikbd
Keyboard
(dp150
S'layout'
p151
NsS'model'
p152
NsS'type'
p153
S'PC'
p154
sg56
(dp155
S'KEYBOARDTYPE'
p156
S'pc'
p157
sS'KEYTABLE'
p158
g118
ssbsS'fdDevice'
p159
S'fd0'
p160
sS'installSystem'
p161
I1
sS'setupFilesystems'
p162
I1
sg125
(itodo
Authentication
(dp163
S'useNIS'
p164
I0
sS'nisServer'
p165
S''
sS'useLdap'
p166
I0
sS'krb5Kdc'
p167
S''
sS'useHesiod'
p168
I0
sS'ldapServer'
p169
S''
sS'nisDomain'
p170
S''
sS'krb5Realm'
p171
S''
sS'useLdapauth'
p172
I0
sS'hesiodRhs'
p173
S''
sS'useShadow'
p174
I1
sS'nisuseBroadcast'
p175
I0
sS'useKrb5'
p176
I0
sS'useMD5'
p177
I1
sS'ldapBasedn'
p178
S''
sS'krb5Admin'
p179
S''
sS'hesiodLhs'
p180
S''
sS'hesiodDlhs'
p181
S''
sbsg86
NsS'reconfigOnly'
p182
I0
sS'x'
(ixf86config
XF86Config
(dp183
S'monlist'
p184
(dsS'keyModel'
p185
S'pc101'
p186
sS'monids'
p187
(dsg137
NsS'monEisa'
p188
NsS'server'
p189
NsS'monHoriz'
p190
S'31.5'
p191
sS'devID'
p192
NsS'modes'
p193
(dp194
S'8'
(lp195
S'640x480'
p196
assS'keyOptions'
p197
S''
sS'keyVariant'
p198
S''
sS'monID'
p199
S'Unprobed Monitor'
p200
sS'keyLayout'
p201
S'us'
p202
sS'manualModes'
p203
(dsg113
g135
sS'keyRules'
p204
S'xfree86'
p205
sS'monVert'
p206
S'60'
p207
sS'cardMan'
p208
NsS'monSect'
p209
S''
sS'primary'
p210
I0
sS'vidRam'
p211
NsS'probed'
p212
I0
sS'monName'
p213
NsS'vidCards'
p214
(lsS'skip'
p215
I0
sS'files'
p216
S'\012# The location of the RGB database.  Note, this is the name of 
the\012# file minus the extension (like ".txt" or ".db").  There is 
normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and 
later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012    
FontPath   "unix/:7100"\012'
p217
sbsS'users'
p218
NsS'instPath'
p219
S'/mnt/sysimage'
p220
sS'intf'
p221
NsS'hdList'
p222
Nsb.
Comment 1 Patrick Coffey 2000-10-20 01:49:12 EDT
Created attachment 4448 [details]
Core dump file saved by installation program
Comment 2 Michael Fulbright 2000-10-27 17:57:49 EDT
What is on partition /dev/hdc1, and how was it created?

It seems like it is marked as a RAID partition but it does not contain an actual
RAID partition.

Is this an upgrade or install?

Comment 3 Patrick Coffey 2000-10-30 09:25:32 EST
* partition /dev/hdc1 is FAT32 and contains a bunch of old windows98 files.
* I was doing an upgrade from RedHat 6.2. Originally when I installed 6.2, I 
told it to make /dev/hdc1 a RAID disk (Yes, I didn't know what I was doing). 
Despite my naivete, 6.2 still installed okay, still read the files from hdc1 
after the install was complete, and just gave me a quick warning message during 
bootup that reminded me that hdc1 is not a valid RAID partition.

Comment 4 Brock Organ 2000-11-07 10:54:17 EST
does your system still consider this a RAID partition (ie entries in
/etc/raidtab, etc.) ...?  Are you able to remove the references to hdc1 as a
RAID-able partition ...?

Having a FAT filesystem seen as a RAID-able partition is an irregular case, and
could lead to unpredictable (and undesirable!) results in the future ... :(
Comment 5 Brent Fox 2001-06-12 21:56:58 EDT
*** Bug 20078 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.