Bug 20078 - Partition damaged and unuseable after setup crash.
Partition damaged and unuseable after setup crash.
Status: CLOSED DUPLICATE of bug 19446
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-30 21:36 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-12 21:57:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-30 21:36:31 EST
After picking my packages during setup, the setup program began formatting 
my drive. During the format it crashed, giving an error that it had run 
out of TMP space. Unfortunately I did not get the debug info :)

Now, whenever I try and run setup, fdisk, or Disk Druid, I am unable to 
access my drive completely. If I boot into Win98, I can run fdisk and try 
to delete the partitions, but once I reboot the damaged Linux ones are 
still there.

I am now unable to setup Linux on my hard drive as it is not being 
recognized. Here is the error that Anaconda is returning now:

----------------------------------------
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/examine_gui.py", line 
30, in getScreen
    self.parts = self.todo.upgradeFindRoot ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 841, in 
upgradeFindRoot
    mdList = raid.startAllRaid(drives)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/raid.py", line 61, in 
startAllRaid
    for (mdDevice, deviceList) in scanForRaid(driveList):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/raid.py", line 25, in 
scanForRaid
    (major, minor, raidSet, level, nrDisks, totalDisks, mdMinor) = \
  File "/usr/lib/anaconda/isys.py", line 37, in raidsb
    rc = _isys.getraidsb(fd)
ValueError: bad md magic on device

Local variables in innermost frame:
mdDevice: hdb2
fd: 17

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
-----------------------------------------------
Comment 1 Michael Fulbright 2000-10-31 11:00:58 EST
It isn't clear to me what happened here. The traceback you supplied is from an
attempted upgrade, but if you were having partitiions getting formatted then you
were doing an install.  Partitions are not formatted during an upgrade.

I would recommend you attempt the installation again if you don't have any data
you need to save.

This is probably a dupe of 19446.
Comment 2 Need Real Name 2000-10-31 14:42:35 EST
As noted above, I was unable to capture the original debug info. I tried 
several things to recover my hard drive, and an upgrade may have been one of 
them. The debug info that I attached may be completely usless to you.

The original crash occured during the format of my partition. It said that it 
ran out of tmp space.

As mentioned before, regardless of how many times I restart setup, neither Disk 
Druid or fdisk are able to access my hard drive. I would love to start a clean 
install as you mentioned, but am unable to access my drive.

Also, I do not have the privileges to view bug 19446, so I have no way of 
verifying whether this is the same thing (yes, I was logged in).
Comment 3 Need Real Name 2000-11-03 13:07:54 EST
Here's what else I've figured out. This is from a post I made to RH support:

I couldn't wait around for tech support, so here's what I did and what I've 
determined: I tried both "Partition Magic" and "Norton Utilities" on my drive 
and they told me that the Extended partition was damaged. The only way that I 
could manage to change the partition information was to boot up in Windows2000 
and delete everything. After re-establishing my DOS partion and NTFS partition, 
I went through the install again and the same thing happened. So, I repeated 
the process of deleting and re-establishing my partitions and tried a RH 6.2 
install. THE SAME THING HAPPENED!

What I finally noticed was that my 6GB hard drive shows up as an 8GB hard drive 
in Disk Druid (under RH 6.2 and 7.0). So, in reality I may only have 1GB of 
space left for RH, but disk druid tells me that I have 3GB! When it tries to 
format the 3GB, it formats for about 10minutes then the install crashes and 
says that it's out of TMP space. After figuring this out, I redid the entire 
process and this time only allocated what I knew was free on my drive to RH. 
The install went perfectly after that. 

I really hope someone actually reads this and makes a note of it in bugzilla... 
I have already tried writing bugzilla but they seem pretty un-receptive. 
Thanks. I'm not going to close this just yet because I want to make sure that 
someone actaully reads this and looks into it. This is a pretty major bug and 
it's terrible that it is happening in both RH 6.2 and 7.0!
Comment 4 Brent Fox 2001-06-12 21:57:03 EDT

*** This bug has been marked as a duplicate of 19446 ***

Note You need to log in before you can comment on or make changes to this bug.