Bug 19453 - Anaconda Install failure during upgrade 6.2 to 7.0 with updated install
Summary: Anaconda Install failure during upgrade 6.2 to 7.0 with updated install
Status: CLOSED DUPLICATE of bug 18031
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-20 10:48 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-03 20:18:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-10-20 10:48:52 UTC
The following error occurred using the original v7.0 and lastest update (update-disk-20001009.img) of the anaconda installer while trying to 
update version 6.2 to version 7.0:    (This is the output of the anacdump.txt file)
The errors appear to be similiar to but not exactly the same as bug# 18876,19137,19234,19346



Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1028, in run
    rc = apply (step[1](), (dir,) + step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 279, in __call__
    todo.upgradeFindPackages (root)
  File "/tmp/updates/todo.py", line 941, in upgradeFindPackages
    self.getCompsList ()
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in readCompsFile
    comp.addPackage(packages[l])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in __getitem__
    return self.packages[item]
KeyError: MAKEDEV

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 8229e60>
item: MAKEDEV

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 Michael Fulbright 2000-10-27 22:00:31 UTC
If you burned this CD image yourself make sure the ISO you downloaded matches
the md5sum given on the ftp site. Most likely you have a bad CD.

Comment 2 Need Real Name 2000-10-31 03:29:49 UTC
This error was first experienced with the deluxe retail package for v7.  The update was attempted again using the new anaconda update image 20001009.
I do not believe this to be a corrupt image problem, unless it was corrupt on the v7 retail package.  Has there been any reported image problems?



Comment 3 Michael Fulbright 2000-11-03 20:18:48 UTC
I do not know of any issues - this error occurs when the MAKEDEV package does
not exist on the CD, or it could not be read.  That points at either a media
error, or a problem with the CDROM drive.

You may want to consider getting replacement CDs.

*** This bug has been marked as a duplicate of 18031 ***


Note You need to log in before you can comment on or make changes to this bug.