Bug 194536 - FC5: Asian TrueType font encoding entries are missing on fonts.scale
FC5: Asian TrueType font encoding entries are missing on fonts.scale
Status: CLOSED DUPLICATE of bug 204893
Product: Fedora
Classification: Fedora
Component: ttmkfdir (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Liang Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-08 16:17 EDT by IBM Bug Proxy
Modified: 2015-04-06 23:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-08 21:57:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2006-06-08 16:17:27 EDT
Problem description:
According to following URL:
  http://www.redhat.com/archives/fedora-announce-list/2005-August/msg00017.html
On FC4, it can create Asian TrueType font encoding entries on fonts.scale.
On FC5, even if ttmkfdir-3.0.9-19.2.1 package has the latest fix, it seems 
fonts.scale does not have TrueType font encoding entries:
=======================================================
$ cat /usr/share/fonts/japanese/TrueType/fonts.scale
19
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-ascii-0
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso10646-1
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-1
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-10
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-13
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-15
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-2
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-3
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-4
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-5
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-7
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-iso8859-9
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-koi8-r
sazanami-mincho.ttf -misc-Sazanami Mincho-medium-r-normal--0-0-0-0-c-0-koi8-ru
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-ascii-0
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso10646-1
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso8859-1
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso8859-15
sazanami-gothic.ttf -misc-Sazanami Gothic-medium-r-normal--0-0-0-0-c-0-iso8859-9
=======================================================

This was seen and fixed in RHEL4 in
  
https://enterprise.redhat.com/issue-tracker/?module=issues&action=view&tid=82230&gid=43
Comment 1 Mike A. Harris 2006-06-14 00:09:55 EDT
ttmkfdir is not part of xorg-x11.
Comment 2 Adam Jackson 2006-10-04 11:20:11 EDT
Move to ttmkfdir.
Comment 3 Liang Zhang 2006-10-08 21:52:34 EDT
It seems to be same as bug204893.
Comment 4 Liang Zhang 2006-10-08 21:54:30 EDT
I found the reason which creates this bug is relative to encodings.dir of X11.
The encodings.dir of FC-5 (/usr/share/X11/fonts/encodings/encodings.dir) doesn't
include the encodings in the "large" sub-dir, so encodings.dir doesn't include
the CJK encodings. Then ttmkfdir can not find the CJK encodings through scaning
encodings.dir, therefore, there are not CJK encodings in the fonts.dir which is
created by ttmkfdir.
The encodings.dir of RHEL-4 (/usr/X11R6/lib/X11/fonts/encodings/encodings.dir)
includes the encodings in the "large" sub-dir, so there are CJK encodings in the
fonts.dir.
So I think this bug is not a bug of ttmkfdir, but a bug of encodings.dir of X11.
encodings.dir of FC-5 must include the encodings in the "large" sub-dir.
I need some information which the maintainer of X11 gives me about encodings.dir
of X11.
Thanks.
Comment 5 Liang Zhang 2006-10-08 21:57:24 EDT

*** This bug has been marked as a duplicate of 204893 ***

Note You need to log in before you can comment on or make changes to this bug.