Bug 204893 - no CJK encodings in fonts.dir
no CJK encodings in fonts.dir
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-fonts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: i18n
: 194536 (view as bug list)
Depends On:
Blocks: FC6Blocker 209102
  Show dependency treegraph
 
Reported: 2006-09-01 00:33 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 13:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2006-09-01 00:33:02 EDT
Description of problem:
ttmkfdir doesn't generate valid XLFDs for CJK.

Version-Release number of selected component (if applicable):
ttmkfdir-3.0.9-20.2.1

How reproducible:
always

Steps to Reproduce:
1.look around /usr/share/fonts/*/TrueType/fonts.dir
2.
3.
  
Actual results:
no CJK encodings

Expected results:
should contain CJK encodings as needed.

Additional info:
it may be caused by moving the X encoding files to
/usr/share/X11/fonts/encodings since modular X has been entered into Core.
Comment 1 sangu 2006-09-19 23:14:15 EDT
Please see : https://bugs.freedesktop.org/show_bug.cgi?id=7199
Is this the same problem?
Comment 2 Akira TAGOH 2006-09-20 01:06:33 EDT
Not really. we don't use mkfontscale to generate fonts.scale for
TrueType/OpenType fonts.
Comment 3 Liang Zhang 2006-09-26 03:51:30 EDT
I found /usr/share/X11/fonts/encodings/encodings.dir, it only has 39 encodings:

39
iso8859-16 /usr/share/X11/fonts/encodings/iso8859-16.enc.gz
microsoft-win3.1 /usr/share/X11/fonts/encodings/microsoft-win3.1.enc.gz
microsoft-cp1250 /usr/share/X11/fonts/encodings/microsoft-cp1250.enc.gz
suneu-greek /usr/share/X11/fonts/encodings/suneu-greek.enc.gz
microsoft-ansi /usr/share/X11/fonts/encodings/microsoft-cp1252.enc.gz
microsoft-cp1252 /usr/share/X11/fonts/encodings/microsoft-cp1252.enc.gz
tis620-2 /usr/share/X11/fonts/encodings/tis620-2.enc.gz
mulearabic-0 /usr/share/X11/fonts/encodings/mulearabic-0.enc.gz
microsoft-cp1256 /usr/share/X11/fonts/encodings/microsoft-cp1256.enc.gz
mulearabic-1 /usr/share/X11/fonts/encodings/mulearabic-1.enc.gz
ibm-cp852 /usr/share/X11/fonts/encodings/ibm-cp852.enc.gz
mulearabic-2 /usr/share/X11/fonts/encodings/mulearabic-2.enc.gz
iso8859-13 /usr/share/X11/fonts/encodings/iso8859-13.enc.gz
microsoft-cp1257 /usr/share/X11/fonts/encodings/microsoft-cp1257.enc.gz
ibm-cp866 /usr/share/X11/fonts/encodings/ibm-cp866.enc.gz
adobe-dingbats /usr/share/X11/fonts/encodings/adobe-dingbats.enc.gz
microsoft-cp1258 /usr/share/X11/fonts/encodings/microsoft-cp1258.enc.gz
dec-special /usr/share/X11/fonts/encodings/dec-special.enc.gz
iso8859-6.16 /usr/share/X11/fonts/encodings/iso8859-6.16.enc.gz
mulelao-1 /usr/share/X11/fonts/encodings/mulelao-1.enc.gz
tcvn-0 /usr/share/X11/fonts/encodings/tcvn-0.enc.gz
iso8859-6.8x /usr/share/X11/fonts/encodings/iso8859-6.8x.enc.gz
microsoft-cp1253 /usr/share/X11/fonts/encodings/microsoft-cp1253.enc.gz
ibm-cp437 /usr/share/X11/fonts/encodings/ibm-cp437.enc.gz
adobe-standard /usr/share/X11/fonts/encodings/adobe-standard.enc.gz
armscii-8 /usr/share/X11/fonts/encodings/armscii-8.enc.gz
ascii-0 /usr/share/X11/fonts/encodings/ascii-0.enc.gz
microsoft-cp1254 /usr/share/X11/fonts/encodings/microsoft-cp1254.enc.gz
microsoft-cp1251 /usr/share/X11/fonts/encodings/microsoft-cp1251.enc.gz
microsoft-cp1255 /usr/share/X11/fonts/encodings/microsoft-cp1255.enc.gz
adobe-symbol /usr/share/X11/fonts/encodings/adobe-symbol.enc.gz
tis620.2533-0 /usr/share/X11/fonts/encodings/iso8859-11.enc.gz
tis620.2533-1 /usr/share/X11/fonts/encodings/iso8859-11.enc.gz
tis620.2529-1 /usr/share/X11/fonts/encodings/iso8859-11.enc.gz
tis620-0 /usr/share/X11/fonts/encodings/iso8859-11.enc.gz
iso8859-11 /usr/share/X11/fonts/encodings/iso8859-11.enc.gz
ansi-1251 /usr/share/X11/fonts/encodings/ansi-1251.enc.gz
ibm-cp850 /usr/share/X11/fonts/encodings/ibm-cp850.enc.gz
viscii1.1-1 /usr/share/X11/fonts/encodings/viscii1.1-1.enc.gz
Comment 4 Liang Zhang 2006-09-26 03:52:59 EDT
/usr/X11R6/lib/X11/fonts/encodings/encodings.dir has 93 encodings:

93
sun.unicode.india-0 large/sun.unicode.india-0.enc.gz
ksxjohab-1 large/ksc5601.1992-3.enc.gz
ksx1001.1998-3 large/ksc5601.1992-3.enc.gz
ksc5601.1992-3 large/ksc5601.1992-3.enc.gz
ksx1001.1997-0 large/ksc5601.1987-0.enc.gz
ksx1001.1998-0 large/ksc5601.1987-0.enc.gz
ksc5601.1987-0 large/ksc5601.1987-0.enc.gz
jisx0212.1990-0 large/jisx0212.1990-0.enc.gz
jisx0208.1983-0 large/jisx0208.1990-0.enc.gz
jisx0208.1990-0 large/jisx0208.1990-0.enc.gz
jisx0201.1976-0 large/jisx0201.1976-0.enc.gz
gb18030.2000-1 large/gb18030.2000-1.enc.gz
gb18030.2000-0 large/gb18030.2000-0.enc.gz
gbk-0 large/gbk-0.enc.gz
gb2312.1980-0 large/gb2312.1980-0.enc.gz
cns11643-3 large/cns11643-3.enc.gz
cns11643-3 large/cns11643-3.enc.gz
cns11643-2 large/cns11643-2.enc.gz
cns11643-2 large/cns11643-2.enc.gz
cns11643-1 large/cns11643-1.enc.gz
cns11643-1 large/cns11643-1.enc.gz
big5hkscs-0 large/big5hkscs-0.enc.gz
big5.cp950-0 large/big5.eten-0.enc.gz
big5-0 large/big5.eten-0.enc.gz
big5.eten-0 large/big5.eten-0.enc.gz
gb18030.2000-1 large/gb18030.2000-1.enc
ksxjohab-1 large/ksc5601.1992-3.enc
ksx1001.1998-3 large/ksc5601.1992-3.enc
ksc5601.1992-3 large/ksc5601.1992-3.enc
jisx0212.1990-0 large/jisx0212.1990-0.enc
big5.cp950-0 large/big5.eten-0.enc
big5-0 large/big5.eten-0.enc
big5.eten-0 large/big5.eten-0.enc
jisx0201.1976-0 large/jisx0201.1976-0.enc
cns11643-1 large/cns11643-1.enc
cns11643-1 large/cns11643-1.enc
sun.unicode.india-0 large/sun.unicode.india-0.enc
gbk-0 large/gbk-0.enc
gb18030.2000-0 large/gb18030.2000-0.enc
jisx0208.1983-0 large/jisx0208.1990-0.enc
jisx0208.1990-0 large/jisx0208.1990-0.enc
cns11643-3 large/cns11643-3.enc
cns11643-3 large/cns11643-3.enc
big5hkscs-0 large/big5hkscs-0.enc
ksx1001.1997-0 large/ksc5601.1987-0.enc
ksx1001.1998-0 large/ksc5601.1987-0.enc
ksc5601.1987-0 large/ksc5601.1987-0.enc
gb2312.1980-0 large/gb2312.1980-0.enc
cns11643-2 large/cns11643-2.enc
cns11643-2 large/cns11643-2.enc
viscii1.1-1 ./viscii1.1-1.enc.gz
adobe-symbol ./adobe-symbol.enc.gz
adobe-standard ./adobe-standard.enc.gz
adobe-dingbats ./adobe-dingbats.enc.gz
microsoft-win3.1 ./microsoft-win3.1.enc
ibm-cp850 ./ibm-cp850.enc
armscii-8 ./armscii-8.enc
iso8859-16 ./iso8859-16.enc
microsoft-cp1254 ./microsoft-cp1254.enc
microsoft-cp1253 ./microsoft-cp1253.enc
microsoft-cp1255 ./microsoft-cp1255.enc
ibm-cp852 ./ibm-cp852.enc
viscii1.1-1 ./viscii1.1-1.enc
microsoft-cp1257 ./microsoft-cp1257.enc
tcvn-0 ./tcvn-0.enc
mulearabic-0 ./mulearabic-0.enc
dec-special ./dec-special.enc
ibm-cp437 ./ibm-cp437.enc
ansi-1251 ./ansi-1251.enc
microsoft-ansi ./microsoft-cp1252.enc
microsoft-cp1252 ./microsoft-cp1252.enc
adobe-standard ./adobe-standard.enc
microsoft-cp1258 ./microsoft-cp1258.enc
ascii-0 ./ascii-0.enc
iso8859-6.8x ./iso8859-6.8x.enc
iso8859-13 ./iso8859-13.enc
tis620-2 ./tis620-2.enc
tis620.2533-0 ./iso8859-11.enc
tis620.2533-1 ./iso8859-11.enc
tis620.2529-1 ./iso8859-11.enc
tis620-0 ./iso8859-11.enc
iso8859-11 ./iso8859-11.enc
microsoft-cp1251 ./microsoft-cp1251.enc
suneu-greek ./suneu-greek.enc
mulearabic-2 ./mulearabic-2.enc
adobe-dingbats ./adobe-dingbats.enc
ibm-cp866 ./ibm-cp866.enc
mulearabic-1 ./mulearabic-1.enc
adobe-symbol ./adobe-symbol.enc
iso8859-6.16 ./iso8859-6.16.enc
mulelao-1 ./mulelao-1.enc
microsoft-cp1250 ./microsoft-cp1250.enc
microsoft-cp1256 ./microsoft-cp1256.enc
Comment 5 Liang Zhang 2006-09-26 03:54:38 EDT
the first one is in FC5, the second one is in RHEL4.
I think the encodings.dir creates this bug.
Comment 6 Liang Zhang 2006-09-27 04:11:13 EDT
I found the reason which creates this bug is relative to encodings.dir of X11.
The encodings.dir of FC-5 (/usr/share/X11/fonts/encodings/encodings.dir) doesn't
include the encodings in the "large" sub-dir, so encodings.dir doesn't include
the CJK encodings. Then ttmkfdir can not find the CJK encodings through scaning
encodings.dir, therefore, there are not CJK encodings in the fonts.dir which is
created by ttmkfdir.
The encodings.dir of RHEL-4 (/usr/X11R6/lib/X11/fonts/encodings/encodings.dir)
includes the encodings in the "large" sub-dir, so there are CJK encodings in the
fonts.dir.
So I think this bug is not a bug of ttmkfdir, but a bug of encodings.dir of X11.
encodings.dir of FC-5 must include the encodings in the "large" sub-dir.
I need some information which the maintainer of X11 gives me about encodings.dir
of X11.
Thanks.
Comment 7 Liang Zhang 2006-10-08 21:57:26 EDT
*** Bug 194536 has been marked as a duplicate of this bug. ***
Comment 8 Kristian Høgsberg 2006-10-12 13:56:31 EDT
Here's a build of the fonts package that has a encodings.dir file that works as
before:

  http://people.redhat.com/krh/xorg-x11-fonts-base-7.1-2.bz209102.noarch.rpm

Please give it a try and see if it fixes the issue.

thanks,
Kristia
Comment 9 Akira TAGOH 2006-10-13 04:26:15 EDT
Yes, after installed the above package, I got the large encodings in fonts.dir
that regenerated by ttmkfdir 3.0.9-22.
Comment 10 Kristian Høgsberg 2006-10-16 13:33:29 EDT
Fixed in rawhide: xorg-x11-fonts-7.1-3, will do an fc6 update once that opens up.
Comment 11 IBM Bug Proxy 2007-01-25 06:50:55 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED
             Impact|------                      |Usability




------- Additional Comments From takiguc@jp.ibm.com  2007-01-25 06:48 EDT -------
I verified following SRPM file for this problem on FC6.
http://mirrors.dotsrc.org/fedora/development/source/SRPMS/xorg-x11-fonts-7.1-
3.fc7.src.rpm
I could see following entries.
=============================================
37
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-ascii-0
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-iso10646-
1
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-iso8859-
15
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-iso8859-1
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-iso8859-9
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-
jisx0208.1983-0
sazanami-gothic.ttf -misc-sazanami gothic-medium-r-normal--0-0-0-0-c-0-
jisx0208.1990-0
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-adobe-
standard
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-adobe-
symbol
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-ansi-1251
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-ascii-0
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-ibm-cp437
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-ibm-cp850
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-ibm-cp852
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-ibm-cp866
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso10646-
1
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-1
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-
10
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-
13
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-
15
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-
16
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-2
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-3
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-4
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-5
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-7
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-iso8859-9
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
jisx0208.1983-0
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
jisx0208.1990-0
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
jisx0212.1990-0
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-koi8-ru
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-koi8-r
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
microsoft-ansi
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
microsoft-cp1250
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
microsoft-cp1251
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-
microsoft-cp1252
sazanami-mincho.ttf -misc-sazanami mincho-medium-r-normal--0-0-0-0-c-0-suneu-
greek
===================================================== 

Note You need to log in before you can comment on or make changes to this bug.