Bug 1945740 - vagrant seems to be missing a dependency on rexml
Summary: vagrant seems to be missing a dependency on rexml
Alias: None
Product: Fedora
Classification: Fedora
Component: vagrant-libvirt
Version: 34
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Pavel Valena
QA Contact: Fedora Extras Quality Assurance
: 1959350 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2021-04-01 19:55 UTC by Emilio Cobos Álvarez (:emilio)
Modified: 2021-05-19 01:21 UTC (History)
15 users (show)

Fixed In Version: vagrant-libvirt-0.4.1-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2021-05-19 01:21:56 UTC
Type: Bug

Attachments (Terms of Use)
Another issue (same project) (6.60 KB, text/plain)
2021-04-01 19:57 UTC, Emilio Cobos Álvarez (:emilio)
no flags Details

Description Emilio Cobos Álvarez (:emilio) 2021-04-01 19:55:25 UTC
Description of problem:

Updated to Fedora 34 beta, tried to run `vagrant up` on one project I contribute to, and it failed when trying to load rexml/document.

How reproducible:


Steps to Reproduce:

0. dnf install vagrant vagrant-libvirt
1. git clone https://github.com/mozsearch/mozsearch
2. cd mozsearch
3. vagrant up

Actual results:

$ vagrant up                                                                                                                                                                                                                               
Bringing machine 'default' up with 'libvirt' provider...
==> default: Checking if box 'generic/ubuntu2004' version '3.2.6' is up to date...
<internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require': cannot load such file -- rexml/document (LoadError)
	from <internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from /usr/share/vagrant/gems/gems/vagrant-libvirt-0.1.2/lib/vagrant-libvirt/action/start_domain.rb:2:in `<top (required)>'
	from <internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from <internal:/usr/share/rubygems/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from /usr/share/vagrant/gems/gems/vagrant-libvirt-0.1.2/lib/vagrant-libvirt/action.rb:50:in `block (2 levels) in action_up'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builtin/call.rb:47:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builtin/box_check_outdated.rb:92:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builtin/config_validate.rb:25:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/warden.rb:48:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/builder.rb:149:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/runner.rb:89:in `block in run'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/util/busy.rb:19:in `busy'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/action/runner.rb:89:in `run'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:240:in `action_raw'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:212:in `block in action'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/environment.rb:613:in `lock'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:198:in `call'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/machine.rb:198:in `action'
	from /usr/share/vagrant/gems/gems/vagrant-2.2.9/lib/vagrant/batch_action.rb:86:in `block (2 levels) in run'

Expected results:

Stuff works. Manually installing `rubygem-rexml` worked.
Additional info:

Comment 1 Emilio Cobos Álvarez (:emilio) 2021-04-01 19:57:41 UTC
Created attachment 1768344 [details]
Another issue (same project)

(This one I haven't yet figured out)

Comment 2 Emilio Cobos Álvarez (:emilio) 2021-04-04 20:34:40 UTC
This might be related to ruby 3.0, iiuc: https://www.ruby-lang.org/en/news/2019/12/12/separation-of-positional-and-keyword-arguments-in-ruby-3-0/

Comment 3 Emilio Cobos Álvarez (:emilio) 2021-04-04 20:49:21 UTC
So there are three issues in Fedora 34:

 * The dependency issue reported in comment 0.
 * Two other issues (at least) related to ruby 3.0.

I sent PRs for the later two here: https://github.com/hashicorp/vagrant/pull/12273 / https://github.com/vagrant-libvirt/vagrant-libvirt/pull/1242

Comment 4 Vít Ondruch 2021-04-06 07:39:04 UTC
(In reply to Emilio Cobos Álvarez (:emilio) from comment #0)

This was already reported in bug 1915671. However, I'll keep this open, because you are pointing another issues.

Comment 5 iolo 2021-04-28 21:07:11 UTC
I haven't seen the other two problems, but https://github.com/hashicorp/vagrant/pull/12273 also occurs when trying to "vagrant up" an instance of Laravel Homestead with VirtualBox. While I wait for the PR to be merged, is it possible to downgrade ruby to an earlier version in Fedora 34 without breaking stuff?

Comment 6 Philipp Trulson 2021-05-06 14:37:00 UTC
Isn't it possible to apply Emilio's patch on the Fedora package of Vagrant? I can't execute 'vagrant up' as well, which is breaking it completely.

Comment 7 Pavel Valena 2021-05-06 14:55:41 UTC
I'll be updating Vagrant in Fedora this week.

Comment 8 Pavel Valena 2021-05-12 19:57:12 UTC
*** Bug 1959350 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2021-05-17 13:44:06 UTC
FEDORA-2021-17ded5c4ca has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-17ded5c4ca

Comment 10 Fedora Update System 2021-05-18 01:57:35 UTC
FEDORA-2021-17ded5c4ca has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-17ded5c4ca`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-17ded5c4ca

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Uri Simchoni 2021-05-18 03:59:46 UTC
That fixes the issue for me - Thanks!

Comment 12 Fedora Update System 2021-05-19 01:21:56 UTC
FEDORA-2021-17ded5c4ca has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.