Bug 1947878 - Request to package Slurmrestd for EPEL7 and EPEL8
Summary: Request to package Slurmrestd for EPEL7 and EPEL8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: slurm
Version: epel7
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Philip Kovacs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1940198
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-09 13:18 UTC by Heitor
Modified: 2021-06-16 15:25 UTC (History)
2 users (show)

Fixed In Version: slurm-20.11.6-1.el8 slurm-20.11.6-1.el7 slurm-20.11.7-3.el8 slurm-20.11.7-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-09 02:14:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Heitor 2021-04-09 13:18:14 UTC
I'd like to request to package slurm-slurmrestd for EPEL7 and EPEL8.

Slurm provides a REST API daemon named slurmrestd.[0]

It depends on the following additional libraries:
- http-parser
- libyaml
- json-c
- libjwt

The first 3 dependencies are already in EPEL7, and there is a request to add libjwt to EPEL7.[1]



[0] https://slurm.schedmd.com/rest.html
[1] https://bugzilla.redhat.com/show_bug.cgi?id=1940198

Comment 1 Philip Kovacs 2021-04-09 21:48:30 UTC
The dependencies are all met for Fedora rawhide, so I'll implement this first in rawhide (which is also in the spirit of what rawhide is all about).   

I notice that slurm upstream mentions that json web tokens is optional for slurmrestd -- it would be heavily crippled without it, correct?

Comment 2 Heitor 2021-04-12 12:55:18 UTC
libjwt is used for authentication, using json web tokens. Auth is optional, but in practice we always want authentication.

Comment 3 Philip Kovacs 2021-04-12 18:43:52 UTC
I've added the slurmrestd sub-package to Fedora rawhide, so there is a testing ground for this now.  Adding the libjwt bug as a blocker for this so the bottleneck is clear.

Comment 4 PeterK 2021-04-28 12:32:28 UTC
I'm interested in this as well! If there is anything I can do to help and speed up the process I'm happy to.

Comment 5 Philip Kovacs 2021-04-28 16:00:43 UTC
The libjwt bug (below) is on QA in the 2-week testing period with 6 days left to stable.  After that goes through, I can submit the needed slurm changes which in turn will require another 2 week testing period.  Testers can grant the builds karma to speed up the process.

https://bugzilla.redhat.com/show_bug.cgi?id=1940198
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-b8c4714317
https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-f1920cd4c1

Comment 6 Fedora Update System 2021-05-05 01:07:20 UTC
FEDORA-EPEL-2021-f06db8686b has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-f06db8686b

Comment 7 Fedora Update System 2021-05-05 01:12:50 UTC
FEDORA-EPEL-2021-77115f5c43 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-77115f5c43

Comment 8 Fedora Update System 2021-05-06 01:05:51 UTC
FEDORA-EPEL-2021-f06db8686b has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-f06db8686b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2021-05-06 01:28:02 UTC
FEDORA-EPEL-2021-77115f5c43 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-77115f5c43

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 PeterK 2021-05-10 06:08:47 UTC
Works perfect. My login https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-77115f5c43 is not working (500 server error) so I give my feedback here and hope for good karma :)

Comment 11 Fedora Update System 2021-05-21 02:50:35 UTC
FEDORA-EPEL-2021-f06db8686b has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2021-05-21 04:02:57 UTC
FEDORA-EPEL-2021-77115f5c43 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 13 Heitor 2021-05-24 17:42:02 UTC
I tried to setup a simple cluster with 4 nodes, one for each slurm component: slurmd, slurmctld, slurmdbd, and slurmrestd. Unfortunately, slurm{d,dbd,ctld} could not start, as they do not have the auth_jwt plugin (/usr/lib64/slurm/auth_jwt.so). Here is the end of the logs:

[2021-05-24T16:58:27.330] debug3: Trying to load plugin /usr/lib64/slurm/auth_jwt.so
[2021-05-24T16:58:27.330] debug4: /usr/lib64/slurm/auth_jwt.so: Does not exist or not a regular file.
[2021-05-24T16:58:27.330] error: Couldn't find the specified plugin name for auth/jwt looking at all files
[2021-05-24T16:58:27.330] error: cannot find auth plugin for auth/jwt
[2021-05-24T16:58:27.330] error: cannot create auth context for auth/jwt
[2021-05-24T16:58:27.330] fatal: failed to initialize authentication plugin

O copied the file /usr/lib64/slurm/auth_jwt.so from slurmrestd node, installed libjwt, and restarted the slurm{d,dbd,ctld} services and the cluster came back to life.

I think this file (/usr/lib64/slurm/auth_jwt.so) should be packaged in slurm-slurmdbd, slurm-slurmctld, and slurm-slurmdbd.

Should I open another ticket for that?

Comment 14 Philip Kovacs 2021-05-24 22:19:47 UTC
We'll use this ticket since the bug manifests from this new packaging -- this is why cluster testing is important!  I agree that auth_jwt.so probably needs to be moved, but it must sit in one package only.  Let me investigate further.  Reopened.

Comment 15 Fedora Update System 2021-05-25 00:45:39 UTC
FEDORA-EPEL-2021-0e0c1a76c6 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-0e0c1a76c6

Comment 16 Fedora Update System 2021-05-25 00:46:51 UTC
FEDORA-EPEL-2021-7e9a7ecfb4 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-7e9a7ecfb4

Comment 17 Philip Kovacs 2021-05-25 00:55:00 UTC
I moved the auth_jwt.so plugin into the base slurm package since it is needed for all node types (compute node, control node, database accounting node, etc.).  This should resolve the problem.  The other rest related plugins (openapi, rest_auth_jwt) are loaded only by the slurmrestd daemon itself, so those can stay in the slurmrestd subpackge.

Comment 18 Heitor 2021-05-25 13:11:59 UTC
Thank you!

Do you know when this fix will arrive in Epel7 stable?

Comment 19 Philip Kovacs 2021-05-25 18:51:02 UTC
There's a 14-day time gate or +3 karma gate, whichever happens first.  As soon as the update is swept to the testing repo (should be within 24 hours), however, you can use the command at the top of the update to test it.  Essentially you activate the testing repo and then install that "
advisory" package.  Please test it if you can instead of waiting the 2 weeks, finding another problem, and then having to wait all over again.

https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-7e9a7ecfb4

Once the package goes stable you can remove the advisory package installation, de-activate the testing repo and install it through the stable channel.

Comment 20 Fedora Update System 2021-05-26 01:11:38 UTC
FEDORA-EPEL-2021-0e0c1a76c6 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-0e0c1a76c6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2021-05-26 01:24:28 UTC
FEDORA-EPEL-2021-7e9a7ecfb4 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2021-7e9a7ecfb4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2021-06-09 02:14:13 UTC
FEDORA-EPEL-2021-0e0c1a76c6 has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 23 Fedora Update System 2021-06-09 02:21:11 UTC
FEDORA-EPEL-2021-7e9a7ecfb4 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 24 Heitor 2021-06-16 15:25:04 UTC
I can confirm slurmrestd is working nicely :)

Thanks for packaging it, Philip Kovacs!


Note You need to log in before you can comment on or make changes to this bug.