Bug 1948197 - ibus-anthy upgrade script freezes system
Summary: ibus-anthy upgrade script freezes system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-anthy
Version: 34
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1949216 (view as bug list)
Depends On:
Blocks: F34FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2021-04-10 17:06 UTC by uwe geercken
Modified: 2021-04-24 20:17 UTC (History)
21 users (show)

Fixed In Version: ibus-anthy-1.5.12-6.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-23 21:03:38 UTC
Type: Bug


Attachments (Terms of Use)

Description uwe geercken 2021-04-10 17:06:20 UTC
Description of problem:
I have a brand new Lenovo Yoga 7i laptop. Installed F34 without any issue. When doing a dnf update the packages where downloaded successfully. When the update scripts ran, the ibus-anthy update made the desktop freeze. No interaction possible anymore. After a while I hard stopped the laptop and rebootet, but Fedora does not start anymore.

I have then repeated the complete setup and upgrade again, but with the same result.


Version-Release number of selected component (if applicable):
F34

How reproducible:


Steps to Reproduce:
1. Install Fedora 34
2. Reboot system
3. do a dnf update

Actual results:
at ibus-anthy update script the system freezes

Expected results:
script runs successfully or otherwise throws an error

Additional info:
Lenovo Yoga 7i, 16Gb, 512Gb SSD

Comment 1 Mike B 2021-04-11 21:10:34 UTC
I'm experiencing the same thing, with identical symptoms. 

I also tried booting into tty2 from grub, which works after the failed update, but I was unable to recover the system.

Hardware Info:
AMD 3700X / X570 installing to an NVMe SSD.

Comment 2 Mike B 2021-04-11 21:31:29 UTC
(In reply to Mike B from comment #1)
> I'm experiencing the same thing, with identical symptoms. 
> 
> I also tried booting into tty2 from grub, which works after the failed
> update, but I was unable to recover the system.
> 
> Hardware Info:
> AMD 3700X / X570 installing to an NVMe SSD.

I just spun up a VM (KVM/QEMU) to test this, and the virtual machine *does not* experience this issue.

Comment 3 Stephen Hassard 2021-04-11 22:52:15 UTC
I've run into this same issue on a Lenovo Yoga 920 while performing updates via dnf in a gnome terminal session inside Gnome 40, and reproduced this on a second run with a fresh install from the Fedora 34 Workstation beta iso.

The hang did not happen if I switched to a text console first without any GUI before performing the first dnf update.

Comment 4 Jens Petersen 2021-04-12 07:57:27 UTC
It might help if someone can update by hand with say "sudo rpm -Uvh --noscripts ibus-anthy-*.rpm".

And then try to run: sudo /usr/bin/ibus write-cache --system
and attach any log output here. There may be better ways to debug though.

Comment 5 fujiwara 2021-04-12 09:28:31 UTC
I cannot reproduce your problem.

Comment 6 Jens Petersen 2021-04-14 08:46:34 UTC
We don't know how to reproduce this, but it seems to warrant attention.
Specially not being able to reboot is rather concerning.

If someone could confirm if this is specific to ibus-anthy or not that would be helpful.
ie just `rpm -e ibus-anthy` before attempting to update packages.

Comment 7 Jens Petersen 2021-04-14 08:48:11 UTC
Also reported in bug 1948197 against ibus.

Comment 8 Stephen Hassard 2021-04-14 14:24:51 UTC
I did a fresh install of the Fedora 34 beta and upgraded just the ibus-anthy and ibus-anthy-python packages via dnf without the hang. I'll try a few mutations of that and see if I can repo.

Comment 9 Stephen Hassard 2021-04-14 15:14:21 UTC
A few more data point:

1. Installation this morning from the 1.3 beta iso immediately upgrading full via dnf inside a wayland session resulted in the hang with the gnome terminal showing "Running scriptlet: ibus-anthy-1.5.12-4.fc34.x86_64". Rebooting the system resulted in a system that was unable to start gdm properly.

2. Installation from the 1.3 beta iso, rebooting into the newly installed system, removing ibus-anthy and ibus-anthy-python via dnf, then doing a "dnf -y update" resulted in the wayland session switching back to a terminal with a blinking cursor in the top left corner of the screen. Rebooting the system resulted in gdm being unable to start.

I'll testing doing a full upgrade from xorg and see if that works next.

Comment 10 Stephen Hassard 2021-04-14 15:51:30 UTC
I re-tested removing ibus-anthy before the update using wayland, and that worked this go around. I think the screensaver setting timed out in my first test causing the display issue. Anyhow, retesting this it worked flawlessly.

Performing the first 'dnf -y update' using an Xorg session without removing ibus-anthy also seemed to work without issues.

It definitely seems like the ibus-anthy upgrade packed with the rest of the beta package upgrades is causing issues with Wayland sessions.

Comment 11 Anderson Silva 2021-04-14 21:15:21 UTC
Brand new T14s, installed Fedora 34 from scratch. ibus-anthy froze the whole system as well. I was able to reboot into the system in single mode, remove some conflicts, but thing got messy with dual installs of grub2-* packages. So, I re-installed the OS, and removed ibus-anthy like some folks here and upgrade finished.

Comment 12 Jens Petersen 2021-04-15 04:40:35 UTC
(In reply to Jens Petersen from comment #7)
> Also reported in bug 1948197 against ibus.
(Ugh I meant bug 1949216)

Thank you, Stephen for the additional testing - much appreciated.
Somehow I suspect this might be something on the gnome or kernel side, or maybe via dbus?
I don't think there have been any recent changes related to this in ibus.

Maybe if one runs `dnf update ibus-anthy` first and then `dnf update` the problem might not happen?
Dunno if `strace /usr/bin/ibus write-cache --system` gives any more clues.

Also if this only happens on bare-metal - it seems unlikely the problem is caused directly by ibus.

Comment 13 Jens Petersen 2021-04-15 05:52:51 UTC
Any help with narrowing down this problem would be greatly appreciated.

Comment 14 Stephen Hassard 2021-04-15 06:49:50 UTC
For what it’s worth, upgrading ibus-anthy first in isolation avoids the nasty lock condition.

Comment 15 fujiwara 2021-04-15 07:18:26 UTC
Does your home directory mount a different partition?

ibus engines including ibus-anthy runs `ibus write-cache --system` in the postscript, which runs sub-scripts in /usr/share/ibus/*.xml internally, and updates /var/cache/ibus/bus/registry file.
E.g. /usr/share/ibus/anthy.xml runs `/usr/libexec/ibus-engine-anthy --xml` which loads /usr/share/ibus/anthy.xml and /usr/share/ibus-anthy/engine/default.xml .

`ibus write-cache --system` checks the time stamps of /var/cache/ibus/bus/registry and $HOME/.cache/ibus/bus/registry. Maybe the home is /home/liveuser .

Comment 16 fujiwara 2021-04-15 07:38:13 UTC
All I do at the moment is to move both the postinstall and postuninstall to %posttrans but I don't know if it can resolve your issue since I cannot reproduce it.

You can see the postscript with `rpm -q --scripts ibus-anthy`.

Comment 17 fujiwara 2021-04-15 09:43:03 UTC
I prepared the test package in copr to move both the postinstall and postuninstall to %posttrans :
https://copr.fedorainfracloud.org/coprs/fujiwara/ibus-anthy/

Could you try the new package if your problem can be fixed?

1. Install F34 newly again

2. Add the copr repo to run `dnf copr enable fujiwara/ibus-anthy`

3. Run `dnf update` and make sure ibus-anthy-1.5.12-5 is installed.

Comment 18 Jens Petersen 2021-04-15 10:34:55 UTC
*** Bug 1949216 has been marked as a duplicate of this bug. ***

Comment 19 Geraldo Simião 2021-04-15 10:37:43 UTC
A friend of mine had the same problem.
He downloaded a new iso (a nightly build) and performed the updates without problems. 
Perhaps that's a bug that isn't present anymore at newly images?

Comment 20 Lee Thomas 2021-04-15 12:49:05 UTC
Just adding my experience in case it helps.

Installed Fedora 34 on my Lenovo V155 last night, one of the first things I did was a `sudo dnf update` and it locked up running the ibus-anthy update script as others have mentioned.

I did manage to switch to a tty and login after hard resetting. Ran `dmesg -e` and noted that gnome-shell had listed a segfault in libEGL_mesa.so, but couldn't figure out how to reinstall mesa-libEGL.

Reinstalled Fedora 34 this morning, updated ibus-anthy on its own in a tty first, followed by a `sudo dnf update` and it seems to have worked just fine.

Comment 21 fujiwara 2021-04-15 14:30:21 UTC
(In reply to Lee Thomas from comment #20)
> Reinstalled Fedora 34 this morning, updated ibus-anthy on its own in a tty
> first, followed by a `sudo dnf update` and it seems to have worked just fine.

Sorry, this way does not help to resolve this issue since it seems to depend on the timing to run the postscripts.
I asked the testing way in comment #17.

Comment 22 uwe geercken 2021-04-15 15:13:15 UTC
Another comment from my side. I restarted from scratch and installed F33 first and then subsequently did the upgrade to F34 and did not have the problem.

I am running it for some days now without an issue (although I have other issues with external monitors and pipewire)

Comment 23 Ben Cotton 2021-04-15 15:46:23 UTC
I could not reproduce on a fresh vm. I installed F34 Workstation Beta and ran a dnf update. It successfully updated to ibus-anthy-1.5.12-4.fc34.x86_64.

Comment 24 Parag Nemade 2021-04-15 15:59:01 UTC
(In reply to Ben Cotton from comment #23)
> I could not reproduce on a fresh vm. I installed F34 Workstation Beta and
> ran a dnf update. It successfully updated to ibus-anthy-1.5.12-4.fc34.x86_64.

This need to be checked on bare-metal system. VM works fine.

Comment 25 fujiwara 2021-04-16 07:18:32 UTC
If none verify my fix, I will close this as not a bug.

Comment 26 Luca Botti 2021-04-16 09:41:37 UTC
(In reply to fujiwara from comment #25)
> If none verify my fix, I will close this as not a bug.

Tested. Fresh install of F34 Beta on Dell Latitude 7410 (10th gen core i7). Wayland session. With copr enabled, the issue on ibus-anthy is gone, BUT the updates locks on "Running scriptlet: ibus-typing-booster-2.11.2-1.fc34.noarch".

Same situation as before - session locked. Boot is feasible, when restarted dnf does not suggest to complete transaction, but a conflict with libhandhy. Looks like the transaction will not complete.

Comment 27 Luca Botti 2021-04-16 09:50:29 UTC
(In reply to Luca Botti from comment #26)
> (In reply to fujiwara from comment #25)
> > If none verify my fix, I will close this as not a bug.
> 
> Tested. Fresh install of F34 Beta on Dell Latitude 7410 (10th gen core i7).
> Wayland session. With copr enabled, the issue on ibus-anthy is gone, BUT the
> updates locks on "Running scriptlet:
> ibus-typing-booster-2.11.2-1.fc34.noarch".
> 
> Same situation as before - session locked. Boot is feasible, when restarted
> dnf does not suggest to complete transaction, but a conflict with libhandhy.
> Looks like the transaction will not complete.

Additionally - on my system (vt-d turned on in bios) I need to add intel_iommu=on on the kernel command line to boot, with noapic added as default from fedora.

Comment 28 Frederic Masi 2021-04-16 11:40:24 UTC
(In reply to fujiwara from comment #17)
> I prepared the test package in copr to move both the postinstall and
> postuninstall to %posttrans :
> https://copr.fedorainfracloud.org/coprs/fujiwara/ibus-anthy/
> 
> Could you try the new package if your problem can be fixed?
> 
> 1. Install F34 newly again
> 
> 2. Add the copr repo to run `dnf copr enable fujiwara/ibus-anthy`
> 
> 3. Run `dnf update` and make sure ibus-anthy-1.5.12-5 is installed.

Tested fresh install on X1 Carbon Gen6

Enable fujiwara/ibus-anthy repo and confirmed that dnf update was targeting ibus-anthy-1.5.12-5

Starting version Ibus-anthy-1.5.12-1.fc34.x86_64
Successfully installed Ibus-anthy-1.5.12-5.fc34.x86_64
Successfully installed Ibus-anthy-python-1.5.12-5.fc34.x86_64
Dns update gets stuck in Ibus-typing-booster-2.11.2-1.fc34.noarch 

System exhibited same behaviour as when previously stuck at ibus-anthy

Hope this help, let me know if you need further tests done.

Comment 29 fujiwara 2021-04-16 11:57:42 UTC
(In reply to Luca Botti from comment #27)
(In reply to Frederic Masi from comment #28)

@Luca Botti and @Frederic Masi

Thank you for the testing.
The similar postscript is also saved in ibus-typing-booster and could be the same issue.

Now I updated ibus-typing-booster, ibus-hangul, ibus-libpinyin, ibus-input-pad besides ibus-anthy in the same copr:
https://copr.fedorainfracloud.org/coprs/fujiwara/ibus-anthy/

Could you please try the Fedora 34 installation again?

1. Install F34 newly again

2. Add the copr repo to run `dnf copr enable fujiwara/ibus-anthy`

3. Run `dnf update` and make sure ibus-anthy-1.5.12-5 is installed.

Comment 30 Luca Botti 2021-04-16 14:22:51 UTC
(In reply to fujiwara from comment #29)
> (In reply to Luca Botti from comment #27)
> (In reply to Frederic Masi from comment #28)
> 
> @Luca Botti and @Frederic Masi
> 
> Thank you for the testing.
> The similar postscript is also saved in ibus-typing-booster and could be the
> same issue.
> 
> Now I updated ibus-typing-booster, ibus-hangul, ibus-libpinyin,
> ibus-input-pad besides ibus-anthy in the same copr:
> https://copr.fedorainfracloud.org/coprs/fujiwara/ibus-anthy/
> 
> Could you please try the Fedora 34 installation again?
> 
> 1. Install F34 newly again
> 
> 2. Add the copr repo to run `dnf copr enable fujiwara/ibus-anthy`
> 
> 3. Run `dnf update` and make sure ibus-anthy-1.5.12-5 is installed.

Hi,

just tested and it worked. No issue with ibus-*.

Comment 31 fujiwara 2021-04-16 15:52:04 UTC
(In reply to Luca Botti from comment #30)
> (In reply to fujiwara from comment #29)
> > (In reply to Luca Botti from comment #27)
> > (In reply to Frederic Masi from comment #28)
> > 
> > @Luca Botti and @Frederic Masi
> > 
> > Thank you for the testing.
> > The similar postscript is also saved in ibus-typing-booster and could be the
> > same issue.
> > 
> > Now I updated ibus-typing-booster, ibus-hangul, ibus-libpinyin,
> > ibus-input-pad besides ibus-anthy in the same copr:
> > https://copr.fedorainfracloud.org/coprs/fujiwara/ibus-anthy/
> > 
> > Could you please try the Fedora 34 installation again?
> > 
> > 1. Install F34 newly again
> > 
> > 2. Add the copr repo to run `dnf copr enable fujiwara/ibus-anthy`
> > 
> > 3. Run `dnf update` and make sure ibus-anthy-1.5.12-5 is installed.
> 
> Hi,
> 
> just tested and it worked. No issue with ibus-*.

Fantastic!

@Luca Botti and @Frederic Masi

Thank you very much for your tests.

Comment 32 lightshowak 2021-04-16 23:00:58 UTC
I can also confirm the issue is resolved on a Lenovo T490 after adding the COPR repo.

Comment 33 Ioan Hadade 2021-04-17 10:34:54 UTC
I encountered this issue as well on a custom build AMD Ryzen 9 5950X. 

Fixed after following fujiwara's instructions.

Thanks!

Comment 34 edsvo 2021-04-19 01:20:46 UTC
I had encountered this problem over multiple attempts over the past several days. Today I followed fujiwara's most recent instructions above and that resolved the problem.

This is on a Dell Latitude 7490.

Comment 35 Adam Williamson 2021-04-19 15:53:00 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/353 , marking accepted. @fujiwara, could you please do an official build/update with the fix? Thanks!

Comment 36 Jens Petersen 2021-04-20 07:01:28 UTC
Problem is we need to update all the ibus IMEs - at least the default installed ones.

I am not sure if the fix needs to be in GA though - I think 0-day updates should do the trick?
UNless there are concerns with the %postun scriptlet too.

Comment 37 fujiwara 2021-04-20 07:06:16 UTC
I think the fix will be available after Fedora 34 GA since we don't have to fix ibus-anthy only but also other packages at the same time with more tests.
Unfortunately ibus does not have the group integration in bodhi.

I will update the release note to describe the copr repository.

Comment 38 Jens Petersen 2021-04-20 08:26:13 UTC
Proven packagers can help with fixing other IMEs.
We should address the most common ones first.


dnf repoquery --file /usr/share/ibus/component/*.xml --qf "%{source_name}"
ibus [*]
ibus-anthy [*]
ibus-bogo
ibus-cangjie
ibus-chewing
ibus-handwrite
ibus-hangul [*]
ibus-input-pad
ibus-kkc
ibus-libpinyin [*]
ibus-libzhuyin [*]
ibus-m17n [*]
ibus-pinyin
ibus-rawcode
ibus-rime
ibus-sayura
ibus-skk
ibus-table
ibus-typing-booster [*]
ibus-uniemoji
ibus-unikey
mozc

([*] = default in @input-methods)

Comment 39 Jens Petersen 2021-04-20 09:22:25 UTC
(In reply to fujiwara from comment #37)
> I think the fix will be available after Fedora 34 GA since we don't have to
> fix ibus-anthy only but also other packages at the same time with more tests.

That is what updates-testing is for.

> I will update the release note to describe the copr repository.

The copr repo is not an acceptable short-term solution.

Comment 40 fujiwara 2021-04-20 11:43:47 UTC
(In reply to Jens Petersen from comment #39)
> (In reply to fujiwara from comment #37)
> > I think the fix will be available after Fedora 34 GA since we don't have to
> > fix ibus-anthy only but also other packages at the same time with more tests.
> 
> That is what updates-testing is for.

It cannot do at the same time automatically.

> 
> > I will update the release note to describe the copr repository.
> 
> The copr repo is not an acceptable short-term solution.

Not sure who does not accept the short-term solution.

But since ibus-typing-booster is now updated, I will update ibus-anthy too.

Comment 41 fujiwara 2021-04-20 11:46:17 UTC
(In reply to Jens Petersen from comment #38)
> Proven packagers can help with fixing other IMEs.
> We should address the most common ones first.

> 
> ([*] = default in @input-methods)

I think the default IMEs would be enough since the reproducing environment is not clarified at the moment and the root cause is not too.

Comment 42 Fedora Update System 2021-04-20 12:04:10 UTC
FEDORA-2021-ec82cf176a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec82cf176a

Comment 43 Fedora Update System 2021-04-20 12:22:03 UTC
FEDORA-2021-a77c4b6e7a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a77c4b6e7a

Comment 44 Fedora Update System 2021-04-20 22:25:45 UTC
FEDORA-2021-ec82cf176a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ec82cf176a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec82cf176a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 45 Fedora Update System 2021-04-20 22:25:47 UTC
FEDORA-2021-a77c4b6e7a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a77c4b6e7a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a77c4b6e7a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 46 Fedora Update System 2021-04-21 02:54:44 UTC
FEDORA-2021-ec82cf176a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec82cf176a

Comment 47 Fedora Update System 2021-04-21 03:24:00 UTC
FEDORA-2021-a77c4b6e7a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a77c4b6e7a

Comment 48 Fedora Update System 2021-04-21 06:07:08 UTC
FEDORA-2021-850d49df4e has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 49 Fedora Update System 2021-04-21 06:13:08 UTC
FEDORA-2021-eb993b286e has been pushed to the Fedora ELN stable repository.
If problem still persists, please make note of it in this bug report.

Comment 50 Fedora Update System 2021-04-21 06:15:00 UTC
FEDORA-2021-125dd83ddc has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-125dd83ddc

Comment 51 Adam Williamson 2021-04-21 06:32:12 UTC
When a bug is a blocker or FE for a Fedora release, please don't mark updates for *other* releases as 'fixing' it, or it will get closed and then it won't show up in the tooling I use to do the Fedora compose/push requests and it'll get left out.

Comment 52 Fedora Update System 2021-04-21 07:04:33 UTC
FEDORA-2021-9a46e1fdcc has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-9a46e1fdcc

Comment 53 Fedora Update System 2021-04-21 07:17:10 UTC
FEDORA-2021-a77c4b6e7a has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-a77c4b6e7a

Comment 54 Fedora Update System 2021-04-21 15:01:00 UTC
FEDORA-2021-ec82cf176a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ec82cf176a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec82cf176a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 55 Fedora Update System 2021-04-21 15:01:04 UTC
FEDORA-2021-a77c4b6e7a has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-a77c4b6e7a`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-a77c4b6e7a

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 56 Fedora Update System 2021-04-21 15:01:33 UTC
FEDORA-2021-125dd83ddc has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-125dd83ddc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-125dd83ddc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 57 Fedora Update System 2021-04-21 15:01:37 UTC
FEDORA-2021-9a46e1fdcc has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-9a46e1fdcc`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-9a46e1fdcc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 58 fujiwara 2021-04-22 05:17:55 UTC
Now the test packages are available in updates-testing repo and it would be really great if you could try the installation test again.


1. Install F34 newly again

2. Run `dnf update --enablerepo=updates-testing` and make sure ibus-anthy-1.5.12-5 is installed.

Comment 59 Jens Petersen 2021-04-22 14:00:26 UTC
(In reply to Adam Williamson from comment #51)
> When a bug is a blocker or FE for a Fedora release, please don't mark
> updates for *other* releases as 'fixing' it, or it will get closed and then
> it won't show up in the tooling I use to do the Fedora compose/push requests
> and it'll get left out.

Thank you for catching this, Adam, and for tagging all the updating into the compose.

Comment 60 vishalvvr 2021-04-23 02:21:38 UTC
I have tested this issue with two images on bare metal.
 
Image: Fedora-Workstation-Live-x86_64-34-20210421.n.0.iso
 Steps:
 - Was able to reproduce this issue, during dnf update with the default packages(did not enable advisory).
 - Reboot the system and again format, install the new system. Enabled the advisory=FEDORA-2021-ec82cf176a and then ran dnf update.
   
 Observations:
 - Update was smooth, during/post update no system freeze/hang was observed.
 - log: https://paste.opensuse.org/b69c819c
 
 
Image: 34_RC-1.1: Fedora-Workstation-Live-x86_64-34-1.1.iso
 Steps:
 - Installed a new system and checked for package version, all the packages related to this bug were already updated to the latest build(the fixed build).
 
 Observations:
 - No system freeze/hang or any other issue observed.
 - log: https://paste.opensuse.org/1df7a772
 
 
This update[1] works for me.
[1]https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec82cf176a

Comment 61 vishalvvr 2021-04-23 04:03:28 UTC
Image: Fedora-Workstation-Live-x86_64-34_Beta-1.3.iso on bare metal
 Steps:
 - Installed a new system and run "dnf update"
 
 Observations:
 - Update was smooth, during/post update no system freeze/hang was observed.
 - log: https://paste.opensuse.org/eb22d08a

Comment 62 Jens Petersen 2021-04-23 06:57:38 UTC
I have also tested upgrading from Fedora 33 to latest Fedora 34 in a VM and
ibus continued to work normally in desktop and flatpak as expected.

Comment 63 Jens Petersen 2021-04-23 07:25:41 UTC
I also tested updating F34 Beta in a VM and ibus continued to work correctly afterwards.

Comment 64 Fedora Update System 2021-04-23 10:21:05 UTC
FEDORA-2021-02ce3d9d56 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-02ce3d9d56

Comment 65 Fedora Update System 2021-04-23 21:03:38 UTC
FEDORA-2021-ec82cf176a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 66 Fedora Update System 2021-04-23 21:03:42 UTC
FEDORA-2021-a77c4b6e7a has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 67 Fedora Update System 2021-04-23 21:03:44 UTC
FEDORA-2021-125dd83ddc has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 68 Fedora Update System 2021-04-23 21:03:46 UTC
FEDORA-2021-9a46e1fdcc has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 69 Fedora Update System 2021-04-24 20:17:02 UTC
FEDORA-2021-02ce3d9d56 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.