Bug 1949430 - python-wsproto fails to build with Python 3.10: AssertionError: assert 'H11Handshake..., state=OPEN)' == 'H11Handshake...onState.OPEN)'
Summary: python-wsproto fails to build with Python 3.10: AssertionError: assert 'H11Ha...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: python-wsproto
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George 🤠
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1969171 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1969166
TreeView+ depends on / blocked
 
Reported: 2021-04-14 09:42 UTC by Tomáš Hrnčiar
Modified: 2021-07-12 12:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-07-12 12:44:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2021-04-14 09:42:10 UTC
python-wsproto fails to build with Python 3.10.0a7.

=================================== FAILURES ===================================
__________________________ test_successful_handshake ___________________________

    def test_successful_handshake() -> None:
        client = H11Handshake(CLIENT)
        server = H11Handshake(SERVER)
    
        server.receive_data(client.send(Request(host="localhost", target="/")))
        assert isinstance(next(server.events()), Request)
    
        client.receive_data(server.send(AcceptConnection()))
        assert isinstance(next(client.events()), AcceptConnection)
    
        assert client.state is ConnectionState.OPEN
        assert server.state is ConnectionState.OPEN
    
>       assert repr(client) == "H11Handshake(client=True, state=ConnectionState.OPEN)"
E       AssertionError: assert 'H11Handshake..., state=OPEN)' == 'H11Handshake...onState.OPEN)'
E         - H11Handshake(client=True, state=ConnectionState.OPEN)
E         ?                                 ----------------
E         + H11Handshake(client=True, state=OPEN)

test/test_handshake.py:22: AssertionError
=========================== short test summary info ============================
FAILED test/test_handshake.py::test_successful_handshake - AssertionError: as...
======================== 1 failed, 225 passed in 0.78s =========================

There were some changes in repr() in latest alpha of Python 3.10.
https://docs.python.org/3.10/whatsnew/changelog.html#python-3-10-0-alpha-7

bpo-40066: Enum: adjust repr() to show only enum and member name (not value, nor angle brackets) and str() to show only member name. Update and improve documentation to match.

bpo-40066: Enum’s repr() and str() have changed: repr() is now EnumClass.MemberName and str() is MemberName. Additionally, stdlib Enum’s whose contents are available as module attributes, such as RegexFlag.IGNORECASE, have their repr() as module.name, e.g. re.IGNORECASE.
https://bugs.python.org/issue40066

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.10/fedora-rawhide-x86_64/02127323-python-wsproto/

For all our attempts to build python-wsproto with Python 3.10, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/package/python-wsproto/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.10:
https://copr.fedorainfracloud.org/coprs/g/python/python3.10/

Let us know here if you have any questions.

Python 3.10 will be included in Fedora 35. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.10.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 1 Miro Hrončok 2021-06-04 20:15:45 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 23:00:07 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:35:55 UTC
*** Bug 1969171 has been marked as a duplicate of this bug. ***

Comment 4 Ben Beasley 2021-06-08 18:57:54 UTC
Reported upstream: https://github.com/python-hyper/wsproto/issues/159

Comment 5 Miro Hrončok 2021-06-15 20:26:49 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Ben Beasley 2021-07-09 12:42:51 UTC
It’s only the one test that fails, and there shouldn’t be any impact on users who aren’t depending on the exact string value of “repr(<something from wsproto>)”. Would you consider skipping the test—

> %check
> # https://github.com/python-hyper/wsproto/issues/159
> %pytest --verbose -k 'not test_successful_handshake'

—as a workaround until upstream decides what to do? Or do you want to keep waiting for upstream?

Comment 7 Miro Hrončok 2021-07-12 11:52:35 UTC
The package no longer fails to build with Python 3.10.0b4.

I will take care of the rebuild.

Please note that the standard library enum implementation was reverted upstream to the Python 3.9 version; if the failure was enum related (such as tests expecting a specific Enum.__repr__ value) it will likely happen again with Python 3.11.

https://mail.python.org/archives/list/python-dev@python.org/message/LSTMFAPSPD3BGZ4D6HQFODXZVB3PLYKF/

Comment 8 Miro Hrončok 2021-07-12 12:44:39 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 35.

Thanks for taking care of it!


Note You need to log in before you can comment on or make changes to this bug.