Bug 1969166 - F35FailsToInstall: python3-uvicorn+standard, python3-uvicorn. The build hangs in %check
Summary: F35FailsToInstall: python3-uvicorn+standard, python3-uvicorn. The build hangs...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-uvicorn
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Carl George 🤠
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On: 1914246 1949430 1969168
Blocks: F35FailsToInstall PYTHON3.10 F35BetaFreezeException 1968971 1968972
TreeView+ depends on / blocked
 
Reported: 2021-06-07 23:49 UTC by Miro Hrončok
Modified: 2021-09-16 23:55 UTC (History)
5 users (show)

Fixed In Version: python-uvicorn-0.15.0-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-09-16 23:55:32 UTC
Type: ---


Attachments (Terms of Use)

Description Miro Hrončok 2021-06-07 23:49:31 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

Your package (python-uvicorn) Fails To Install in Fedora 35:

can't install python3-uvicorn+standard:
  - nothing provides ((python3.9dist(uvloop) < 0.15 or python3.9dist(uvloop) > 0.15) with (python3.9dist(uvloop) < 0.15.1 or python3.9dist(uvloop) > 0.15.1) with python3.9dist(uvloop) >= 0.14) needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  - nothing provides (python3.9dist(httptools) >= 0.1 with python3.9dist(httptools) < 0.2) needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  - nothing provides (python3.9dist(websockets) >= 8 with python3.9dist(websockets) < 9) needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  - nothing provides python3.9dist(python-dotenv) >= 0.13 needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  - nothing provides python3.9dist(setuptools) needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  - nothing provides python(abi) = 3.9 needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  - nothing provides python3.9dist(pyyaml) >= 5.1 needed by python3-uvicorn+standard-0.13.4-1.fc35.noarch
  
can't install python3-uvicorn:
  - nothing provides (python3.9dist(click) >= 7 with python3.9dist(click) < 8) needed by python3-uvicorn-0.13.4-1.fc35.noarch
  - nothing provides python3.9dist(h11) >= 0.8 needed by python3-uvicorn-0.13.4-1.fc35.noarch
  - nothing provides python3.9dist(setuptools) needed by python3-uvicorn-0.13.4-1.fc35.noarch
  - nothing provides python(abi) = 3.9 needed by python3-uvicorn-0.13.4-1.fc35.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors.

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2021-06-07 23:54:13 UTC
This bugzilla is likely a fallout from the Python 3.10 rebuild.

If your package (or some of the dependencies it has) failed to rebuild during the Python 3.10 rebuild, they now fail to install. To fix this, packages need to be rebuilt in Rawhide.

We will slowly triage the bugzillas, but we'd appreciate your help.

If you know this is blocked by an existing reported build failure or another package not yet rebuilt with Python 3.10, please mark it as such by using the "Depends On"/"Blocks" bugzilla fields. That will help us determine what failures to prioritize.

Thank you and sorry for the inconvenience. Let me know if you need any help.

Comment 2 Ben Beasley 2021-06-08 12:27:25 UTC
Doing a quick triage since I need this for python-fastapi. The build failed because python-wsproto (https://bugzilla.redhat.com/show_bug.cgi?id=1949430) and python-watchgod (https://bugzilla.redhat.com/show_bug.cgi?id=1969168) did not rebuild successfully for Python 3.10.

Comment 3 Miro Hrončok 2021-06-15 20:53:32 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Miro Hrončok 2021-07-12 12:04:51 UTC
This was unblocked. The build appears to hang in %check after:

...PASSED tests...
tests/test_auto_detection.py::test_websocket_auto FAILED                 [  1%]
...PASSED tests...
tests/protocols/test_websocket.py::test_invalid_upgrade[WebSocketProtocol] FAILED [ 78%]
tests/protocols/test_websocket.py::test_accept_connection[WSProtocol] <--- hangs here

Comment 5 Carl George 🤠 2021-07-13 00:00:31 UTC
There is an open pull request to update to 0.14.0, but it doesn't resolve the test suite hanging.

https://src.fedoraproject.org/rpms/python-uvicorn/pull-request/1

Comment 6 Ben Cotton 2021-08-10 13:06:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 35 development cycle.
Changing version to 35.

Comment 7 Miro Hrončok 2021-08-23 11:58:29 UTC
Hello Carl. What do we do with this one? Attempt a fix? Skip some tests? Retire? Note that this blocks falcon and mailman3 (which is however also blocked by other packages).

Comment 8 Ben Beasley 2021-08-24 14:46:09 UTC
It’s also supposed to be a dependency of python3-fastapi+all. For now I’m (mostly harmlessly) patching it out to unblock fastapi.

Comment 9 Fedora Update System 2021-09-10 15:01:25 UTC
FEDORA-2021-55adef54f6 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-55adef54f6

Comment 10 Ben Beasley 2021-09-10 17:41:59 UTC
Thanks! I’ve restored the dependency in python3-fastapi+all in Rawhide and F35 (https://bodhi.fedoraproject.org/updates/FEDORA-2021-ecc1a1b5db).

Comment 11 Fedora Update System 2021-09-10 22:12:26 UTC
FEDORA-2021-55adef54f6 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-55adef54f6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-55adef54f6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Miro Hrončok 2021-09-11 05:43:09 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok@redhat.com).

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 36.

Thanks for taking care of it!

Comment 13 Fedora Update System 2021-09-12 08:12:12 UTC
FEDORA-2021-55adef54f6 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-55adef54f6

Comment 14 Fedora Update System 2021-09-12 18:08:57 UTC
FEDORA-2021-55adef54f6 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-55adef54f6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-55adef54f6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 Lukas Ruzicka 2021-09-13 07:16:39 UTC
I can confirm that this package can be installed with the latest updates.

Comment 16 Fedora Update System 2021-09-16 23:55:32 UTC
FEDORA-2021-55adef54f6 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.