Bug 1950230 - Blender radeonsi: can't compile a main shader part
Summary: Blender radeonsi: can't compile a main shader part
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blender
Version: 34
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Luya Tshimbalanga
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1956451 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-04-16 07:13 UTC by Atsushi
Modified: 2021-06-13 01:49 UTC (History)
7 users (show)

Fixed In Version: blender-2.93.0-1.fc33 blender-2.93.0-1.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-13 01:19:53 UTC
Type: Bug


Attachments (Terms of Use)
attached at blender command on gnome-terminal. (1.10 KB, text/plain)
2021-04-16 07:13 UTC, Atsushi
no flags Details
crash log blender auto output /tmp/Blender.crash.txt (1.85 KB, text/plain)
2021-04-16 07:16 UTC, Atsushi
no flags Details

Description Atsushi 2021-04-16 07:13:32 UTC
Created attachment 1772338 [details]
attached at blender command on gnome-terminal.

Created attachment 1772338 [details]
attached at blender command on gnome-terminal.

Created attachment 1772338 [details]
attached at blender command on gnome-terminal.

Created attachment 1772338 [details]
attached at blender command on gnome-terminal.

Description of problem:
Blender crash with error as attached file. 
 

Version-Release number of selected component (if applicable):
Blender 2.92.0-2.fc34.x86_64

How reproducible:


Steps to Reproduce:
1. rm ~/.config/2.92
2. Open Blender
3. Open blend file is https://cloud.blender.org/p/gallery/60337d495677e942564cce76.
4. rendering it.

Actual results:

rendering display show a few minites, then Blender crash.

Expected results:

rendering the image as above url.

Additional info:

all package up to date.

Hardware info:
CPU&GPU AMD Ryzen 5 2400G Radeon RX Vega 11 Graphics

Similar to this case on Gentoo Linux.
https://gitlab.freedesktop.org/mesa/mesa/-/issues/4107

Comment 1 Atsushi 2021-04-16 07:16:47 UTC
Created attachment 1772339 [details]
crash log blender auto output /tmp/Blender.crash.txt

Comment 2 Atsushi 2021-04-16 10:57:54 UTC
Removed because I don't know if the gentoo case is relevant.

Comment 3 Luya Tshimbalanga 2021-04-16 15:34:07 UTC
The Gentoo case is relevant because it includes an important upstream bug. Please put it back.
Also see https://developer.blender.org/T83488. 

I was able to reproduce the bug with AMD Ryzen 5 2550U with Vega 8 suggesting the problem is possibly linked with llvm and radeonsi.

Comment 4 Atsushi 2021-04-17 02:02:13 UTC
OK. i rewrite my post.

Comment 5 Luya Tshimbalanga 2021-04-17 18:43:09 UTC
Setting the bug as public as no sensitive data is found.

Comment 6 Bruno Postle 2021-05-01 08:30:35 UTC
I'm seeing presumably the same issue, fedora 34 x86_64. The segfault appears with the 'cycles' render engine, either in the viewport or rendering the scene, the 'eevee' render engine is fine and otherwise blender appears to be ok.

This is unrelated to greasepencil, to reproduce:

1. Open blender with the default scene cube
2. Select 'Render Properties'
3. 'Render Engine', select 'Cycles'
4. segfault

I have older AMD graphics, using default radeon driver:

    VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R6 Graphics] (prog-if 00 [VGA controller])

Comment 7 Luya Tshimbalanga 2021-05-03 22:28:27 UTC
*** Bug 1956451 has been marked as a duplicate of this bug. ***

Comment 8 Luya Tshimbalanga 2021-05-05 01:23:03 UTC
Narrowing the traceback, the crashes occurred on 
File "/usr/share/blender/2.92/scripts/addons/cycles/engine.py", line 176 in render
File "/usr/share/blender/2.92/scripts/addons/cycles/__init__.py", line 83 in render

as listed by the original reporter. The possible curprit is depsgraph (https://wiki.blender.org/wiki/Source/Depsgraph) incompatibility with python 3.9 as the report on #1956451 noticed the same cycle rendering on Fedora 33 is unaffected.

Bug filed upstream for further investigation:
https://developer.blender.org/T88042

Comment 9 Atsushi 2021-05-07 05:55:51 UTC
thanks for investigation.
Blender crash Bruno Postle says as same problem on my PC.

Comment 10 jc-fas@neniam.net 2021-05-21 23:09:26 UTC
Same crash as above, completely consistent.  Graphics card is Radeon RX 550.

Updated to f34 from f32, was working in f32.

1. launch blender, click the banner if necessary to make it go away
1a. leave the initial cube object there
2. press z and move the mouse upwards (to select rendered view)
3. go to the render properties editor (the little camera icon probably on the pane on the lower right)
4. change render engine from Eevee to Cycles
5. in a moment, it will crash with segfault

Same crash report as shown above, most interesting lines
blender(_ZN3ccl11BlenderSync13sync_geometryERN2BL9DepsgraphERNS1_6ObjectES5_bbPNS_8TaskPoolE+0x87b) [0x5586945517bb]
blender(_ZN3ccl11BlenderSync11sync_objectERN2BL9DepsgraphERNS1_9ViewLayerERNS1_23DepsgraphObjectInstanceEfbbRNS_20BlenderObjectCullingEPbPNS_8TaskPoolE+0xb77) [0x558694552a27]
blender(_ZN3ccl11BlenderSync12sync_objectsERN2BL9DepsgraphERNS1_11SpaceView3DEf+0x569) [0x558694554759]
blender(_ZN3ccl11BlenderSync9sync_dataERN2BL14RenderSettingsERNS1_9DepsgraphERNS1_11SpaceView3DERNS1_6ObjectEiiPPv+0x1f2) [0x558694503f22]
blender(_ZN3ccl14BlenderSession11synchronizeERN2BL9DepsgraphE+0x459) [0x558694513499]

It's a blocker for migrating our other machines, since we need the Cycles render engine.

Comment 11 jc-fas@neniam.net 2021-05-21 23:32:00 UTC
Of note: the blender console output errors of Apr 16 are there all the time, apparently unrelated.
So the crash.txt attachment seems to be the most relevant text.

One other possible useful tidbit: Same version (2.92), run via flatpak from flathub, does not crash in this way.

Comment 12 jc-fas@neniam.net 2021-05-21 23:38:54 UTC
Oh!  I just reproduced it on a laptop with Intel UHD graphics.

So this seems like a basic bug, not related to a particular graphics card.

Comment 13 jc-fas@neniam.net 2021-05-21 23:47:42 UTC
Uh, one more comment, sorry about the spam.

I think there are two separate bugs.  The original attached stdout is documenting a bug that is radeon specific.  It might be worthy of investigation, but doesn't cause a crash, and might not be important.

The original attached crash.txt is documenting a bug that is NOT radeon specific, and is more egregious.  Just imagine somebody switching to cycles rendering for a quick check after working for a while and then BOOM.  Forgot to save....  That would be painful--potentially a lot of lost work.

Comment 14 J. Bruce Fields 2021-05-23 01:49:26 UTC
For what it's worth, the segfault is 100% reproduceable for me with blender-2.92.0-5.fc34.x86_64, but does not reproduce at all with a binary downloaded from https://www.blender.org/download/Blender2.92/blender-2.92.0-linux64.tar.xz/.

Comment 15 Luya Tshimbalanga 2021-05-23 08:26:23 UTC
Something changed inside cycle rendering on Fedora 34 build. I don't know how yet.

Comment 16 Luya Tshimbalanga 2021-06-04 01:11:19 UTC
Blender 2.93 recently landed with a fix related to cycle. It seems the crashing cycle rendering is specific to 2.92.0. I successfully tested blender 2.93.0 which addressed the issue. For those willing to test right way, a scratch build is available: https://koji.fedoraproject.org/koji/taskinfo?taskID=69269842.

Comment 17 Fedora Update System 2021-06-04 08:59:42 UTC
FEDORA-2021-95e340dc3d has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-95e340dc3d

Comment 18 Fedora Update System 2021-06-05 01:09:42 UTC
FEDORA-2021-95e340dc3d has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-95e340dc3d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-95e340dc3d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2021-06-05 01:57:15 UTC
FEDORA-2021-ec68aa382b has been pushed to the Fedora 33 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-ec68aa382b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-ec68aa382b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 20 Fedora Update System 2021-06-13 01:19:53 UTC
FEDORA-2021-ec68aa382b has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2021-06-13 01:49:58 UTC
FEDORA-2021-95e340dc3d has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.