Bug 195240 - splitttree.py size calc fails for symlink'd files
Summary: splitttree.py size calc fails for symlink'd files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 197973 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-14 15:48 UTC by Bob Arendt
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 19:13:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix symlink file size issue (850 bytes, patch)
2006-06-14 15:48 UTC, Bob Arendt
no flags Details | Diff

Description Bob Arendt 2006-06-14 15:48:39 UTC
Description of problem:

I'm using anaconda-runtime-11.0.5-1 to respin fedora w/ updates.
It's much faster and disk-efficient to create the new Fedora/RPMS/
directory using symlinks to the original and update cache areas.

The existing version of splittree.py uses the link size instead of
the actual filesize.

Using "du -sL" instead of "du -s" corrects this.  I've attached a patch
that implements this.  du is from coreutils-5.96-1.2.

BTW: bugzilla doesn't have a "anaconda-runtime" category, so I'm
posting this against anaconda.

Comment 1 Bob Arendt 2006-06-14 15:48:40 UTC
Created attachment 130865 [details]
Patch to fix symlink file size issue

Comment 2 Jeremy Katz 2006-06-20 00:33:03 UTC
... splittree also needs to be integrated with createrepo/pkgorder changes.

Comment 3 Paul Nasrat 2006-06-26 19:13:54 UTC
Applied in rawhide so I don't loose in integration work

Comment 4 Jeremy Katz 2006-07-11 00:38:38 UTC
*** Bug 197973 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.