Bug 195249 - Sound starts reapeting.
Sound starts reapeting.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
NeedsRetesting
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-14 12:11 EDT by Victor Bogado
Modified: 2008-03-11 12:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 12:12:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci, cat /proc/interrupts and dmesg (18.29 KB, text/plain)
2006-06-14 12:11 EDT, Victor Bogado
no flags Details

  None (edit)
Description Victor Bogado 2006-06-14 12:11:07 EDT
Description of problem:
The sound sometimes starts to repeat it self uninterruptedly, after that the
rhythmbox app do not respond anymore. This happens after a time hearing sound,
and as far as I can tell is somewhat randomly.

My theory is that the kernel is loosing a interrupt and after that it blocks the
app until it get the now lost interruption. I also have noticed that sometimes
the eth0 stop working also, but this happen less often, it could be the same
problem. 

This machine has a HT intel processor, I tried with both hyper-threading enabled
and disabled and in both cases the sound started to gag. Since this did not
happened before, I suspect it is the fault of one of the new kernels. Now I am
using 2.6.16-1.2133_FC5 but the one before that also had problems.

I solved the problem in the earlier kernel using the option "acpi=ht" in the
grub.conf file. Also when the problem happened I checked the system log, but
there was no message in the time frame of the problem. 

I am attaching a file with lspci, cat /proc/interrupts and dmesg runned as root
in this machine where I am having the problem.
Comment 1 Victor Bogado 2006-06-14 12:11:07 EDT
Created attachment 130868 [details]
lspci, cat /proc/interrupts and dmesg
Comment 2 Dave Jones 2006-10-16 14:53:02 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 3 Victor Bogado 2006-10-30 08:38:24 EST
Hi, the new kernel has the same problem, I am not new to linux but I have little
experience in debugging the kernel, so I don't know how to extract good
information for you :-(. 

With the new kernel the work around of using "acpi=ht" does not work though I
get a kernel panic in the boot soon after grub runs the kernel. This happens
every time I boot with this options, but I don't know how to capture this
information. I took some "screen shots" of the error with my cell phone, but it
would take a long time to copy those into here, so if there is a better way to
get hold of this info or at least if you could tell me the most important info
that I should copy here. 

thanks
Comment 4 Victor Bogado 2006-11-06 13:00:04 EST
I am still having the same problem, I used the new FC5 kernel and it showed the
problem I described above and now I upgraded to FC6 and the problem persists. I
am trying to test if there is a way of getting it to work. 
Comment 5 Victor Bogado 2006-11-06 13:30:10 EST
I tested the following options with mixed results : 


irqfixup : The repetition starts and after this it goes into a state that it
keep repeting but the music advances, bit by bit in this anoying repetition.
irqpoll : seems to work. 
Comment 6 Victor Bogado 2008-03-11 12:12:57 EDT
This is not an issue anymore, I am using F8 and didn't even remembered those
problems. :-) 

Note You need to log in before you can comment on or make changes to this bug.