Bug 195274 - NAT-PT support
NAT-PT support
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: FutureFeature
: 323961 (view as bug list)
Depends On:
Blocks: 181490 OLPCTracker IPv6Blocker
  Show dependency treegraph
 
Reported: 2006-06-14 13:18 EDT by David Woodhouse
Modified: 2014-03-16 23:00 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-01 16:44:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-06-14 13:18:43 EDT
NAT-PT (protocol translation) provides a means for IPv6-only hosts to
communicate with the Legacy Internet. Our netfilter code doesn't yet support it.
Comment 1 David Miller 2006-06-14 19:32:24 EDT
Jeff and many others have voiced objections to any kind of NAT in the
context of IPV6.  IPV6 is our chance to disconnect ourselves from NAT
and all the problems it entails.

Maybe it doesn't apply here, for connection to legacy IPV4 from IPV6-only
hosts.
Comment 2 David Woodhouse 2006-06-14 19:43:41 EDT
Yeah, everybody hates NAT -- and rightly so, even in Legacy IP. 

NAT-PT is different.
Comment 3 Eric Hopper 2007-10-08 18:20:45 EDT
*** Bug 323961 has been marked as a duplicate of this bug. ***
Comment 4 Eric Hopper 2007-10-08 18:23:22 EDT
The proper component for this isn't the kernel, it's the distribution as a
whole. In fact, I doubt that fixing this will require any kernel modifications
at all.

As a starting point, I would suggest this package:

http://tomicki.net/naptd.php
Comment 5 Dave Jones 2008-03-24 15:04:17 EDT
That url is dead.

Is there any value to keeping this bug open ?   It's been sat open for a year
and half, with no activity.  Unless someone signs up to do the work, wishlist
bugs like this might as well just be closed out.
If the kernel needs something, CLOSED->UPSTREAM is likely the intended resolution.
If other parts of the distro needs integration work, then bugs should be filed
against those components instead.
Comment 6 Eric Hopper 2008-03-25 01:40:52 EDT
It's going to be at least a couple of years before support for this is really
relevant since most networks are going to be dual stack networks and use normal
NAT for IPv4 only hosts, but it would be good to be able to play with this now.

I could probably do it if someone wanted to fund me.  *big grin*
Comment 7 Mark McClelland 2008-05-06 03:55:13 EDT
The new URL for naptd is http://lucastomicki.net/naptd.php

There's even a package there for Fedora 4. It should be pretty easy to bring it
up to date and get it into Fedora. Unless one of you wants to that, just add it
to the package wish-list and close this bug.
Comment 8 Jeff Garzik 2008-05-06 06:02:32 EDT
Responding to comment #1, NAT-PT specifically is needed in order to permit
v6-only hosts to communicate with v4-only hosts.
Comment 9 Chuck Ebbert 2008-05-13 01:12:03 EDT
I added NAT-PT to the package wishlist. Changing component to distribution
instead of closing it since it blocks some other bugs...
Comment 10 Bug Zapper 2008-05-13 22:10:35 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Jon Stanley 2008-05-14 22:40:18 EDT
marking as RFE
Comment 12 Jon Stanley 2008-05-14 22:42:33 EDT
Also marking as ASSIGNED to get out of NEEDINFO, but there's really no
appropriate state for this bug in our limited options :(  Sorry for the spam.
Comment 14 Bill Nottingham 2008-12-01 16:44:21 EST
Closing this, barring a maintainer jumping up to do this.

Note You need to log in before you can comment on or make changes to this bug.