Bug 195439 - vfat corruption
vfat corruption
Status: CLOSED DUPLICATE of bug 195440
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-06-15 04:10 EDT by barry gould
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-15 12:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description barry gould 2006-06-15 04:10:55 EDT
Description of problem:
A VFAT partition which is mounted frequently gets corrupted after adding,
changing, or deleting files.

Version-Release number of selected component (if applicable):
and earlier, but not in FC4 AFAIK

How reproducible:

Steps to Reproduce:
1. copy, change, and/or delete files on a mounted vfat partition
2. run fsck or windows chkdsk to check for corruption.
Actual results:
fsck or chkdsk reports fs damage

the most common result is that deleted files end up as 'lost chains' according
to XP chkdsk,
however, I have had data loss on files edited by emacs, etc.

Expected results:

Additional info:
this is on a Dell D800 notebook, Pentium M, 1GB RAM, 100GB Seagate notebook HD.
note I have no swapfile or swap partition, period.

I have tried re-creating and re-formatting the partition; it hasn't made a

I am not having any problems with lockups or crashes.

I have not seen any problems with my ext3 partition, or my NTFS partition
(dual-boot winXP)
Note that the corruption happens even if I never boot XP.

Also note that deleting files from XP on the vfat partition works fine. Also, XP
chkdsk always fixes the problem (but data loss still occurs on the corrupted
files). I have not tried letting fsck fix the partition.
After fixing with chkdsk, both chkdsk and fsck say the partition is fine.

$ sudo fdisk -l /dev/hda

Disk /dev/hda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1        1460    11727418+  83  Linux
/dev/hda2   *        1462        2920    11719417+   7  HPFS/NTFS
/dev/hda3            2921       12161    74228332+   f  W95 Ext'd (LBA)
/dev/hda4            1461        1461        8032+  83  Linux
/dev/hda5            2921       12161    74228301    b  W95 FAT32

Partition table entries are not in disk order

Please let me know if additional information is needed.

Comment 1 barry gould 2006-06-15 12:51:25 EDT

*** This bug has been marked as a duplicate of 195440 ***

Note You need to log in before you can comment on or make changes to this bug.